From: louis john (west_coast@inbox.com)
Date: Mon Jun 25 2007 - 14:24:05 ART
Hi Blaine, Hi all
You bet, It is via PIM, I changed the joinging on F0/0 of R4 instead of L0 of R4,
Before filtering IGMP on F1/0/4 of SW2 , the result of show ip igmp member on R2 will be :
R2#show ip igmp mem
Channel/Group Reporter Uptime Exp. Flags Interface
*,224.0.1.40 130.1.24.4 00:00:07 02:52 2A Et1
*,229.1.1.5 130.1.24.4 00:00:01 02:58 2A Et1
*,229.1.1.4 130.1.24.4 00:00:02 02:57 2A Et1
*,229.1.1.6 130.1.24.4 00:00:06 02:53 2A Et1
*,229.1.1.1 130.1.24.4 00:07:15 02:54 2A Et1
*,229.1.1.3 130.1.24.4 00:07:16 02:58 2A Et1
*,229.1.1.2 130.1.24.4 00:07:16 02:54 2A Et1
After Appling the IP IGMP FILTER on F1/0/4 of SW2
IGMP Profile 10
permit
range 229.1.1.1 229.1.1.3
interface FastEthernet1/0/4
switchport access vlan 48
ip igmp filter 10
end
R2#clear ip igmp group
R2#show ip igmp mem
Channel/Group Reporter Uptime Exp. Flags Interface
*,229.1.1.1 130.1.24.4 00:00:08 02:51 2A Et1
*,229.1.1.3 130.1.24.4 00:00:07 02:52 2A Et1
*,229.1.1.2 130.1.24.4 00:00:05 02:54 2A Et1
But Again, Why R4 will join via PIM if I ping a denied group ? what is the purpose of filter IGMP then ?
I am confused like in the real world, is it enough to filter IGMP join or I should do something more such as filtering PIM.
I am gonna be glad if you explain the thought porcess in this context.
for example, on R2
R2#ping 229.1.1.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 229.1.1.5, timeout is 2 seconds:
Reply to request 0 from 130.1.24.4, 20 ms
Reply to request 0 from 130.1.24.4, 24 ms
R2# show ip mroute 229.1.1.5
(*, 229.1.1.5), 04:41:40/stopped, RP 150.1.2.2, flags: SJC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1, Forward/Sparse, 04:41:40/00:02:46
(130.1.24.2, 229.1.1.5), 00:00:35/00:02:24, flags: P
Incoming interface: Ethernet1, RPF nbr 0.0.0.0
Outgoing interface list: Null
(150.1.2.2, 229.1.1.5), 00:00:35/00:02:34, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1, Forward/Sparse, 00:00:36/00:03:21
> -----Original Message-----
> From: williams.blaine@gmail.com
> Sent: Mon, 25 Jun 2007 07:46:11 -0400
> To: west_coast@inbox.com
> Subject: Re: HOW IGMP PROFILE WORKS?
>
> Louis,
>
> Ip igmp profile filters IGMP membership reports. In this case, R4 is
> sending PIM joins to R2 not IGMP membership reports. Do a show ip
> igmp member on R2 and you probably won't see any of your groups listed
> under E0.
>
> If you want to test igmp filters, move your ip igmp join-groups to
> R4's Fa0/0 and turn off PIM on R4.
>
> Blaine W.
>
> On 6/25/07, louis john <west_coast@inbox.com> wrote:
>> Hi Group,
>>
>> I spent three hours trying to understand how IGMP PROFILE works without
>> any result, here is my scenarion :
>>
>> R2-E0----L3---F1/0/2---SW2---F1/0/4---L2--F0/0--R4
>>
>> R2 is the mapping agent and the RP for the groups 229.1.1.0/29
>>
>> Loopback 0 of R4 is joining the following groups:
>>
>> 229.1.1.1
>> 229.1.1.2
>> 229.1.1.3
>> 229.1.1.4
>> 229.1.1.5
>> 229.1.1.6
>> 229.1.1.7
>>
>> Scope :
>>
>> I want to permit only 229.1.1.1, 229.1.1.2, 229.1.1.3 to be Joined by
>> the Loopback 0 of R4. Though I configured THE IGMP PROFILE and applied
>> the IGMP filter under F1/0/4, still I can see all (*,G) flowing from R4
>> towards the RP which is R2. from R2 I can ping all the groups!
>>
>> I understood filtering of IGMP such that if any IGMP Membership report
>> sent to SW2 F1/0/4 then SW2 should filter this IGMP joining because of
>> the IGMP filter is applied under this interface.
>>
>> Also I was expecting not to see other than the first three groups on SW2
>> and R2.
>>
>>
>>
>> Here are my configuration :
>>
>>
>> R2
>> ip multicast-routing
>>
>> interface Loopback0
>> ip address 150.1.2.2 255.255.255.0
>> ip pim sparse-mode
>> !
>> !
>> interface Ethernet1
>> Description Connected to SW2 F1/0/2
>> ip address 130.1.28.2 255.255.255.0
>> ip pim sparse-mode
>> !
>> ip pim bsr-candidate Loopback0 0
>> ip pim rp-candidate Loopback0 group-list R2-GROUPS priority 50
>>
>> ip access-list standard R2-GROUPS
>> permit 229.1.1.0 0.0.0.7
>> !
>>
>>
>>
>>
>> R4
>> ip multicast-routing
>>
>> interface FastEthernet0/0
>> ip address 130.1.48.4 255.255.255.0
>> ip pim sparse-mode
>> speed auto
>> !
>> interface Loopback0
>> ip address 150.1.4.4 255.255.255.0
>> ip pim sparse-mode
>> ip igmp join-group 229.1.1.1
>> ip igmp join-group 229.1.1.2
>> ip igmp join-group 229.1.1.3
>> ip igmp join-group 229.1.1.4
>> ip igmp join-group 229.1.1.5
>> ip igmp join-group 229.1.1.6
>> ip igmp join-group 229.1.1.7
>>
>>
>>
>>
>> SW2
>>
>> ip multicast-routing
>>
>>
>> interface FastEthernet1/0/2
>> description Connected to R2 E1
>> no switchport
>> ip address 130.1.28.8 255.255.255.0
>> ip pim sparse-mode
>> !
>> ip igmp profile 10
>> permit
>> range 229.1.1.1 229.1.1.3
>> !
>> interface FastEthernet1/0/4
>> switchport access vlan 48
>> ip igmp filter 10
>> !
>> interface Vlan48
>> ip address 130.1.48.8 255.255.255.0
>> ip pim sparse-mode
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> On SW2
>>
>> SW2#show ip mroute
>> IP Multicast Routing Table
>> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
>> Connected,
>> L - Local, P - Pruned, R - RP-bit set, F - Register flag,
>> T - SPT-bit set, J - Join SPT, M - MSDP created entry,
>> X - Proxy Join Timer Running, A - Candidate for MSDP
>> Advertisement,
>> U - URD, I - Received Source Specific Host Report,
>> Z - Multicast Tunnel, z - MDT-data group sender,
>> Y - Joined MDT-data group, y - Sending to MDT-data group
>> Outgoing interface flags: H - Hardware switched, A - Assert winner
>> Timers: Uptime/Expires
>> Interface state: Interface, Next-Hop or VCD, State/Mode
>>
>> (*, 229.1.1.1), 00:01:04/00:03:25, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:04/00:03:25
>>
>> (*, 229.1.1.3), 00:01:06/00:03:22, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:06/00:03:22
>>
>> (*, 229.1.1.2), 00:01:10/00:03:19, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:10/00:03:19
>>
>> (*, 229.1.1.5), 00:01:04/00:03:24, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:04/00:03:24
>>
>> (*, 229.1.1.4), 00:00:59/00:03:29, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:00/00:03:29
>>
>> (*, 229.1.1.7), 00:01:02/00:03:26, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:02/00:03:26
>>
>> (*, 229.1.1.6), 00:01:05/00:03:23, RP 150.1.2.2, flags: S
>> Incoming interface: FastEthernet1/0/2, RPF nbr 130.1.28.2
>> Outgoing interface list:
>> Vlan48, Forward/Sparse, 00:01:05/00:03:23
>>
>> (*, 224.0.1.40), 00:01:47/00:02:37, RP 0.0.0.0, flags: DCL
>> Incoming interface: Null, RPF nbr 0.0.0.0
>> Outgoing interface list:
>> FastEthernet1/0/2, Forward/Sparse, 00:01:47/00:02:37
>>
>>
>>
>>
>>
>>
>> ON R1
>>
>> SW2#SHOW IP igmp profile
>> IGMP Profile 10
>> permit
>> range 229.1.1.1 229.1.1.3
>>
>>
>> SW2#SHOW IP igmp filter
>> IGMP filter enabled
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Jul 01 2007 - 17:24:51 ART