From: Kamal Dissanayaka (kamalasiri@gmail.com)
Date: Wed Jun 20 2007 - 10:22:45 ART
Hi Alexi,
Many thans for your help,
It is difficult to find a issue in this config only difference is I am
having a nested policy. I had similar match-any with all class-maps in qos
policy had to move to same match clause (like match ip dscp cs4 af41) get it
matched.
see below my config.
class-map match-any MM-LOW
match ip dscp cs4
match ip dscp af41
match ip dscp af42
match ip dscpcs6
.
.
snipped
!
!
policy-map WAN-QoS
.
.
class MM-LOW
bandwidth remaining percent 40
random-detect dscp-based
.
.
snipped
policy-map WAN-UPLINK
class class-default
shape average 2048000
service-policy WAN-QoS
interface GigabitEthernet0/0
service-policy output WAN-UPLINK
I will try simplified config and let you know the results tommorow
Thanks again,
Kamal
On 6/20/07, Alexei Monastyrnyi <alexeim@orcsoftware.com> wrote:
>
> Kamal,
>
> I have done some quick labbing around your example and it seems to work
> fine for me.
>
> R2 e0/0 - e0/0 R1 S0/0 -FR- S0/0 R3 e0/0 -
>
> R1 marks all traffic from R2 with ip dscp af42 inbound on e0/0 interface
> and marks traffic that matches your class-map with fr-de bit outbound on
> s0/0.
>
> Now if we have a small eigrp routing domain between R1 R2 and R3 and
> ping R3 e0/0 from R2 (via R1), that ICMP traffic is marked alright with
> ip dscp af42 first and then fr-de bit adds.
>
> I used 2611 routers with c2600-j1s3-mz.123-20 on board. You most
> probably missing something in your config...
>
> === config on R1
>
> class-map match-any MM-LOW
> match ip dscp af41
> match ip dscp cs4
> match ip dscp af42
> match ip dscp cs6
> !
> !
> policy-map test-dscp
> class MM-LOW
> set fr-de
> policy-map set-dscp
> class class-default
> set ip dscp af42
> !
> !
> !
> !
> interface Ethernet0/0
> dampening
> ip address 10.1.1.1 255.255.255.0
> no ip proxy-arp
> half-duplex
> service-policy input set-dscp
> !
> interface Serial0/0
> description ---> DLCI 102 103 104 105 106 <---
> ip address 10.1.0.1 255.255.255.0
> encapsulation frame-relay
> clock rate 1000000
> frame-relay map ip 10.1.0.3 103 broadcast
> no frame-relay inverse-arp
> service-policy output test-dscp
>
> === output on R1
>
> R1#clear counters ser 0/0
> Clear "show interface" counters on this interface [confirm]
> R1#clear counters ser 0/0
> R1#sh policy-map in ser 0/0
>
> Serial0/0
>
> Service-policy output: test-dscp
>
> Class-map: MM-LOW (match-any)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: ip dscp af41 (34)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: ip dscp cs4 (32)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: ip dscp af42 (36)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: ip dscp cs6 (48)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> QoS Set
> fr-de
> Packets marked 0
>
> Class-map: class-default (match-any)
> 1 packets, 14 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
>
> === output on R2
>
> R2(config-router)#do sh ip route | in 192.168.200.
> D 192.168.200.0/24 [90/2198016] via 10.1.1.1, 00:21:43, Ethernet0/0
> R2(config-router)#do ping 192.168.200.3
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 192.168.200.3, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 4/7/8 ms
>
> === output on R1
>
> R1#sh policy-map in ser 0/0
>
> Serial0/0
>
> Service-policy output: test-dscp
>
> Class-map: MM-LOW (match-any)
> 5 packets, 520 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: ip dscp af41 (34)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: ip dscp cs4 (32)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> Match: ip dscp af42 (36)
> 5 packets, 520 bytes
> 5 minute rate 0 bps
> Match: ip dscp cs6 (48)
> 0 packets, 0 bytes
> 5 minute rate 0 bps
> QoS Set
> fr-de
> Packets marked 5
>
> Class-map: class-default (match-any)
> 3 packets, 42 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
>
> A.
>
> on 6/20/2007 12:19 PM Kamal Dissanayaka wrote:
> > Hi Alexi,
> >
> > Thanks for your help.
> >
> >
> > It is 2821 & bellow is the version
> >
> > Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version
> > 12.4(11)XV,
> > RELEASE SOFTWARE (fc3)
> > Synched to technology version 12.4(11.3)T
> >
> > do both class-maps ( in my first mail) should perform same function ?
> >
> > Best Regards
> >
> > Kamal
> >
> >
> > On 6/20/07, Alexei Monastyrnyi <alexeim@orcsoftware.com> wrote:
> >>
> >> Kamal,
> >> which platform/IOS version you're on?
> >>
> >> A.
> >>
> >> on 6/20/2007 1:47 AM Kamal Dissanayaka wrote:
> >> > Dear all,
> >> >
> >> > Can somebody expalin me about bellow two class-map configs need to
> >> perform
> >> > same or different functions ? Policy-map is applied on on egress of
> a
> >> WAN
> >> > link.
> >> >
> >> > 1. class-map match-any MM-LOW
> >> > match ip dscp af41
> >> > match ip dscp cs4
> >> > match ip dscp af42
> >> > match ip dscp cs6
> >> >
> >> > With this config there is no matches on this class map and all goes
> >> through
> >> > default-class see the out put bellow , I get confirmed with access
> >> list
> >> > there are packets comming with dscp cs6.
> >> >
> >> > Class-map: MM-LOW (match-any)
> >> > 0 packets, 0 bytes
> >> > 30 second offered rate 0 bps, drop rate 0 bps
> >> > Match: ip dscp af41 (34)
> >> > 0 packets, 0 bytes
> >> > 30 second rate 0 bps
> >> > Match: ip dscp cs4 (32)
> >> > 0 packets, 0 bytes
> >> > 30 second rate 0 bps
> >> > Match: ip dscp af42 (36)
> >> > 0 packets, 0 bytes
> >> > 30 second rate 0 bps
> >> > Match: ip dscp cs6 (48)
> >> > 0 packets, 0 bytes
> >> > 30 second rate 0 bps
> >> > Queueing
> >> > Output Queue: Conversation 137
> >> > Bandwidth remaining 40 (%)Max Threshold 64 (packets)
> >> > (pkts matched/bytes matched) 0/0
> >> > (depth/total drops/no-buffer drops) 0/0/0
> >> >
> >> > 2. class-map match-any MM-LOW
> >> > match ip dscp cs4 af41 af42 cs6
> >> >
> >> > When I configure the class-map in this way it matches the packet. see
> >> the
> >> > out put bellow,
> >> >
> >> > Class-map: MM-LOW (match-any)
> >> > 187 packets, 168760 bytes
> >> > 30 second offered rate 22000 bps, drop rate 0 bps
> >> > Match: ip dscp cs4 (32) af41 (34) af42 (36) cs6 (48)
> >> > 0 packets, 0 bytes
> >> > 30 second rate 0 bps
> >> > Queueing
> >> > Output Queue: Conversation 137
> >> > Bandwidth remaining 40 (%)Max Threshold 64 (packets)
> >> > (pkts matched/bytes matched) 0/0
> >> > (depth/total drops/no-buffer drops) 0/0/0
> >> >
> >> >
> >> > Best Regards
> >> >
> >> > Kamal
> >> >
> >> >
> _______________________________________________________________________
> >> > Subscription information may be found at:
> >> > http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Jul 01 2007 - 17:24:50 ART