Re: REDISTRIBUTE--------OSPF to RIP

From: NITIN NITIN (ccie_study_123@yahoo.com)
Date: Sat May 12 2007 - 18:31:42 ART


HI ,
   
  Configs of the routers------
  
Configs of the router are
  Rack1R2#sh running-config
Building configuration...
  Current configuration : 2375 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
ip multicast-routing
ipv6 unicast-routing
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Tunnel25
 ip address 141.1.25.2 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 141.1.0.5
 no clns route-cache
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
 ip pim sparse-mode
 no clns route-cache
!
interface Ethernet0/0
 ip address 141.1.0.2 255.255.255.0<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
 ip pim sparse-mode
 ipv6 address 2001:141:1:25::2/64
 ipv6 ospf 1 area 1
 no clns route-cache
!
interface Ethernet1/0
 no ip address
 shutdown
 no clns route-cache
!
interface Serial2/0
 ip address 141.1.123.2 255.255.255.0
 ip pim nbma-mode
 ip pim sparse-mode
 encapsulation frame-relay
 ipv6 address 2001:141:1:12::2/64
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 1
 serial restart-delay 0
 frame-relay map ipv6 FE80::A8BB:CCFF:FE02:2700 201 broadcast
 frame-relay map ipv6 2001:141:1:12::1 201 broadcast
 frame-relay map ip 141.1.123.1 201 broadcast
 frame-relay map ip 141.1.123.3 203 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 no clns route-cache
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 1 nssa no-summary
 network 141.1.0.2 0.0.0.0 area 1<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
 network 141.1.25.2 0.0.0.0 area 0
 network 141.1.123.2 0.0.0.0 area 0
 network 150.1.2.2 0.0.0.0 area 0
 neighbor 141.1.123.3
 neighbor 141.1.123.1
!
ip classless
no ip http server
!
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 18
ip mroute 150.1.5.5 255.255.255.255 141.1.0.5
ip mroute 141.1.145.4 255.255.255.255 141.1.0.5
!
!
access-list 18 permit 225.0.0.0 0.255.255.255
ipv6 router ospf 1
 log-adjacency-changes
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 password cisco
 login
line vty 0 4
 no login
!
!
end
  Rack1R2#
   
   
   
   
  
Rack1R3#sh running-config
Building configuration...
  Current configuration : 2021 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
ip multicast-routing
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
 no clns route-cache
!
interface Ethernet0/0
 ip address 141.1.36.3 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 239.39.39.39
 no clns route-cache
!
interface Ethernet1/0
 ip address 141.1.37.3 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 225.25.25.25
 no clns route-cache
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay lmi-type cisco
 no clns route-cache
!
interface Serial2/0.1 point-to-point
 ip address 141.1.123.3 255.255.255.0
 ip pim sparse-mode
 ip ospf network non-broadcast
 ip ospf priority 0
 frame-relay interface-dlci 302
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial4/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial5/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial6/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
interface Serial7/0
 no ip address
 shutdown
 serial restart-delay 0
 no clns route-cache
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 redistribute rip subnets
 network 141.1.123.3 0.0.0.0 area 0
 network 150.1.3.3 0.0.0.0 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 2<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Ethernet1/0
 network 141.1.0.0
 no auto-summary
!
!
ip classless
no ip http server
!
ip pim autorp listener
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
  Rack1R3#
   
  
Rack1R6#sh running-config
Building configuration...
  Current configuration : 1499 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
 no clns route-cache
!
interface Ethernet0/0
 ip address 141.1.36.6 255.255.255.0
 no clns route-cache
!
interface Ethernet1/0
 ip address 141.1.6.6 255.255.255.0
 no clns route-cache
!
interface Serial2/0
 no ip address
 shutdown
 no fair-queue
 serial restart-delay 0
 no clns route-cache
!
interface Serial3/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 54.1.1.254 101 broadcast
 no frame-relay inverse-arp
 no clns route-cache
!
router rip
 version 2
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Serial3/0
 offset-list 44 in 9 Serial3/0
 network 54.0.0.0
 network 141.1.0.0
 network 150.1.0.0
 no auto-summary
!
ip classless
no ip http server
!
!
!
access-list 44 permit 0.0.0.0 255.255.254.255
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
!
end
  Rack1R6#
   
   
   
  ==========================================================================================
Rack1R2# sh ip route | i 141.1.0.0
     141.1.0.0/24 is subnetted, 13 subnets
C 141.1.0.0 is directly connected, Ethernet0/0
   
   
   
  Rack1R3# sh ip route | i 141.1.0.0
     141.1.0.0/24 is subnetted, 13 subnets
O IA 141.1.0.0 [110/74] via 141.1.123.2, 00:00:18, Serial2/0.1
   
  Rack1R3#sh ip rip database | i 141.1.0.0
141.1.0.0/16 auto-summary
141.1.0.0/24 redistributed
   
   
  
Rack1R6# sh ip route 141.1.0.0 255.255.255.0
% Subnet not in table
   
   
  Regards

NITIN NITIN <ccie_study_123@yahoo.com> wrote: Hi Group,
  I'm facing a issue while redistributing OSPF to RIP
  
(141.1.0.0/24 OSPF NETWORK)R2-----OSPF PROTOCOL (141.1.123.0/24)-----R3---(141.1.36.0)(RIP PROTOCOL) ----R6
  
Rack1R3#sh ip route ospf
     51.0.0.0/32 is subnetted, 1 subnets
O E2 51.51.51.51 [110/20] via 141.1.123.1, 00:02:53, Serial2/0.1
O E2 204.12.1.0/24 [110/100] via 141.1.123.2, 00:02:53, Serial2/0.1
     141.1.0.0/24 is subnetted, 13 subnets
O IA 141.1.145.0 [110/11185] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.255.0 [110/84] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.8.0 [110/84] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.0.0 [110/74] via 141.1.123.2, 00:02:53, Serial2/0.1<<<<<<<<<<<<<<<<<<I HAVE THIS N/W on R3
O 141.1.25.0 [110/11175] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.45.0 [110/11239] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.54.0 [110/11185] via 141.1.123.2, 00:02:53, Serial2/0.1
O IA 141.1.88.0 [110/84] via 141.1.123.2, 00:02:53, Serial2/0.1
  
Rack1R3#sh ip route 141.1.0.0 255.255.255.0
Routing entry for 141.1.0.0/24
  Known via "ospf 1", distance 110, metric 74, type inter area
  Redistributing via rip
  Advertised by rip metric 2
  Last update from 141.1.123.2 on Serial2/0.1, 00:04:55 ago
  Routing Descriptor Blocks:
  * 141.1.123.2, from 150.1.2.2, 00:04:55 ago, via Serial2/0.1
      Route metric is 74, traffic share count is 1
   
  
BUT R3 I REDISTRIBUTE OSPF TO RIP -------
  router rip
 version 2
 redistribute ospf 1 metric 2
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Ethernet1/0
 network 141.1.0.0<<<<<<<<<<<<<<<<<<
 no auto-summary
!
   
  Rack1R6#sh ip route 141.1.0.0
Routing entry for 141.1.0.0/24, 12 known subnets
  Attached (1 connections)
  Redistributing via rip
  R 141.1.145.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.255.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.8.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.7.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.25.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.45.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
C 141.1.36.0 is directly connected, Ethernet0/0
R 141.1.37.0 [120/1] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.54.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.77.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.88.0 [120/2] via 141.1.36.3, 00:00:18, Ethernet0/0
R 141.1.123.0 [120/1] via 141.1.36.3, 00:00:18, Ethernet0/0
Rack1R6#sh ip route 141.1.0.0 255.255.255.0
% Subnet not in table
  
BUT R6 doesn't have the specific N/W 141.1.0.0/24
  Please suggest why such behaviour.
  Please do let me know if the info provided BY ME IS NOT SUFFICIENT AND WHAT ELSE REQUIRED.
   
  Thanks and Regards

    
---------------------------------
  Bored stiff? Loosen up...
Download and play hundreds of games for free on Yahoo! Games.

       
---------------------------------
Get the Yahoo! toolbar and be alerted to new email wherever you're surfing.
       
---------------------------------
Got a little couch potato?
Check out fun summer activities for kids.



This archive was generated by hypermail 2.1.4 : Fri Jun 01 2007 - 06:55:20 ART