From: Henk de Tombe (henk.de.Tombe@qi.nl)
Date: Mon Apr 23 2007 - 10:06:24 ART
Hi,
I've pasted your configs in two routers and It's works fine:
R1#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.1.0.0/24 is subnetted, 4 subnets
C 172.1.1.0 is directly connected, Loopback2
C 172.1.0.0 is directly connected, Loopback1
C 172.1.3.0 is directly connected, Loopback4
C 172.1.2.0 is directly connected, Loopback3
150.50.0.0/24 is subnetted, 1 subnets
C 150.50.17.0 is directly connected, FastEthernet0/0
R1#
R1#sh ip rip data
150.50.0.0/16 auto-summary
150.50.17.0/24 directly connected, FastEthernet0/0
172.1.0.0/16 auto-summary
172.1.0.0/22 int-summary
172.1.0.0/24 directly connected, Loopback1
172.1.1.0/24 directly connected, Loopback2
172.1.2.0/24 directly connected, Loopback3
172.1.3.0/24 directly connected, Loopback4
R2#sh ver | i IOS
Cisco IOS Software, 7200 Software (C7200-ADVIPSERVICESK9-M), Version
12.4(9)T, RELEASE SOFTWARE (fc1)
R2#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.1.0.0/22 is subnetted, 1 subnets
R 172.1.0.0 [120/1] via 150.50.17.1, 00:00:00, FastEthernet0/0
150.50.0.0/24 is subnetted, 1 subnets
C 150.50.17.0 is directly connected, FastEthernet0/0
R2#
R2#
R2#sh ip rip data
150.50.0.0/16 auto-summary
150.50.17.0/24 directly connected, FastEthernet0/0
172.1.0.0/16 auto-summary
172.1.0.0/22
[1] via 150.50.17.1, 00:00:09, FastEthernet0/0
Regards,
Henk
Met vriendelijke groet,
Q&I
Henk de Tombe
Network Engineer
Q&I NEDERLAND BV
Delftech Park 35 - 37
P.O. Box 402 - 2600 AK DELFT
Phone [+31] 15-8880444 - Fax [+31] 15-8880445
info@qi.nl - www.qi.nl
-----Oorspronkelijk bericht-----
Van: nobody@groupstudy.com [mailto:nobody@groupstudy.com] Namens Phuong
Nguyen Van
Verzonden: maandag 23 april 2007 13:55
Aan: ccielab@groupstudy.com
Onderwerp: RIPv2 summary-address problem.
Hi GS,
I have problem with summary-address in RIPv2. I have 2 scenarios here:
*[1]*
My topology: R1 (f0/0) connect directly to R2 (Fa0/0), 2 routers run
only
RIPv2 (send & receive) with no auto-summary.
I want to summary all loopback addresses on R1 in to one entry and
advertises it to R2; so, my configuration like this:
**
*R1*
!
*interface Loopback1
ip address 172.1.0.1 255.255.255.0
!
interface Loopback2
ip address 172.1.1.1 255.255.255.0
!
interface Loopback3
ip address 172.1.2.1 255.255.255.0
!
interface Loopback4
ip address 172.1.3.1 255.255.255.0
!
interface FastEthernet0/0
description To R2
ip address 150.50.17.1 255.255.255.0
no ip split-horizon
ip summary-address rip 172.1.0.0 255.255.252.0
!
router rip
version 2
network 150.50.0.0
network 172.1.0.0
no auto-summary
! *
------------------------------
*R2
**!
interface FastEthernet0/0
description To R1
ip address 150.50.17.2 255.255.255.0
!
!
router rip
version 2
network 150.50.0.0
no auto-summary
!*
On R1:
R1#sh ip rip database
...
150.50.17.0/24 directly connected, FastEthernet0/0
172.1.0.0/16 auto-summary
*172.1.0.0/22 int-summary*
172.1.0.0/24 directly connected, Loopback1
172.1.1.0/24 directly connected, Loopback2
172.1.2.0/24 directly connected, Loopback3
172.1.3.0/24 directly connected, Loopback4
...
R1#debug ip rip database
RIP database events debugging is on
R1#
*Mar 1 01:53:37.279: *RIP-ERROR: summary route 172.1.0.0/22 not in
routing
table.*
-> The result is: R1 doesn't advertise the summary-address to R2; what
is
the problem here? What are mistakes in this configuration?
[2]
The topology like in [1]. I don't use command ip summary-address
anymore, I
add a route entry to null0.
**
*R1*
*!
interface FastEthernet0/0
description To R2
ip address 150.50.17.1 255.255.255.0
! *
*router rip
version 2
network 150.50.0.0
network 172.1.0.0
no auto-summary
! *
*ip route 172.1.0.0 255.255.252.0 null0*
------------------------------
*R2
**!
interface FastEthernet0/0
description To R1
ip address 150.50.17.2 255.255.255.0
!
router rip
version 2
network 150.50.0.0
no auto-summary
!*
**
-The result is: R2 has route 172.1.0.0/22 in routing table
R2# sh ip route rip
172.1.0.0/22 is subnetted, 1 subnets
*R 172.1.0.0 [120/1] via 150.50.17.1, 00:00:21, FastEthernet0/0*
--> As I know the *network *command in RIP is to enable RIP on
interfaces.
What should I understand in this scenario?
Can anyone help me? Thanks in advance.
Phuong
This archive was generated by hypermail 2.1.4 : Tue May 01 2007 - 08:28:37 ART