Re: Challenge

From: maureen schaar (maureen.schaar@gmail.com)
Date: Fri Mar 23 2007 - 19:17:30 ART


Do not advertise the tunnel address into ospf. Use a local policy
route-map to send the trace traffic over the tunnel. In your case:

R3
interface Tunnel0
 ip unnumbered Loopback0
 tunnel source 10.10.23.x
 tunnel destination 10.10.12.x

router ospf 1
 passive-interface Tunnel 0

route-map LOCAL permit 10
 match ip address VIA-TUNNEL
 set interface Tunnel0
!
route-map LOCAL permit 20

ip access-list extended VIA-TUNNEL
 permit ip host 10.10.23.3 host 10.10.1.1 (should be more specific
only matching the udp trace traffic)

ip local policy route-map LOCAL

R1 --> tunnel back. For traffic to flow symmetrically, also use local
policy route-map here.

Not pretty, but it works....

Otherwise you would have to find a way to advertise the tunnel
addresses over a different routing protocol.

Maureen

On 3/23/07, Antonio Soares <amsoares@netcabo.pt> wrote:
> Hello Tony,
>
> Yes, but there is the Recursive Routing problem with OSPF... And since you
> are not allowed to add ip addresses or static routes... Please try to solve
> this, it's funny :)
>
> Thanks.
> Antonio
>
> -----Original Message-----
> From: Tony Schaffran [mailto:groupstudy@cconlinelabs.com]
> Sent: sexta-feira, 23 de Margo de 2007 14:08
> To: 'Antonio Soares'; ccielab@groupstudy.com
> Subject: RE: Challenge
>
> Am I missing something here?
>
> Would a GRE tunnel from loopback to loopback give you the desired results?
>
>
> Tony Schaffran
> Network Analyst
> CCIE #11071
> CCNP, CCNA, CCDA,
> NNCDS, NNCSS, CNE, MCSE
>
> www.cconlinelabs.com
> Your #1 choice for online Cisco rack rentals.
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Antonio Soares
> Sent: Friday, March 23, 2007 6:29 AM
> To: ccielab@groupstudy.com
> Subject: RE: Challenge
>
> Hello GS,
>
> I forgot to add one resctiction: you cannot add ip addressing.
>
> Any takers ? I found this very interesting and challenging.
>
>
> Thanks.
> Antonio
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Antonio Soares
> Sent: sexta-feira, 23 de Margo de 2007 1:21
> To: ccielab@groupstudy.com
> Subject: Challenge
>
> Dear GS,
>
> I have an interesting challenge for you. Given the setup and configurations
> bellow, you are allowed to configure a tunnel between R1 and R3. You need to
> reach 10.10.1.1 from R3 in just one hop.
>
> ++++++++++++++++++++++++++++++++++++++++++++++++
> Original Output:
> ++++++++++++++++++++++++++++++++++++++++++++++++
> R3#trace 10.10.1.1
>
> Type escape sequence to abort.
> Tracing the route to 10.10.1.1
>
> 1 10.10.23.2 16 msec 16 msec 16 msec
> 2 10.10.12.1 32 msec * 28 msec
> R3#
>
> ++++++++++++++++++++++++++++++++++++++++++++++++
> Required Output:
> ++++++++++++++++++++++++++++++++++++++++++++++++
> R3#trace 10.10.1.1
>
> Type escape sequence to abort.
> Tracing the route to 10.10.1.1
>
> 1 xxx.xxx.xxx.xxx 44 msec * 44 msec
> R3#
> ++++++++++++++++++++++++++++++++++++++++++++++++
>
>
> ++++++++++++++++++++++++++++++++++++++++++++++++
> Setup and Configurations:
> ++++++++++++++++++++++++++++++++++++++++++++++++
> (Area 0)===R1===(Area 12)===R2===(Area 0)===R3===(Area 0)
> ++++++++++++++++++++++++++++++++++++++++++++++++
> R1:
> !
> interface Loopback0
> ip address 10.10.1.1 255.255.255.0
> !
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0/0.12 point-to-point
> ip address 10.10.12.1 255.255.255.0
> frame-relay interface-dlci 102
> !
> router ospf 1
> router-id 10.10.1.1
> log-adjacency-changes
> area 12 virtual-link 10.10.2.2
> network 10.10.1.1 0.0.0.0 area 0
> network 10.10.12.1 0.0.0.0 area 12
> !
> ++++++++++++++++++++++++++++++++++++++++++++++++
> R2:
> !
> interface Loopback0
> ip address 10.10.2.2 255.255.255.0
> !
> interface Serial0/0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0/0.12 point-to-point
> ip address 10.10.12.2 255.255.255.0
> frame-relay interface-dlci 201
> !
> interface Serial0/0.23 point-to-point
> ip address 10.10.23.2 255.255.255.0
> frame-relay interface-dlci 203
> !
> router ospf 1
> router-id 10.10.2.2
> log-adjacency-changes
> area 12 virtual-link 10.10.1.1
> network 10.10.12.2 0.0.0.0 area 12
> network 10.10.23.2 0.0.0.0 area 0
> !
> ++++++++++++++++++++++++++++++++++++++++++++++++
> R3:
> !
> interface Loopback0
> ip address 10.10.3.3 255.255.255.0
> !
> interface Serial1/0
> no ip address
> encapsulation frame-relay
> !
> interface Serial1/0.23 point-to-point
> ip address 10.10.23.3 255.255.255.0
> frame-relay interface-dlci 302
> !
> router ospf 1
> router-id 10.10.3.3
> log-adjacency-changes
> network 10.10.3.3 0.0.0.0 area 0
> network 10.10.23.3 0.0.0.0 area 0
> !
> ++++++++++++++++++++++++++++++++++++++++++++++++
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:52 ART