Redistibute Connected then Additional Redistibution

From: Antonio Soares (amsoares@netcabo.pt)
Date: Sun Mar 18 2007 - 19:24:54 ART


Dear GS,

Suppose this base configuration:

!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 204.12.1.3 255.255.255.0
!
interface Ethernet0/1
 ip address 183.1.39.3 255.255.255.0
!
interface Serial1/0
 ip address 183.1.123.3 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 183.1.0.3 255.255.255.0
 encapsulation frame-relay
 no frame-relay inverse-arp
!
router eigrp 100
 network 183.1.123.3 0.0.0.0
 no auto-summary
 eigrp router-id 150.1.3.3
!
router ospf 1
 router-id 150.1.3.3
 network 150.1.3.3 0.0.0.0 area 0
 network 183.1.0.3 0.0.0.0 area 0
!

1) Then you are asked to redistribute E0/0 and E0/1 into EIGRP:

!
route-map conn2eigrp permit 10
 match interface Ethernet0/1 Ethernet0/0
!
!
router eigrp 100
 redistribute connected route-map conn2eigrp
 network 183.1.123.3 0.0.0.0
 no auto-summary
 eigrp router-id 150.1.3.3
!

2) The you are asked to redistribute OSPF into EIGRP:

!
router eigrp 100
 redistribute connected route-map conn2eigrp
 redistribute ospf 1 metric 10000 100 255 1 1500
 network 183.1.123.3 0.0.0.0
 no auto-summary
 eigrp router-id 150.1.3.3
!

3) Now the problem:

Loopback0 and Serial1/1 are running OSPF but they won't be redistributed
into EIGRP. This is because we are only redistributing connected interfaces
Ethernet0/0 and Ethernet0/1.

Should we always reconfigure our route-map in order to have them
redistributed like this:

!
route-map conn2eigrp permit 10
 match interface Ethernet0/1 Ethernet0/0 Serial1/1 Loopback0
!

Or if nothing is said about Optimal Routing/Redundancy, we shouldn't care
about it ?

Thanks.
Antonio



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:51 ART