Re: Help for trunking with dynamips and IEv4

From: gwendel@gregw.biz
Date: Sun Mar 04 2007 - 23:52:51 ART


The only way I have found to get this working correctly is to only use one
NM-16ESW module. I tested with a basic configuration and even using more
Ram and NVRAM whenever I used the second module I couldn't do any
trunking.

Here is the basic net file I used:

###############################################################################
#
# Internetwork Expert Routing & Switching topology mappings for
dynamips//dynagen
# by: Brian McGahan, CCIE #8593
# bmcgahan@internetworkexpert.com
#
# For more information:
# Dynamips: http://www.ipflow.utc.fr/index.php/Cisco_7200_Simulator
# /dynagen: http://dyna-gen.sourceforge.net/
# Hacki.s Forum: http://hacki.at/7200emu/index.php
# Internetwork Expert's Forum: http://forum.internetworkexpert.com
#
###############################################################################

##################################################
#
# Define global router parameters for instance 1
#
##################################################

autostart = False
[xxx.xxx.105.36:7200]
    udp = 8000 # Change the base udp port to 11000 (the default is 10000)

    workingdir = /dynagen/intexpert/working

    [[3640]]
        #
        # Specify 3640 IOS image on Windows here:
        #
        # Specify 3640 IOS image on Linux here:
        image = /dynagen/images/c3640.extracted.bin
        #image = /ios/c3640-jk9o3s-mz.123-14.T7.extracted.bin
        #
        ram = 128
        disk0 = 0
        disk1 = 0
        # Choose an idlepc value from the below
        idlepc = 0x629953d8
                mmap = True

    ###########################
    #
    # Define router instances
    #
    ###########################

    [[Router R1]]
        model = 3640
        autostart = False
        slot0 = NM-1FE-TX
        slot1 = NM-4T
        F0/0 = SW1 F1/1
        S1/0 = FRSW 1
        #cnfg = /dynagen/intexpert/initial.config/R1.initial.config.txt

    [[Router R2]]
        model = 3640
        autostart = False
        slot0 = NM-1FE-TX
        slot1 = NM-4T
          F0/0 = SW2 F1/2
        S1/0 = FRSW 2
        #cnfg = /dynagen/intexpert/initial.config/R2.initial.config.txt

    [[Router R3]]
        model = 3640
        autostart = False
# slot0 = NM-4E
        slot0 = NM-1FE-TX
        slot1 = NM-4T
        slot2 = NM-1FE-TX

        S1/0 = FRSW 3
        S1/1 = FRSW 13
        S1/2 = R1 S1/1
        S1/3 = R2 S1/1
        F0/0 = SW1 F1/3
        F2/0 = SW3 F1/3
        #cnfg = /dynagen/intexpert/initial.config/R3.initial.config.txt

    [[Router R4]]
        model = 3640
        autostart = False
# slot0 = NM-4E
        slot0 = NM-1FE-TX
        slot1 = NM-4T
          slot2 = NM-1FE-TX

        F0/0 = SW2 F1/4
        F2/0 = SW4 F1/4
        S1/0 = FRSW 4
        S1/1 = R5 S1/1
        #cnfg = /dynagen/intexpert/initial.config/R4.initial.config.txt

    [[Router R5]]
        model = 3640
        autostart = False
        slot0 = NM-1FE-TX
        slot1 = NM-4T
          slot2 = NM-1FE-TX
        F0/0 = SW1 F1/5
        F2/0 = SW3 F1/5

        #E0/0 = SW1 F1/5
      # E0/1 = SW2 F1/5
        S1/0 = FRSW 5
        #cnfg = /dynagen/intexpert/initial.config/R5.initial.config.txt

    [[Router R6]]
        model = 3640
        autostart = False
        slot0 = NM-1FE-TX
      slot1 = NM-4T
        slot2 = NM-1FE-TX
        F0/0 = SW2 F1/6
      F2/0 = SW4 F1/6

 # E0/0 = SW1 F1/6
 # E0/1 = SW2 F1/6
        S1/0 = FRSW 6

        #cnfg = /dynagen/intexpert/initial.config/R6.initial.config.txt

    [[Router SW1]]
        model = 3640
        autostart = False
        slot1 = NM-16ESW
        F1/7 = SW2 F1/7
        F1/8 = SW2 F1/8
        F1/9 = SW2 F1/9
        F1/10 = SW3 F1/7
        F1/11 = SW3 F1/8
        F1/12 = SW3 F1/9
          F1/13 = SW4 F1/7
        F1/14 = SW4 F1/8
        F1/15 = SW4 F1/9

        #cnfg = /dynagen/intexpert/initial.config/SW1.initial.config.txt

##################################################
#
# Define global router parameters for instance 2
#
##################################################

[xxx.xxx.105.36:7201] # Talk to the 2nd dynamips process on port 7201
    udp = 11000 # Change the base udp port to 11000 (the default is 10000)

    workingdir = /dynagen/intexpert/working

    [[3640]]
        #
        # Specify 3640 IOS image on Windows here:
        #
        # Specify 3640 IOS image on Linux here:
        # image = /ios/c3640-jk9o3s-mz.123-14.T7.extracted.bin
        image = /dynagen/images/c3640.extracted.bin

        #
        ram = 128
          disk0 = 0
        disk1 = 0
        # Choose an idlepc value from the below
        # idlepc = 0x60530870
        # idlepc = 0x60530890
        # idlepc = 0x60530a58
        # idlepc = 0x60530abc
        # idlepc = 0x605310c4
        # idlepc = 0x605e92e8
        # idlepc = 0x605e9364
        # idlepc = 0x60531394
        # idlepc = 0x605313d0
        # idlepc = 0x605313ec

        idlepc = 0x629953d8

        mmap = True

    ###########################
    #
    # Define router instances
    #
    ###########################

    [[Router SW2]]
        model = 3640
        console = 2007
        autostart = False
        slot1 = NM-16ESW
#cnfg = /dynagen/intexpert/initial.config/SW2.initial.config.txt
       F1/10 = SW3 F1/10
        F1/11 = SW3 F1/11
        F1/12 = SW3 F1/12
          F1/13 = SW4 F1/10
        F1/14 = SW4 F1/11
        F1/15 = SW4 F1/12

    [[Router SW3]]
        model = 3640
        console = 2008
        autostart = False
        slot1 = NM-16ESW
 #cnfg = /dynagen/intexpert/initial.config/SW2.initial.config.txt
        F1/13 = SW4 F1/13
        F1/14 = SW4 F1/14
        F1/15 = SW4 F1/15

    [[Router SW4]]
        model = 3640
        console = 2009
        autostart = False
        slot1 = NM-16ESW
          #cnfg = /dynagen/intexpert/initial.config/SW2.initial.config.txt

    [[Router BB1]]
        model = 3640
        console = 2010
        autostart = False
        slot1 = NM-4T
        S1/0 = BB3 S1/0
        S1/1 = FRSW 21
        ##cnfg = /dynagen/intexpert/initial.config/BB1.initial.config.txt

    [[Router BB2]]
        model = 3640
        console = 2011
        autostart = False
# slot0 = NM-4E
        slot0 = NM-1FE-TX
        F0/0 = SW2 F1/0
                ##cnfg = /dynagen/intexpert/initial.config/BB2.initial.config.txt

    [[Router BB3]]
        model = 3640
        console = 2012
        autostart = False
        slot0 = NM-1FE-TX
        slot1 = NM-4T
             slot2 = NM-1FE-TX
          F0/0 = SW1 F1/0
         ##cnfg = /dynagen/intexpert/initial.config/BB3.initial.config.txt

    [[FRSW FRSW]]

        # R1 to FRSW
        1:102 = 2:201
        1:103 = 3:301
        1:113 = 13:311
        1:104 = 4:401
        1:105 = 5:501

        # R2 to FRSW
        2:203 = 3:302
        2:213 = 13:312
        2:204 = 4:402
        2:205 = 5:502

        # R3 to FRSW
        3:304 = 4:403
        3:305 = 5:503
        13:314 = 4:413
        13:315 = 5:513

        # R4 to FRSW
        4:405 = 5:504

        # R6 to FRSW
        6:51 = 21:51
        6:100 = 21:100
        6:101 = 21:101
        6:201 = 21:201
        6:301 = 21:301
        6:401 = 21:401

> Ok,
>
> I have found the problem,
> In the file of configurations proposed by IE (for dynamips) it
> foresees for every SW (with two NM-16ESW) a memory of 128, which is
> not enough to work two NM-16ESW.
> It uses 256 ram.
>
> Example:
> [[Router SW1]]
> model = 3640
> ram = 256
> slot1 = NM-16ESW
> slot2 = NM-16ESW
>
>
> Ernesto.
>
>
>
>
>
>
> 2007/3/4, Victor Cappuccio <victor@ccbootcamp.com>:
>> Hola Ernesto,
>>
>> Puedes por favor mostrarnos la configuracion de Sw2 y R2?
>>
>> Here is a couple of question that I would ask to myself in order to
>> troubleshoot the problem..
>>
>> Do you have R2 in the same subnet as R1?
>> Do you have the trunk at Sw2 passing the same Vlans ??
>> Do you have the interface connecting R2 in the Same Vlan as R1?
>>
>> I am not sure about if this is possible in Dynamips, but to test that
>> you can create an SVI for that Vlan (3) in the same Address that R1 and
>> R2 are hanging and try the ping from Sw1 or Sw2
>>
>> HTH
>>
>> Gracias,
>> Victor Cappuccio.-
>> Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
>> Cisco Learning credits!
>> victor@ccbootcamp.com
>> http://www.ccbootcamp.com (Cisco Training and Rental Racks)
>> http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
>> Voice: 702-968-5100
>> FAX: 702-446-8012
>>
>>
>>
>>
>> -----Original Message-----
>> From: nobody@groupstudy.com on behalf of ernesto.mazuelos@gmail.com
>> Sent: Sun 3/4/2007 11:40
>> To: ccielab@groupstudy.com
>> Subject: Help for trunking with dynamips and IEv4
>>
>> Hi,
>> I don't succeed in doing a simple trunk among two SW with dynamips
>>
>> the trunk works well, but if ping from R1 to R2 no it works
>>
>> R1-----SW1-----SW2--------R2
>>
>> Rack1R1#ping 10.0.0.2 repeat 10
>>
>> Type escape sequence to abort.
>> Sending 10, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
>> ..........
>>
>> Thanks
>>
>>
>> Config :
>>
>>
>>
>>
>> Do I forget me of something?
>> R1
>> !
>> interface FastEthernet0/0
>> ip address 10.0.0.1 255.0.0.0
>> speed 100
>> full-duplex
>> !
>>
>> SW1
>> -----------
>> interface FastEthernet1/1
>> description To R1 F0/0
>> switchport access vlan 3
>> duplex full
>> speed 100
>> !
>> interface FastEthernet2/3
>> description To SW2 F2/3
>> switchport mode trunk
>> !
>>
>> SW2
>> -----------
>> !
>> interface FastEthernet1/2
>> description To R2 F0/0
>> switchport access vlan 3
>> duplex full
>> speed 100
>> interface FastEthernet2/3
>> description To SW1 F2/3
>> switchport mode trunk
>> duplex full
>> speed 100
>> !
>>
>> Rack1SW1#sh int tru
>>
>> Port Mode Encapsulation Status Native vlan
>> Fa2/3 on 802.1q trunking 1
>>
>> Port Vlans allowed on trunk
>> Fa2/3 1-1005
>>
>> Port Vlans allowed and active in management domain
>> Fa2/3 1-4
>>
>> Port Vlans in spanning tree forwarding state and not pruned
>>
>>
>> Rack1SW2#sh int tru
>>
>> Port Mode Encapsulation Status Native vlan
>> Fa2/3 on 802.1q trunking 1
>> Fa2/4 off 802.1q not-trunking 1
>> Fa2/5 off 802.1q not-trunking 1
>>
>> Port Vlans allowed on trunk
>> Fa2/3 1-1005
>> Fa2/4 none
>> Fa2/5 none
>>
>> Port Vlans allowed and active in management domain
>> Fa2/3 1-4
>> Fa2/4 none
>> Fa2/5 none
>>
>> Port Vlans in spanning tree forwarding state and not pruned
>> Fa2/3 1-4
>> Fa2/4 none
>> Fa2/5 none
>>
>>
>>
>> SW1
>> sw spa bri
>> ---------
>> VLAN3
>> Spanning tree enabled protocol ieee
>> Root ID Priority 32768
>> Address cc06.0170.0002
>> This bridge is the root
>> Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
>>
>> Bridge ID Priority 32768
>> Address cc06.0170.0002
>> Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
>> Aging Time 300
>>
>> Interface Designated
>> Name Port ID Prio Cost Sts Cost Bridge ID
>> Port ID
>> -------------------- ------- ---- ----- --- ----- --------------------
>> -------
>> FastEthernet1/1 128.42 128 19 FWD 0 32768 cc06.0170.0002
>> 128.42
>> FastEthernet2/3 128.84 128 19 FWD 0 32768 cc06.0170.0002
>> 128.84
>>
>> SW2
>> sh spa bri
>> VLAN3
>> Spanning tree enabled protocol ieee
>> Root ID Priority 32768
>> Address cc06.0170.0002
>> Cost 19
>> Port 84 (FastEthernet2/3)
>> Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
>>
>> Bridge ID Priority 32768
>> Address cc07.066c.0002
>> Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
>> Aging Time 300
>>
>> Interface Designated
>> Name Port ID Prio Cost Sts Cost Bridge ID
>> Port ID
>> -------------------- ------- ---- ----- --- ----- --------------------
>> -------
>> FastEthernet1/2 128.43 128 19 FWD 19 32768 cc07.066c.0002
>> 128.43
>> FastEthernet2/3 128.84 128 19 FWD 0 32768 cc06.0170.0002
>> 128.84
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:50 ART