From: Victor Cappuccio (victor@ccbootcamp.com)
Date: Sun Mar 04 2007 - 16:42:22 ART
Hi Shamin,
Check your authentication...
Remove all the authentication and test it back again
This is my test, on a similar lab topology as yours
R1 --- R3 --- R2
R3(config-router)#do show ip eigrp neigh
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 158.1.0.1 Vi1 13 00:00:06 1292 5000 0 13
0 158.1.0.2 Vi2 12 00:00:06 52 312 0 6
R3(config-router)#^Z
R3#sh
*Mar 4 19:21:37.135: %SYS-5-CONFIG_I: Configured from console by console
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/2713700] via 158.1.0.1, 00:00:23, Virtual-Access1
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/2713700] via 158.1.0.2, 00:00:26, Virtual-Access2
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
158.1.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 158.1.0.2/32 is directly connected, Virtual-Access2
C 158.1.0.1/32 is directly connected, Virtual-Access1
C 158.1.0.0/24 is directly connected, Virtual-Access1
is directly connected, Virtual-Access2
R3#
R3#
rack9>2
[Resuming connection 2 to R2 ... ]
*Mar 4 19:41:24.151: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 158.1.0.3
(Virtual-Access1) is down: metric changed
R2(config-router)#
R2(config-router)#
R2(config-router)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
D 1.1.1.0 [90/5273700] via 158.1.0.3, 00:00:36, Virtual-Access1
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2713700] via 158.1.0.3, 00:00:39, Virtual-Access1
158.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 158.1.0.1/32 [90/5145700] via 158.1.0.3, 00:00:39, Virtual-Access1
C 158.1.0.0/24 is directly connected, Virtual-Access1
R2(config-router)#
rack9>1
[Resuming connection 1 to R1 ... ]
R1(config-router)#
R1(config-router)#
R1(config-router)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/5273700] via 158.1.0.3, 00:00:47, Virtual-Access1
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2713700] via 158.1.0.3, 00:00:47, Virtual-Access1
158.1.0.0/24 is subnetted, 1 subnets
C 158.1.0.0 is directly connected, Virtual-Access1
R1(config-router)#
R1(config-router)#default int s0/0/0
Building configuration...
Interface Serial0/0/0 set to default configuration
R1(config)#
*Mar 4 19:46:39.831: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state
to down
R1(config)#int s0
*Mar 4 19:46:39.835: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 158.1.0.3
(Virtual-Access1) is down: interface down
*Mar 4 19:46:40.831: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-Access1, changed state to down
R1(config)#int s0/0/0
R1(config-if)#sh
R1(config-if)#encap frame-relay
R1(config-if)#exit
R1(config)#
*Mar 4 19:46:45.687: %LINK-5-CHANGED: Interface Serial0/0/0, changed state to
administratively down
*Mar 4 19:46:46.687: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0/0, changed state to down
R1(config)#int s0/0/0.2 point-to-point
R1(config-subif)# frame-relay interface-dlci 103 ppp Virtual-Template1
R1(config-fr-dlci)#exit
R1(config-subif)#int s0/0/0
R1(config-if)#no sh
*Mar 4 19:47:25.567: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state
to up up up
R1(config-if)#
*Mar 4 19:47:27.191: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Virtual-Access1, changed state to up
*Mar 4 19:47:27.247: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 10: Neighbor 158.1.0.3
(Virtual-Access1) is up: new adjacency
R1(config-if)#do show ip eigrp neigh
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 158.1.0.3 Vi1 12 00:00:07 44 264 0 27
R1(config-if)#do show ip route eigrp
2.0.0.0/24 is subnetted, 1 subnets
D 2.2.2.0 [90/5273700] via 158.1.0.3, 00:00:07, Virtual-Access1
3.0.0.0/24 is subnetted, 1 subnets
D 3.3.3.0 [90/2713700] via 158.1.0.3, 00:00:07, Virtual-Access1
158.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 158.1.0.2/32 [90/5145700] via 158.1.0.3, 00:00:07, Virtual-Access1
R1(config-if)#
____________
Look here, this is the debug you should be having at R4 or R5
*Mar 4 19:49:03.027: Vi1 PPP: Authorization required
*Mar 4 19:49:03.047: Vi1 PPP: No authorization without authentication
*Mar 4 19:49:03.063: Vi1 CHAP: I CHALLENGE id 15 len 23 from "R3"
*Mar 4 19:49:03.063: Vi1 CHAP: Using hostname from unknown source
*Mar 4 19:49:03.063: Vi1 CHAP: Using password from interface CHAP
*Mar 4 19:49:03.067: Vi1 CHAP: O RESPONSE id 15 len 23 from "R2"
*Mar 4 19:49:03.087: Vi1 CHAP: I FAILURE id 15 len 25 msg is "Authentication
failed"
You can fix this using this
R3(config)#do show run int virtual-template 1
Building configuration...
Current configuration : 128 bytes
!
interface Virtual-Template1
ip address 158.1.0.3 255.255.255.0
ppp authentication pap chap
ppp chap hostname Rack1R3
end
R2(config-if)#do show run int virtual-templa 1
Building configuration...
Current configuration : 150 bytes
!
interface Virtual-Template1
ip address 158.1.0.2 255.255.255.0
no peer neighbor-route
ppp chap hostname Rack1R2
ppp chap password 0 CISCO
end
or try the Provider WB Solution
HTH
thanks,
Victor Cappuccio.-
Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
Cisco Learning credits!
victor@ccbootcamp.com
http://www.ccbootcamp.com (Cisco Training and Rental Racks)
http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
Voice: 702-968-5100
FAX: 702-446-8012
-----Original Message-----
From: nobody@groupstudy.com on behalf of Shamin
Sent: Sun 3/4/2007 9:37
To: Ivan
Cc: Cisco certification
Subject: Re: EIGRP over PPP over Frame - Problem
Ivan,
Thanks for your reply.
I tried changing the subnet to 158.1.44.0/24 . But that does not solve the
issue.
R5 & R3 are able to ping R4's loopback but R4 does not receive any eigrp
updates from the hub R3 or the spoke R5. Kind of peculiar situation i am in.
Dont see a reason for this.
Regards
Shameen
On 3/4/07, Ivan <ivan@iip.net> wrote:
>
> May be try ip address from another subnet on R4. For instance: 158.1.44.4
> Only suppose.
>
>
>
> On Sunday 04 March 2007 18:39, Shamin wrote:
> > Hi,
> >
> > I tried that. But the point is, If split horizon is acting then R4's
> > loopback should not be seen by R5 as well. But R5 is able to ping R4's
> > loopback.
> >
> > Any other thing that can be a issue?
> >
> > regards
> > shamin
> >
> > On 3/4/07, Darrin K. Pierce <darrin@dkpierce.com> wrote:
> > > Try disabling split-horizon on R3.
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of
> > > Shamin
> > > Sent: Sunday, March 04, 2007 9:39 AM
> > > To: Cisco certification
> > > Subject: EIGRP over PPP over Frame - Problem
> > >
> > > Hi all,
> > >
> > > Hope your preparations are going good.
> > >
> > > I have a peculiar situation running EIGRP over PPPover Frame.
> > >
> > >
> > > R5 ---------- R3 -------------R4
> > >
> > >
> > > R3 is the hub and R4,R5 are the spokes. R3 & R4 are using main
> > > interfaces. R5 is using a point -to - point interface.
> > > The PPPoverFrame seems to be working. I can ping spoke to spoke . Now
> > > when i
> > > enable EIGRP , over this there is a problem that
> > > R4 is not receiving any Eigrp routes from R3 or R5. I configured
> Loopback
> > > 100 on R3 with Ip 3.3.3.3 and advertised it into eigrp.
> > > R5 seems to be receiving this route where as R4 is not.
> > > R5 is able to receive the Loopback of R4 where as R4 is not receiving
> the
> > > R5
> > > Loopback route.
> > >
> > > Can any one help reason why this is happening. The debug commands of
> > > eigrp is not very helpful in this. I dont think this is a split
> horizon
> > > issue as well.
> > >
> > > I will post the configuration on each router as below.
> > >
> > >
> -------------------------------------------------------------------------
> > >--- ------------------------
> > >
> > > R3#
> > > username Rack1R4 password 0 CISCO
> > > username Rack1R5 password 0 CISCO
> > > !
> > > !
> > > !
> > > !
> > > interface Loopback100
> > > ip address 3.3.3.3 255.255.255.0
> > > !
> > > interface Serial2/0
> > > no ip address
> > > encapsulation frame-relay
> > > frame-relay interface-dlci 304 ppp Virtual-Template1
> > > frame-relay interface-dlci 305 ppp Virtual-Template1
> > >
> > > !
> > > interface Virtual-Template1
> > > ip address 158.1.0.3 255.255.255.0
> > > ppp authentication pap chap
> > > !
> > > router eigrp 10
> > > network 3.3.3.3 0.0.0.0
> > > network 158.1.0.3 0.0.0.0
> > > metric weights 0 1 1 1 0 0
> > > no auto-summary
> > > eigrp router-id 150.1.3.3
> > > !
> > >
> > > R3#sh ip route eigrp
> > > 4.0.0.0/24 is subnetted, 1 subnets
> > > D 4.4.4.0 [90/2713700] via 158.1.0.4, 00:22:26, Virtual-Access1
> > > 158.1.0.0/16 is variably subnetted, 11 subnets, 2 masks
> > > D 158.1.5.0/24 [90/2842603] via 158.1.0.5, 00:22:26,
> > > Virtual-Access2 D 158.1.55.0/24 [90/2842603] via 158.1.0.5,
> > > 00:22:26,
> > > Virtual-Access2
> > > 150.1.0.0/16 is variably subnetted, 6 subnets, 2 masks
> > > D 150.1.5.0/24 [90/2713700] via 158.1.0.5, 00:22:26,
> > > Virtual-Access2 D 150.1.4.0/24 [90/2713700] via 158.1.0.4,
> > > 00:22:26, Virtual-Access1
> > >
> > >
> > >
> -------------------------------------------------------------------------
> > >--- --------------------------------------------------------
> > >
> > > R4#
> > > username Rack1R3 password 0 CISCO
> > > !
> > > !
> > > interface Loopback0
> > > ip address 150.1.4.4 255.255.255.0
> > > !
> > > interface Loopback100
> > > ip address 4.4.4.4 255.255.255.0
> > > !
> > > interface Serial0/0
> > > no ip address
> > > encapsulation frame-relay
> > > frame-relay interface-dlci 403 ppp Virtual-Template1
> > > !
> > > !
> > > interface Virtual-Template1
> > > ip address 158.1.0.4 255.255.255.0
> > > no peer neighbor-route
> > > !
> > > router eigrp 10
> > > network 4.4.4.4 0.0.0.0
> > > network 150.1.4.4 0.0.0.0
> > > network 158.1.0.4 0.0.0.0
> > > network 158.1.45.4 0.0.0.0
> > > metric weights 0 1 1 1 0 0
> > > no auto-summary
> > > eigrp router-id 150.1.4.4
> > > !
> > >
> > >
> > > R4#sh ip route
> > >
> > > Gateway of last resort is not set
> > >
> > > C 204.12.1.0/24 is directly connected, Ethernet0/1
> > > 4.0.0.0/24 is subnetted, 1 subnets
> > > C 4.4.4.0 is directly connected, Loopback100
> > > 158.1.0.0/24 is subnetted, 1 subnets
> > > C 158.1.0.0 is directly connected, Virtual-Access1
> > > C 192.10.1.0/24 is directly connected, Ethernet0/0
> > > 150.1.0.0/24 is subnetted, 1 subnets
> > > C 150.1.4.0 is directly connected, Loopback0
> > >
> > >
> > >
> > >
> > >
> -------------------------------------------------------------------------
> > >--- ----------------------------------------
> > >
> > > R5#
> > > !
> > > !
> > > !
> > > interface Loopback0
> > > ip address 150.1.5.5 255.255.255.0
> > > !
> > > interface Ethernet0/0
> > > ip address 158.1.5.5 255.255.255.0
> > > half-duplex
> > > !
> > > interface Serial0/0
> > > no ip address
> > > encapsulation frame-relay
> > > !
> > > interface Serial0/0.1 point-to-point
> > > frame-relay interface-dlci 503 ppp Virtual-Template1
> > > !
> > > interface Ethernet0/1
> > > ip address 158.1.55.5 255.255.255.0
> > > half-duplex
> > > !
> > > interface Virtual-Template1
> > > ip address 158.1.0.5 255.255.255.0
> > > ppp chap password 0 CISCO
> > > !
> > > router eigrp 10
> > > network 150.1.5.5 0.0.0.0
> > > network 158.1.0.5 0.0.0.0
> > > network 158.1.5.5 0.0.0.0
> > > network 158.1.45.5 0.0.0.0
> > > network 158.1.55.5 0.0.0.0
> > > metric weights 0 1 1 1 0 0
> > > no auto-summary
> > > eigrp router-id 150.1.5.5
> > > !
> > >
> > > R5#sh ip route eigrp
> > > 3.0.0.0/24 is subnetted, 1 subnets
> > > D 3.3.3.0 [90/2713700] via 158.1.0.3, 00:36:01, Virtual-Access1
> > > 4.0.0.0/24 is subnetted, 1 subnets
> > > D 4.4.4.0 [90/5273700] via 158.1.0.3, 00:35:31, Virtual-Access1
> > > 158.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
> > > D 158.1.0.4/32 [90/5145700] via 158.1.0.3, 00:54:44,
> > > Virtual-Access1 150.1.0.0/24 is subnetted, 2 subnets
> > > D 150.1.4.0 [90/5273700] via 158.1.0.3, 00:30:47,
> Virtual-Access1
> > >
> > >
> -------------------------------------------------------------------------
> > >--- ----------------------------------------------
> > >
> > > Your help will be much appreciated. I dont see a reason why after
> forming
> > > an
> > > adjacency between R3 & R4 , the routes are only updated one way i.efrom
> > > R4
> > > to R3 and R5 but not back.
> > >
> > > Regards
> > > Shameen
> > >
> > >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> --
> Ivan
This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:50 ART