IP switching path

From: nhatphuc (nhatphuc@gmail.com)
Date: Fri Mar 02 2007 - 06:21:25 ART


Hi Group,

Please help me with this simple configuration.

I configure equal-cost load balancing using RIP. It doesn't work as I
thought.

I enable fast-switching but it still does process-switching. Is there any
feature that can affect router' switching path?

Thanks

Below is my configuration:

Router#sh run
Building configuration...

Current configuration : 1882 bytes
!
configuration mode exclusive manual
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service password-recovery
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable password 7 0822455D0A16
!
no aaa new-model
!
resource policy
!
!
!
no ip cef
!
!
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
 no dspfarm
!
password encryption aes
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.0.0.1 255.255.255.0
!
interface GigabitEthernet0/0
 ip address 100.100.100.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 enable
 ipv6 nat
!
interface GigabitEthernet0/1
 ip address 200.200.200.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 address 2001:1:1::1/64
 ipv6 enable
 ipv6 nat
!
interface Serial0/2/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
!
interface Serial0/2/1
 no ip address
 shutdown
 clock rate 2000000
!
router rip
 passive-interface Loopback0
 passive-interface Loopback1
 network 10.0.0.0
 network 100.0.0.0
 network 200.200.200.0
!
!
!
ip http server
no ip http secure-server
!
ip access-list extended NORIP
 deny udp any eq rip any
 deny udp any any eq rip
 permit ip any any
!
access-list 100 deny udp any eq rip any
access-list 100 deny udp any any eq rip
access-list 100 deny ip any host 255.255.255.255
access-list 100 permit ip any any
!
!
ipv6 nat v4v6 source 172.16.1.2 2001::20
ipv6 nat v6v4 source 2001:1:1::10 172.16.1.20
ipv6 nat prefix 2001::/96
!
control-plane
!
bridge 1 protocol ieee
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
 no exec
 transport input telnet
line vty 0 4
 login local
 transport input all
!
scheduler allocate 20000 1000
!
webvpn context Default_context
 ssl authenticate verify all
 !
 no inservice
!
!
end

Router#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 200.200.200.0/24 is directly connected, GigabitEthernet0/1
     1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
     100.0.0.0/24 is subnetted, 1 subnets
C 100.100.100.0 is directly connected, GigabitEthernet0/0
R 20.0.0.0/8 [120/1] via 200.200.200.2, 00:00:26, GigabitEthernet0/1
                [120/1] via 100.100.100.2, 00:00:06, GigabitEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Loopback1
R 192.168.1.0/24 [120/1] via 200.200.200.2, 00:00:27, GigabitEthernet0/1
                    [120/1] via 100.100.100.2, 00:00:07, GigabitEthernet0/0
Router#sh ip cef
%CEF not running
Prefix Next Hop Interface
Router#sh ip int g0/0
GigabitEthernet0/0 is up, line protocol is up
  Internet address is 100.100.100.1/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is disabled
  IP Feature Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
Router#sh ip int g0/1
GigabitEthernet0/1 is up, line protocol is up
  Internet address is 200.200.200.1/24
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.9
  Outgoing access list is not set
  Inbound access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is disabled
  IP Flow switching is disabled
  IP CEF switching is disabled
  IP Feature Fast switching turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
Router#sh ip ro 20.0.0.1
Routing entry for 20.0.0.0/8
  Known via "rip", distance 120, metric 1
  Redistributing via rip
  Last update from 100.100.100.2 on GigabitEthernet0/0, 00:00:08 ago
  Routing Descriptor Blocks:
    200.200.200.2, from 200.200.200.2, 00:00:27 ago, via GigabitEthernet0/1
      Route metric is 1, traffic share count is 1
  * 100.100.100.2, from 100.100.100.2, 00:00:08 ago, via GigabitEthernet0/0
      Route metric is 1, traffic share count is 1

Router#p 20.0.0.1 so lo1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
Router#
*Mar 2 02:05:45.195: IP: tableid=0, s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), routed via RIB
*Mar 2 02:05:45.195: IP: s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), len 100, sending
*Mar 2 02:05:45.199: IP: tableid=0, s=20.0.0.1 (GigabitEthernet0/1), d=
10.0.0.1 (Loopback1), routed via RIB
*Mar 2 02:05:45.199: IP: s=20.0.0.1 (GigabitEthernet0/1), d=10.0.0.1, len
100, rcvd 4
*Mar 2 02:05:45.199: IP: tableid=0, s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/1), routed via RIB
*Mar 2 02:05:45.199: IP: s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/1), len 100, sending
*Mar 2 02:05:45.199: IP: tableid=0, s=20.0.0.1 (GigabitEthernet0/0), d=
10.0.0.1 (Loopback1), routed via RIB
*Mar 2 02:05:45.199: IP: s=20.0.0.1 (GigabitEthernet0/0), d=10.0.0.1, len
100, rcvd 4
*Mar 2 02:05:45.199: IP: tableid=0, s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), routed via RIB
*Mar 2 02:05:45.199: IP: s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), len 100, sending
*Mar 2 02:05:45.199: IP: tableid=0, s=20.0.0.1 (GigabitEthernet0/1), d=
10.0.0.1 (Loopback1), routed via RIB
*Mar 2 02:05:45.199: IP: s=20.0.0.1 (GigabitEthernet0/1), d=10.0.0.1, len
100, rcvd 4
*Mar 2 02:05:45.199: IP: tableid=0, s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/1), routed via RIB
*Mar 2 02:05:45.199: IP: s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/1), len 100, sending
*Mar 2 02:05:45.203: IP: tableid=0, s=20.0.0.1 (GigabitEthernet0/0), d=
10.0.0.1 (Loopback1), routed via RIB
*Mar 2 02:05:45.203: IP: s=20.0.0.1 (GigabitEthernet0/0), d=10.0.0.1, len
100, rcvd 4
*Mar 2 02:05:45.203: IP: tableid=0, s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), routed via RIB
*Mar 2 02:05:45.203: IP: s=10.0.0.1 (local),
d=20.0.0.1(GigabitEthernet0/0), len 100, sending
*Mar 2 02:05:45.203: IP: tableid=0, s=20.0.0.1 (GigabitEthernet0/1), d=
10.0.0.1 (Loopback1), routed via RIB
*Mar 2 02:05:45.203: IP: s=20.0.0.1 (GigabitEthernet0/1), d=10.0.0.1, len
100, rcvd 4
Router#



This archive was generated by hypermail 2.1.4 : Sun Apr 01 2007 - 06:35:49 ART