RE: traffic shaping

From: Victor Cappuccio (victor@ccbootcamp.com)
Date: Wed Feb 21 2007 - 03:45:14 ART


Hey RAF :D

Now for the class-default you have there; see that the bandwidth you
configured is know as Class Based WFQ. and we can control how much minimum BW
a class can get in case of congestion

The formula is: Available_Bandwidth = (Configured_Bandwidth *
max-reserved-bandwidth/100) - (LLQ - RTP - RSVP)

r1(config)#class-map FTP
r1(config-cmap)#ma proto ftp
r1(config-cmap)#exit
r1(config)#policy-map PLAY
r1(config-pmap)#class FTP
r1(config-pmap-c)#band 1000
r1(config-pmap-c)#exit
r1(config-pmap)#class class-default
r1(config-pmap-c)#band 100
r1(config-pmap-c)#exit
r1(config-pmap)#int f0/0
r1(config-if)#ser out PLAY
r1(config-if)#do show queue f0/0
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: Class-based queueing
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations 0/0/256 (active/max active/max total)
     Reserved Conversations 2/2 (allocated/max allocated)
     Available Bandwidth 73900 kilobits/sec

we just took out some Kilobits out of that 75% available BW.

Lets modify the policy map a little bit

r1(config-if)#policy-map PLAY
r1(config-pmap)# class ftp
r1(config-pmap-c)#do show queue f0/0 | in Ava
     Available Bandwidth 0 kilobits/sec
r1(config-pmap-c)#bandwidth 10000
r1(config-pmap-c)#do show queue f0/0 | in Ava
     Available Bandwidth 64900 kilobits/sec

r1(config-pmap-c)# bandwidth 100000
I/f FastEthernet0/0 Class ftp requested bandwidth 100000 (kbps) Only 74900
(kbps) available

if we take more than the available BW for that interface
The, bandwidth measured in kbps, is an absolute reservation, and is not based
on the available bandwidth of the interface.

See that the BW operates per each class

r1(config-if)#do show policy-map int f0/0 | in Band|Class
    Class-map: ftp (match-all)
        Bandwidth 74900 (kbps)Max Threshold 64 (packets)
    Class-map: class-default (match-any)
        Bandwidth 100 (kbps)Max Threshold 64 (packets)
r1(config-pmap-c)#band 60000
r1(config-pmap-c)#do show policy-map int f0/0 | in Band|Class
    Class-map: ftp (match-all)
        Bandwidth 60000 (kbps)Max Threshold 64 (packets)
    Class-map: class-default (match-any)
        Bandwidth 100 (kbps)Max Threshold 64 (packets)

and other classes BW is not affected.

As a side note, When frame-relay traffic-shaping on a physical interface the
concept of interface Available Bandwidth disappears, and max-reservable
bandwidth is equal to mincir of the dlcis.- Just for FYI.

thanks,
Victor Cappuccio.-
Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
Cisco Learning credits!
victor@ccbootcamp.com
http://www.ccbootcamp.com (Cisco Training and Rental Racks)
http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
Voice: 702-968-5100
FAX: 702-446-8012

-----Original Message-----
From: nobody@groupstudy.com on behalf of Radioactive Frog
Sent: Wed 2/21/2007 3:40
To: M S
Cc: ccielab@groupstudy.com
Subject: Re: traffic shaping

Hi Contention is a ration for bandwidth sharing.
If I have 2 megs uplink (internet bandwidth) and distributing to 10 people
(of 2 megs each) that would be 1:10 ratio (in ISP term we call it
Contention.

Cheers

On 2/21/07, M S <michaelgstout@hotmail.com> wrote:
>
> I do not understand the question.
> What do you mean by contention.
> what two things represent the ratio
>
> ------------------------------
> From: *"Radioactive Frog" <pbhatkoti@gmail.com>*
> Reply-To: *"Radioactive Frog" <pbhatkoti@gmail.com>*
> To: *"Cisco certification" <ccielab@groupstudy.com>*
> Subject: *traffic shaping*
> Date: *Wed, 21 Feb 2007 11:59:02 +1100*
> Hi Guys,
>
> I am simulating:
>
> Internet--fas0/0----7204router----fas0/1---------Customers..
>
>
> Gold (1:1 contention) - IP address 10.1.1.0/24
> Silver (10:1 contention) - IP add 20.1.1.0/24
> bronze (50:1 contention) - IP add 30.1.1.0/24
>
> ip access-list extended Gold
> permit ip any 10.1.1.0 255.255.255.0
>
> ip access-list extended silver
> permit ip any 20.1.1.0 255.255.255.0
>
> ip access-list extended bronze
> permit ip any 30.1.1.0 255.255.255.0
>
> !
> class-map match-all Gold
> match access-group name Gold
>
> class-map match-all Silver
> match access-group name silver
>
> class-map match-all bronze
> match access-group name bronze
>
> !
> !
> policy-map shape-all-traffic
> class gold
> bandwidth 10000
> class silver
> bandwidth 20000
> class bronze
> bandwidth 30000
>
> class class-default
> bandwidth 60000 <--------sum of all class????? Is it necessary
> ?
> !
>
> Interface fas0/1
> service policy shape-all-traffic out
>
>
> Will this work? Any co
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> ------------------------------
> Refi Now: Rates near 39yr lows! $430,000 Mortgage for $1,399/mo -
> Calculate new payment <http://g.msn.com/8HMBENUS/2752??PS=47575>



This archive was generated by hypermail 2.1.4 : Thu Mar 01 2007 - 07:38:47 ART