From: Victor Cappuccio (vcappuccio@desca.com)
Date: Tue Jan 30 2007 - 23:21:38 ART
Hi Li,
That second step is done router automatically by the router.
Now if you use a route-map WITH a redistribute connected then you must match also the network statements (the connected routes of that Routing Protocol)
Great information about this:
http://www.groupstudy.com/archives/ccielab/200310/msg00269.html
But If you allow me to add more, in relation to the question.
Using this Dynamips configuration:
start "R1" /belownormal G:\Images\dynamips-wxp.exe -i 1 -P 3600 --idle-pc 0x6050a06c -p 0:NM-4E -p 1:NM-4T -p 2:NM-1FE-TX -p 3:NM-1FE-TX -s 0:0:udp:11112:127.0.0.1:11121 -s 3:0:udp:130306:127.0.0.1:630301 -G ghost_ram g:\Images\C3640-IS.BIN
start "R2" /belownormal G:\Images\dynamips-wxp.exe -i 2 -P 3600 --idle-pc 0x6050a06c -p 0:NM-4E -s 0:0:udp:11123:127.0.0.1:11132 -s 0:1:udp:11121:127.0.0.1:11112 -s 0:2:udp:11126:127.0.0.1:11162 -G ghost_ram g:\Images\C3640-IS.BIN
start "R3" /belownormal G:\Images\dynamips-wxp.exe -i 3 -P 3600 --idle-pc 0x6050a06c -p 0:NM-4E -p 1:NM-4T -p 2:NM-1FE-TX -p 3:NM-1FE-TX -s 0:0:udp:11134:127.0.0.1:11143 -s 0:1:udp:11132:127.0.0.1:11123 -s 2:0:udp:320206:127.0.0.1:620203 -G ghost_ram g:\Images\C3640-IS.BIN
I configured several loopbacks on R3
R3#show run | in ip route
R3#show ip int brief | in Lo
Loopback0 3.3.3.3 YES NVRAM up up
Loopback102 10.2.0.2 YES NVRAM up up
R3#conf te
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int lo103
R3(config-if)#ip add 10.3.0.3 255.255.255.255 R3(config-if)#int lo104 R3(config-if)#ip add 10.4.0.3 255.255.255.255 R3(config-if)#do show ip prot
R3(config-if)#
R3 is announcing this loopbacks via RIP to R2
R3(config-if)#router rip
R3(config-router)#net 10.0.0.0
R3(config-router)#no auto
R3(config-router)#ver 2
R3(config-router)#do show ip int brief | ex una|admin
Interface IP-Address OK? Method Status Prot
ocol
Ethernet0/0 1.1.34.3 YES NVRAM up up
Ethernet0/1 1.1.23.3 YES NVRAM up up
FastEthernet2/0 1.1.36.3 YES NVRAM up up
Loopback0 3.3.3.3 YES NVRAM up up
Loopback102 10.2.0.2 YES NVRAM up up
Loopback103 10.3.0.3 YES manual up up
Loopback104 10.4.0.3 YES manual up up
R3(config-router)#net 1.0.0.0
, R2 is receiving this information via rip
R2(config)#do show run | in ip route
R2(config)#do show ip proto
R2(config)#router rip
R2(config-router)#ver 2
R2(config-router)#no auto
R2(config-router)#net 1.0.0.0
R2(config-router)#pass default
R2(config-router)#no pass e0/0
R2(config-router)#do clear ip route *
R2(config-router)#do show ip route rip
1.0.0.0/24 is subnetted, 5 subnets
R 1.1.34.0 [120/1] via 1.1.23.3, 00:00:02, Ethernet0/0
R 1.1.36.0 [120/1] via 1.1.23.3, 00:00:02, Ethernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
R 10.2.0.0/16 [120/1] via 1.1.23.3, 00:00:02, Ethernet0/0
R 10.3.0.3/32 [120/1] via 1.1.23.3, 00:00:02, Ethernet0/0
R 10.4.0.3/32 [120/1] via 1.1.23.3, 00:00:02, Ethernet0/0
R2 is redistributing this information to OSPF
R2(config-router)#router ospf 100
R2(config-router)#net 1.1.12.2 0.0.0.0 a 0 R2(config-router)#do show ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
11.11.11.1 1 2WAY/DROTHER 00:00:35 1.1.12.1 Ethernet0/1
R2(config-router)#red rip sub
R2(config-router)#do show ip ospf neigh
R2(config-router)#do show ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
11.11.11.1 1 FULL/DR 00:00:39 1.1.12.1 Ethernet0/1
R2(config-router)#
R1>en
R1#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no ip domain-loo
R1(config)#do show ip pro
Routing Protocol is "bgp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled
Automatic route summarization is disabled
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
1.1.12.2
1.1.16.6
Maximum path: 1
Routing Information Sources:
Gateway Distance Last Update
1.1.12.2 20 00:00:50
Distance: external 20 internal 200 local 200
R1(config)#no router bgp 1
R1(config)#
*Mar 1 00:03:32.959: %BGP-5-ADJCHANGE: neighbor 1.1.12.2 Down BGP protocol init ialization R1(config)#do show run | in ip route R1(config)#router ospf 100 R1(config-router)#do show ip int brief | ex una|admin
Interface IP-Address OK? Method Status Prot
ocol
Ethernet0/0 1.1.12.1 YES NVRAM up up
FastEthernet3/0 1.1.16.1 YES NVRAM up up
Loopback0 1.1.1.1 YES NVRAM up up
Loopback1003 11.11.11.1 YES NVRAM up up
R1(config-router)#net 1.1.12.1 0.0.0.0 a 0 R1(config-router)# *Mar 1 00:11:10.387: %OSPF-5-ADJCHG: Process 100, Nbr 2.2.2.2 on Ethernet0/0 fr om LOADING to FULL, Loading Done R1(config-router)#do show ip route | be Gate Gateway of last resort is not set
1.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C 1.1.1.1/32 is directly connected, Loopback0
C 1.1.12.0/24 is directly connected, Ethernet0/0
C 1.1.16.0/24 is directly connected, FastEthernet3/0
O E2 1.1.23.0/24 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
O E2 1.1.26.0/24 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
O E2 1.1.34.0/24 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
O E2 1.1.36.0/24 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2 10.2.0.0/16 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
O E2 10.3.0.3/32 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
O E2 10.4.0.3/32 [110/20] via 1.1.12.2, 00:00:26, Ethernet0/0
11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, Loopback1003
R1(config-router)#
Now if you redistribute connected using a route-map
R2(config-router)#route-map LO0
R2(config-route-map)#ma int lo0
R2(config-route-map)#router ospf 100
R2(config-router)#red con route-map LO0
% Only classful networks will be redistributed R2(config-router)#red con route-map LO0 sub R2(config-router)#
R1(config-router)#do show ip route ospf
1.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E2 1.1.34.0/24 [110/20] via 1.1.12.2, 00:08:09, Ethernet0/0
O E2 1.1.36.0/24 [110/20] via 1.1.12.2, 00:08:09, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O E2 2.2.2.2 [110/20] via 1.1.12.2, 00:02:19, Ethernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2 10.2.0.0/16 [110/20] via 1.1.12.2, 00:08:09, Ethernet0/0
O E2 10.3.0.3/32 [110/20] via 1.1.12.2, 00:08:09, Ethernet0/0
O E2 10.4.0.3/32 [110/20] via 1.1.12.2, 00:08:09, Ethernet0/0
R1(config-router)#
R1(config-router)#do ping 1.1.23.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.23.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1(config-router)#
On the other side
R2(config-router)#red con route-map LO0 sub R2(config-router)#router rip R2(config-router)#red ospf 100 R2(config-router)#
R3(config-router)#do show ip route | b Gate Gateway of last resort is not set
1.0.0.0/24 is subnetted, 5 subnets
R 1.1.12.0 [120/1] via 1.1.23.2, 00:00:23, Ethernet0/1
C 1.1.23.0 is directly connected, Ethernet0/1
R 1.1.26.0 [120/1] via 1.1.23.2, 00:00:23, Ethernet0/1
C 1.1.34.0 is directly connected, Ethernet0/0
C 1.1.36.0 is directly connected, FastEthernet2/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.2.0.0/16 is directly connected, Loopback102
C 10.3.0.3/32 is directly connected, Loopback103
C 10.4.0.3/32 is directly connected, Loopback104
R3(config-router)#
And if you include a route-map Connected matching Lo0 to RIP R2(config-router)#red conn route-map LO0
R3(config-router)#do clear ip route *
R3(config-router)#do show ip route rip | b Gate R3(config-router)#do show ip route rip | b Gate R3(config-router)#do show ip route rip | b Gate R3(config-router)#do show ip route rip | b Gate R3(config-router)#do show ip route rip | b Gate R3(config-router)#do show ip route rip | b Gate R3(config-router)#
So the default action is to deny all your connected routes by the route-map Without the connected redistribution route-map used in the routing-protocol
I would think that the Route-map is like this
Router ospf 100
Red rip sub
-------- not shown --- red conn sub
Now If you add a redistribute connected using a route-map that statement since to get disappear
I find this link useful to lab it and play around it a long while just to get sure I understand what they mean to say http://www.cisco.com/warp/public/105/52.html
I hope It make sense
Saludos,
Victor.-
-----Mensaje original-----
De: nobody@groupstudy.com en nombre de Li Guoyi
Enviado el: mar 30/01/2007 21:33
Para: Brian Dennis; Bliz Man; ccielab@groupstudy.com
Asunto: RE: Strange issues with routing
I used Dynamip to simulate a scenario, and not sure if it is correct
R1 -link12- R2 -link23 - R3
R1 lo0, R1-link12-R2 is in OSPF
R2 -link23 - R3, R3 lo0 is in EIGRP
1. When I redistribute EIRGP into OSPF on R2 by using "redistribute eig
10 subnet"
R1 can get link23 subnet and R3's lo, which means Step two you mention
may not be necessary?
2.If on R2, I redistributed one more thing
Router os 1
redistribute eig 10 subnet
redistribute connected
R1 can get R2's lo0, and still have link23, and R3' lo0
3. but if I use routemap
Router os 1
redistribute eig 10 sub
redistribute connected route-map R2loopbackonly
Then on R1, it will lose subnet link23
So when we redistribute connected, do we always need to use route-map? I
feel it is better we just "redistribute connected" without any route-map
Can you please advise?
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Brian Dennis
Sent: Thursday, January 25, 2007 7:35 AM
To: Bliz Man; ccielab@groupstudy.com
Subject: RE: Strange issues with routing
Basic route redistribution on a single router is a two step process.
The first step is to bring in the routes from the routing table for the
protocol being redistributed (show ip route <protocol>). The second
step is to bring in the connected interfaces that the protocol is
enabled on (i.e. network statements).
When you manually redistribute connected with a route-map you are
breaking the second step that the router is doing for you automatically.
This second step was done when you redistributed, in your case, OSPF
into EIGRP. You need to match the interfaces that the router was
bringing in for you automatically in your route-map.
If you remember these two steps it will save you a lot of headaches
going forward ;-)
Brian Dennis, CCIE4 #2210 (R&S/ISP-Dial/Security/SP)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Bliz Man
Sent: Wednesday, January 24, 2007 1:46 PM
To: ccielab@groupstudy.com
Subject: Strange issues with routing
Hello group!
I've got following simple topology:
Sw1 -----vlan10---- f0/0 R3 s0/0
(svi) |
|---------f0/0 R4 s0/0
EIGRP: f0/0@R3,R4, SVI on Sw1, OSPF - on s0/0@R3,R4
I'm doing mutual redistribution on R3 and R4 :
CCIE-R4#sh run | be router
router eigrp 1
redistribute ospf 1 metric 1000 100 255 1 1500 network 1.1.4.4 0.0.0.0
network 1.1.10.4 0.0.0.0 no auto-summary !
router ospf 1
router-id 1.1.4.4
log-adjacency-changes
redistribute eigrp 1 subnets
network 1.1.4.4 0.0.0.0 area 0
network 1.1.11.4 0.0.0.0 area 0
CCIE-R3#sh run | be router
router eigrp 1
redistribute ospf 1 metric 1000 100 255 1 1500 network 1.1.3.3 0.0.0.0
network 1.1.10.3 0.0.0.0 no auto-summary !
router ospf 1
router-id 1.1.3.3
log-adjacency-changes
redistribute eigrp 1 subnets
network 1.1.3.3 0.0.0.0 area 0
network 1.1.11.3 0.0.0.0 area 0
And on Sw1 I have 2 routes to 1.1.11.0/24. - simple
CCIE-SW1#sir 1.1.11.1
Routing entry for 1.1.11.0/29
Known via "eigrp 1", distance 170, metric 2585856, type external
Redistributing via eigrp 1
Last update from 1.1.10.4 on Vlan13, 00:31:07 ago
Routing Descriptor Blocks:
1.1.10.4, from 1.1.10.4, 00:31:07 ago, via Vlan13
Route metric is 2585856, traffic share count is 1
Total delay is 1010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 1.1.10.3, from 1.1.10.3, 00:31:07 ago, via Vlan13
Route metric is 2585856, traffic share count is 1
Total delay is 1010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
BUT...
When I add some loopback on R4: lo5 on R4
interface Loopback5
ip address 5.5.5.5 255.255.255.255
end
And try to redistribute it to EIGRP through simple route-map as
connected:
CCIE-R4#sh route-map CONN
route-map CONN, permit, sequence 10
Match clauses:
interface Loopback5
Set clauses:
Policy routing matches: 0 packets, 0 bytes
And add this string to R3 config under EIGRP: redistribute connected
metric 1000 100 255 1 1500 route-map CONN on Sw1 one route to
1.1.11.0/24 removed from RIB
CCIE-SW1#sir 1.1.11.1
Routing entry for 1.1.11.0/29
Known via "eigrp 1", distance 170, metric 2585856, type external
Redistributing via eigrp 1
Last update from 1.1.10.3 on Vlan13, 00:02:15 ago
Routing Descriptor Blocks:
* 1.1.10.3, from 1.1.10.3, 00:02:15 ago, via Vlan13
Route metric is 2585856, traffic share count is 1
Total delay is 1010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
At that moment I have "debug eigrp fsm" on Sw1:
CCIE-SW1#debug eigrp fsm
EIGRP FSM Events/Actions debugging is on CCIE-SW1#
1w2d: DUAL: rcvquery: 1.1.11.0/29 via 1.1.10.4 metric
4294967295/4294967295, RD is 2585856
1w2d: DUAL: Find FS for dest 1.1.11.0/29. FD is 2585856, RD is 2585856
1w2d: DUAL: 1.1.10.4 metric 4294967295/4294967295
1w2d: DUAL: 1.1.10.3 metric 2585856/2585600 found Dmin is 2585856
1w2d: DUAL: send REPLY(r1/n1) about 1.1.11.0/29 to 1.1.10.4
1w2d: DUAL: RT installed 1.1.11.0/29 via 1.1.10.3
1w2d: DUAL: dest(5.5.5.5/32) not active
1w2d: DUAL: rcvupdate: 5.5.5.5/32 via 1.1.10.4 metric 2585856/2585600
1
CCIE-SW1#w2d: DUAL: Find FS for dest 5.5.5.5/32. FD is 4294967295, RD is
4294967295 found
1w2d: DUAL: RT installed 5.5.5.5/32 via 1.1.10.4
1w2d: DUAL: Send update about 5.5.5.5/32. Reason: metric chg
1w2d: DUAL: Send update about 5.5.5.5/32. Reason: new if
1w2d: DUAL: Removing dest 1.1.11.0/29, nexthop 1.1.10.4
And when I remove "redistr connected" on R4 :
1w2d: DUAL: rcvquery: 5.5.5.5/32 via 1.1.10.4 metric
4294967295/4294967295, RD is 2585856
1w2d: DUAL: Find FS for dest 5.5.5.5/32. FD is 2585856, RD is 2585856
1w2d: DUAL: 1.1.10.4 metric 4294967295/4294967295 not found Dmin is
4294967295
1w2d: DUAL: Peer total/stub 3/0 template/full-stub 3/0
1w2d: DUAL: Dest 5.5.5.5/32 entering active state.
1w2d: DUAL: Set reply-status table. Count is 1.
1w2d: DUAL: Doing split horizon on Vlan13
1w2d: DUAL: Going from state 1 to state 3
1w2d: DUAL: dest(1.1.11
CCIE-SW1#.0/29) not active
1w2d: DUAL: rcvupdate: 1.1.11.0/29 via 1.1.10.4 metric 2585856/2585600
1w2d: DUAL: Find FS for dest 1.1.11.0/29. FD is 2585856, RD is 2585856
1w2d: DUAL: 1.1.10.3 metric 2585856/2585600
1w2d: DUAL: 1.1.10.4 metric 2585856/2585600 found Dmin is 2585856
1w2d: DUAL: RT installed 1.1.11.0/29 via 1.1.10.3
1w2d: DUAL: RT installed 1.1.11.0/29 via 1.1.10.4
1w2d: DUAL: dest(5.5.5.5/32) active
1w2d: DUAL: rcvreply: 5.5.5.5/32 via 1.1.9.6 metric
4294967295/4294967295
1w2d: DUAL: reply co
CCIE-SW1#unt is 1
1w2d: DUAL: Clearing handle 0, count now 0
1w2d: DUAL: Freeing reply status table
1w2d: DUAL: Find FS for dest 5.5.5.5/32. FD is 4294967295, RD is
4294967295
found
1w2d: DUAL: send REPLY(r1/n1) about 5.5.5.5/32 to 1.1.10.4
1w2d: DUAL: Removing dest 5.5.5.5/32, nexthop 1.1.9.6
1w2d: DUAL: Going from state 3 to state 1
1w2d: DUAL: Removing dest 5.5.5.5/32, nexthop 1.1.10.4
1w2d: DUAL: No routes. Flushing dest 5.5.5.5/32
And RIB for route 1.1.11.0/24 follows:
CCIE-SW1#sir 1.1.11.1
Routing entry for 1.1.11.0/29
Known via "eigrp 1", distance 170, metric 2585856, type external
Redistributing via eigrp 1
Last update from 1.1.10.4 on Vlan13, 00:00:36 ago
Routing Descriptor Blocks:
1.1.10.4, from 1.1.10.4, 00:00:36 ago, via Vlan13
Route metric is 2585856, traffic share count is 1
Total delay is 1010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
* 1.1.10.3, from 1.1.10.3, 00:00:36 ago, via Vlan13
Route metric is 2585856, traffic share count is 1
Total delay is 1010 microseconds, minimum bandwidth is 1000 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
What's the trick????!!!!
This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:58 ART