From: Bit Gossip (bit.gossip@chello.nl)
Date: Tue Jan 23 2007 - 17:57:41 ART
Hi Jo,
configure the prefix that you want as EX as secondary address; add
another prefix as primary and put the network statement only for this
one: this will bring up the adjacency! Then redistridute connected will
redistribute the secondary address as external which is what you want.
Luca
Labbed and it works!
Suppose that you want 192.168.0.0/24 as external
r1
interface Serial4/3
description ** r2 s4/3 **
ip address 192.168.0.1 255.255.255.0 secondary
ip address 10.0.0.1 255.255.255.0
!
router eigrp 1
network 10.0.0.1 0.0.0.0
no auto-summary
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
r2
interface FastEthernet0/0
ip address 10.0.1.2 255.255.255.0
!
interface Serial4/3
description ** r1 s4/3 **
ip address 192.168.0.2 255.255.255.0 secondary
ip address 10.0.0.2 255.255.255.0
!
router eigrp 1
redistribute connected metric 1 1 1 1 1500
network 10.0.0.2 0.0.0.0
network 10.0.1.2 0.0.0.0
no auto-summary
!
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
r3
interface FastEthernet0/0
ip address 10.0.1.3 255.255.255.0
!
router eigrp 1
network 10.0.1.3 0.0.0.0
no auto-summary
r3#show ip route
...
10.0.0.0/24 is subnetted, 2 subnets
D 10.0.0.0 [90/2172416] via 10.0.1.2, 00:10:15, FastEthernet0/0
C 10.0.1.0 is directly connected, FastEthernet0/0
D EX 192.168.0.0/24 [170/2560002816] via 10.0.1.2, 00:07:10,
FastEthernet0/0
On Tue, 2007-01-23 at 09:36 -0500, Jo Johnson wrote:
> Hi everyone,
>
>
>
> I am working on EIGRP and came across an issue that I can't resolve. How do
> you configure a device to advertise a prefix that is connected to another
> EIGRP neighbor as an External route? With the configuration below, the
> route continues to show up as internal with an AD of 90. If I take out the
> network statement for that prefix, my neighbor relationship goes down and
> the route is advertised as external. Neither solves my problem.
>
>
>
>
>
> router eigrp 99
>
> redistribute connected metric 1 1 1 1 1 route-map EXTERNAL
>
>
>
> route-map EXTERNAL permit 10
>
> match interface gig 0/0
>
>
>
>
>
>
>
> Thanks,
>
> Jo
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:57 ART