From: Bob Sinclair (bob@bobsinclair.net)
Date: Sat Jan 20 2007 - 14:37:20 ART
When doing per-VLAN class-maps on the 3550 you must use the "match-any"
syntax for the class-maps that do not match on VLANs. You must also put the
match VLAN statement first. Here is a working example:
vlan 201-202
!
access-list 100 permit ip any any
class-map match-any IP_TRAFFIC <<<<<<<<<<<<<<<<<<<<<<<
match access-group 100
class-map match-all VLAN_201
match vlan 201 <<<<<<<<<<<<<<<<<<<<<<<
match class-map IP_TRAFFIC
class-map match-all VLAN_202
match vlan 202 <<<<<<<<<<<<<<<<<<<<<<
match class-map IP_TRAFFIC
!
!
policy-map MARK_TRAFFIC
class VLAN_201
set precedence 5
class VLAN_202
set precedence 4
CAT3550(config)#int f0/1
CAT3550(config-if)#service-policy input MARK_TRAFFIC
CAT3550(config-if)#end
CAT3550#show policy-map interface f0/1
FastEthernet0/1
Service-policy input: MARK_TRAFFIC
Class-map: VLAN_201 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: vlan 201
Match: class-map match-any IP_TRAFFIC
Match: access-group 100
0 packets, 0 bytes
5 minute rate 0 bps
Class-map: VLAN_202 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: vlan 202
Match: class-map match-any IP_TRAFFIC
Match: access-group 100
0 packets, 0 bytes
5 minute rate 0 bps
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps
Hope That Helps!
Bob Sinclair
CCIE 10427 CCSI 30427
www.netmasterclass.net
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
deji500@hotmail.com
Sent: Saturday, January 20, 2007 10:48 AM
To: ccielab@groupstudy.com
Subject: IEWB-RS Technology Labs - 3550 QOS
Hi
When i configure a class-map with a match vlan statement, i get the
following error:
vlan 201-202
!
access-list 100 permit ip any any
class-map match-all IP_TRAFFIC
match access-group 100
class-map match-all VLAN_201
match class-map IP_TRAFFIC
match vlan 201
class-map match-all VLAN_202
match class-map IP_TRAFFIC
match vlan 202
!
!
policy-map MARK_TRAFFICE
class VLAN_201
set precedence 5
class VLAN_202
set precedence 4
%QM-4-CLASS_NOT_SUPPORTED: Classification is not supported in classmap
VLAN_202
01:47:44: %QM-4-CLASS_NOT_SUPPORTED: Classification is not supported in
classmap VLAN_202
01:47:44: %QM-4-CLASS_NOT_SUPPORTED: Classification is not supported in
classmap VLAN_202
I have gone through DocCD to see if a command is missing but no joy. When I
remove the match vlan (201 or 202) statement, I am able to apply the
service-policy to the interface.
I am hoping someone might know why i am getting the message.
Thanks
This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:57 ART