RE: BGP with link-local addresses

From: Bit Gossip (bit.gossip@chello.nl)
Date: Sun Jan 14 2007 - 14:53:10 ART


Hi Yasmin,
I couldn't find any attach to your last e-mail. Anyway I have to confirm
my first observation: if the source link-local address is not unique in
the router packet are not sent and so the BGP session doesn't come up! I
know that this is not correct but this is what happens at least on my
router:

Cisco IOS Software, 7200 Software (C7200-IK9S-M), Version 12.4(12)

Thanks,
Luca

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Scenario 1: not unique -> doesn't work

interface Serial4/0
 description ** frs s1/0 **
 no ip address
 encapsulation frame-relay
 load-interval 30
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial4/0.122 point-to-point
 bandwidth 64
 shutdown
 ipv6 address FE80::19 link-local
 ipv6 unnumbered Loopback0
 ipv6 rip 12 enable
 ipv6 rip 12 summary-address 2001:4:12:10::/60
 frame-relay interface-dlci 122
!
interface Serial4/0.124 point-to-point
 bandwidth 64
 ipv6 address FE80::19 link-local
 ipv6 unnumbered Loopback0
 frame-relay interface-dlci 124
....
router bgp 12
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor FE80::49 remote-as 44
 neighbor FE80::49 update-source Serial4/0.124
 !
 address-family ipv6
 neighbor FE80::49 activate
 exit-address-family

r1#show ipv6 int brief
Async1 [up/up]
    FE80::201:64FF:FE50:201C
    2001:730:12:1::1
FastEthernet1/0 [up/up]
    FE80::10
    2001:4:12:10::10
FastEthernet2/0 [up/up]
    FE80::11
    2001:4:12:11::11
FastEthernet3/0 [administratively down/down]
Serial4/0 [up/up]
Serial4/0.122 [administratively down/down]
    FE80::19
    unnumbered (Loopback0)
Serial4/0.124 [up/up]
    FE80::19
    unnumbered (Loopback0)

IPv6 unicast packet debugging is on (detailed)
r1(config-subif)#
*Jan 14 18:37:27.047: IPV6: source FE80::49 (Serial4/0.124)
*Jan 14 18:37:27.051: dest FE80::19
*Jan 14 18:37:27.051: traffic class 192, flow 0x0, len 64+4, prot
6, hops 64, forward to ulp
*Jan 14 18:37:27.051: IPV6: source FE80::19 (local)
*Jan 14 18:37:27.051: dest FE80::49 (Serial4/0.122)
*Jan 14 18:37:27.051: traffic class 192, flow 0x0, len 64+4, prot
6, hops 64, Invalid source address

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Scenario 2: unique -> does work

interface Serial4/0
 description ** frs s1/0 **
 no ip address
 encapsulation frame-relay
 load-interval 30
 serial restart-delay 0
 no frame-relay inverse-arp
!
interface Serial4/0.122 point-to-point
 bandwidth 64
 shutdown
 ipv6 address FE80::19 link-local
 ipv6 unnumbered Loopback0
 ipv6 rip 12 enable
 ipv6 rip 12 summary-address 2001:4:12:10::/60
 frame-relay interface-dlci 122
!
interface Serial4/0.124 point-to-point
 bandwidth 64
 ipv6 address FE80::124 link-local
 ipv6 unnumbered Loopback0
 frame-relay interface-dlci 124
....
router bgp 12
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor FE80::421 remote-as 44
 neighbor FE80::421 update-source Serial4/0.124
 !
 address-family ipv6
 neighbor FE80::421 activate
 exit-address-family

r1(config-router-af)#do show ipv6 int brief
Async1 [up/up]
    FE80::201:64FF:FE50:201C
    2001:730:12:1::1
FastEthernet1/0 [up/up]
    FE80::10
    2001:4:12:10::10
FastEthernet2/0 [up/up]
    FE80::11
    2001:4:12:11::11
FastEthernet3/0 [administratively down/down]
Serial4/0 [up/up]
Serial4/0.122 [administratively down/down]
    FE80::19
    unnumbered (Loopback0)
Serial4/0.124 [up/up]
    FE80::124
    unnumbered (Loopback0)

r1(config-router-af)#do show bgp ipv6 summary
BGP router identifier 1.1.1.1, local AS number 12
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
State/PfxRcd
FE80::421 4 44 9 9 1 0 0 00:05:17
0

On Fri, 2007-01-12 at 06:25 -0700, Yasmin Lara wrote:
> I did not configure the link local addresses (I only did IPv6 enable under the
> interfaces and configured a loopback on each router, with global addresses to
> test that indeed updates were going across) The router picked his own IPv6
> address based on MACs for the serial interface. I think the key is the update
> source command since the link local address as you said is unique. So, I don't
> think you have to configure link local address unless asked to do so.
>
> Regards,
>
> Yasmin
>
> ________________________________
>
> From: nobody@groupstudy.com on behalf of Bit Gossip
> Sent: Fri 1/12/2007 3:24 AM
> To: ccielab@groupstudy.com
> Subject: Re: BGP with link-local addresses
>
>
>
> Jim, Lara,
> thank you for the big help: indeed your configs works also in my lab.
> The big difference is that you have configured an explicit and unique
> link-local address on the interface and this makes a difference!
> In my original configuration I didn't configure a link-local address and
> so the IOS assigned one based on a mac-address of the router.
> Debugging IPv6 packets, I have noticed that the router can
> not source pkts from such serial links complaining with 'invalid source
> address'.
> Maybe because it is not unique??? Anyway configuring a unique link-local
> address makes the difference!
> A bug or a feature ? Certainly not a BGP problem....
>
> Shall we draw the conclusion: "Always configure a unique link-local
> address on serial interfaces if need to use them" ?
> Thanks,
> Luca.
>
>
> On Fri, 2007-01-12 at 06:39, Jim wrote:
> > I don't have any problem using the link-local address, please see
> > config below.
> >
> > r1:
> > ipv6 unicast-routing
> > interface Loopback0
> > ip address 2.2.1.1 255.255.255.0
> > !
> > interface Serial0/0.1 point-to-point
> > ipv6 address FEC0::2/64
> > ipv6 address FE80::1 link-local
> > frame-relay interface-dlci 201
> > !
> > router bgp 1
> > no synchronization
> > bgp log-neighbor-changes
> > neighbor FE80::2 remote-as 2
> > neighbor FE80::2 update-source Serial0/0.1
> > no neighbor FE80::2 activate
> > no auto-summary
> > !
> > address-family ipv6
> > neighbor FE80::2 activate
> > exit-address-family
> > !
> >
> > ####
> > r2:
> > ipv6 unicast-routing
> > interface Serial0/0.1 point-to-point
> > ipv6 address FEC0::1/64
> > ipv6 address FE80::2 link-local
> > frame-relay interface-dlci 210
> > !
> > router bgp 2
> > no synchronization
> > bgp log-neighbor-changes
> > neighbor FE80::1 remote-as 1
> > neighbor FE80::1 update-source Serial0/0.1
> > no neighbor FE80::1 activate
> > no auto-summary
> > !
> > address-family ipv6
> > neighbor FE80::1 activate
> > exit-address-family
> >
> >
> > ### show output
> > r1:
> > # show bgp ipv6 summ
> > BGP router identifier 2.2.1.1, local AS number 1
> > BGP table version is 1, main routing table version 1
> >
> > Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
> > State/PfxRcd
> > FE80::2 4 2 5 5 1 0 0
> > 00:02:22 0
> >
> >
> > r1(config)#do sh bgp ipv6 summ
> > BGP router identifier 2.2.1.1, local AS number 1
> > BGP table version is 1, main routing table version 1
> >
> > Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
> > State/PfxRcd
> > FE80::2 4 2 5 5 1 0 0
> > 00:02:22 0
> > % NOTE: This command is deprecated. Please use 'show bgp ipv6 unicast'
> >
> > r1(config)#do sh bgp ipv6 uni nei
> > BGP neighbor is FE80::2, remote AS 2, external link
> > ...
> > Connection state is ESTAB, I/O status: 1, unread input bytes:
> > 0
> > Connection is ECN Disabled, Mininum incoming TTL 0, Outgoing TTL 1
> > Local host: FE80::1, Local port: 15843
> > Foreign host: FE80::2, Foreign port: 179
> >
> >
> > r2(config-router-af)#do show bgp ipv6 uni summ
> > BGP router identifier 2.2.13.2, local AS number 2
> > BGP table version is 1, main routing table version 1
> >
> > Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
> > State/PfxRcd
> > FE80::1 4 1 11 11 1 0 0
> > 00:08:46 0
> > r2(config-router-af)#do show bgp ipv6 uni nei
> > BGP neighbor is FE80::1, remote AS 1, external link
> > ...
> > Connection state is ESTAB, I/O status: 1, unread input bytes: 0
> > Connection is ECN Disabled
> > Local host: FE80::2, Local port: 179
> > Foreign host: FE80::1, Foreign port: 15843
> >
> >
> > On 1/11/07, Bit Gossip <bit.gossip@chello.nl> wrote:
> > Group,
> > there is no way I can bring up a BGP session using IPv6
> > link-local
> > addresses over a point-point FR link. Same story for a GRE
> > tunnel.
> > While it works fine over a ethernet connection.
> >
> > I noticed that even if I can ping the link-local address of
> > the peer, I
> > can not telnet it; maybe this is the problem.
> >
> > Did someone succeeded in this task?
> >
> > Thanks,
> > Luca
> >
> >
> _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Feb 08 2007 - 23:46:56 ART