From: cadet (cadet22@gmail.com)
Date: Thu Nov 23 2006 - 07:52:59 ART
Hi All !
I need help with RIP traffic-share min across-interfaces !
I have next topology:
fa0/0 sw1 (L3)
R1-- R2 -- ---- R4
fa0/1 sw2 (L3)
Routing protocol - rip
R4 have lo0 14.14.4.4
I need load-balanced in rip
r2#sh ip route 14.14.4.0
Routing entry for 14.14.4.0/24
Known via "rip", distance 120, metric 2
Redistributing via rip
Last update from 14.14.50.8 on FastEthernet0/1, 00:00:16 ago
Routing Descriptor Blocks:
14.14.50.8, from 14.14.50.8, 00:00:16 ago, via FastEthernet0/1
Route metric is 2, traffic share count is 1
* 14.14.40.7, from 14.14.40.7, 00:00:22 ago, via FastEthernet0/0
Route metric is 2, traffic share count is 1
R2:
router rip
version 2
traffic-share min across-interfaces
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Serial0/0
no passive-interface FastEthernet0/1
network 14.0.0.0
no auto-summary
I use command "traffic-share min across-interfaces"
I create 2 ACL on fa0/0 R2 and R2 fa0/1 for test
r2#sh access-lists
Extended IP access list test
10 permit icmp any any log
20 permit ip any any
Extended IP access list test2
10 permit icmp any any log
20 permit ip any any
r2#sh run int fa0/0
Building configuration...
Current configuration : 149 bytes
!
interface FastEthernet0/0
ip address 14.14.40.4 255.255.255.0
ip access-group test out
duplex auto
speed auto
end
r2#sh run int fa0/1
Building configuration...
Current configuration : 150 bytes
!
interface FastEthernet0/1
ip address 14.14.50.4 255.255.255.0
ip access-group test2 out
duplex auto
speed auto
end
TEST 1 only traffic-share min across-interfaces:
r1#ping 14.14.4.4 repeat 40
Type escape sequence to abort.
Sending 40, 100-byte ICMP Echos to 14.14.4.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (40/40), round-trip min/avg/max = 28/36/128 ms
r2#sh access-lists
Extended IP access list test
10 permit icmp any any log
20 permit ip any any
Extended IP access list test2
10 permit icmp any any log (40 matches)
20 permit ip any any
TEST 2 traffic-share min across-interfaces + ip load-sharing
per-packet on interfaces fa0/0 and fa0/1:
r1#ping 14.14.4.4 repeat 40
Type escape sequence to abort.
Sending 40, 100-byte ICMP Echos to 14.14.4.4, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (40/40), round-trip min/avg/max = 28/36/128 ms
r2#sh access-lists
Extended IP access list test
10 permit icmp any any log (20 matches)
20 permit ip any any
Extended IP access list test2
10 permit icmp any any log (20 matches)
20 permit ip any any
So traffic-share min across-interfaces do not traffic-share between
several interfaces ?
Regards.
Max
This archive was generated by hypermail 2.1.4 : Fri Dec 01 2006 - 08:05:48 ART