From: Mengdi Cao (xianglingzj@gmail.com)
Date: Mon Oct 02 2006 - 13:13:59 ART
Hi, Everyone,
Saw a really wired problem when I see this problem today in Lab17.
Briefly, R1, R2 and R5 connects through FR, with R5 having a P2MP
subinterface
R5 --- R1
|
R2
Interface configuration:
R1:
interface Serial0
ip address 173.1.125.1 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 173.1.125.2 105
frame-relay map ip 173.1.125.5 105 broadcast
no frame-relay inverse-arp
R2:
interface Serial0
ip address 173.1.125.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 173.1.125.1 205
frame-relay map ip 173.1.125.5 205 broadcast
no frame-relay inverse-arp
end
R5:
interface Serial0.125 multipoint
ip address 173.1.125.5 255.255.255.0
ip ospf network non-broadcast
ip ospf priority 10
frame-relay interface-dlci 501
frame-relay interface-dlci 502
end
OSPF is enabled on these interfaces with singel network statement matching
the interface IP only. When the adjacency formed, it looks like:
Rack1R5#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
150.1.1.1 1 FULL/DROTHER 00:01:57 173.1.125.1
Serial0.125
150.1.2.2 1 FULL/DR 00:01:54 173.1.125.2
Serial0.125
It seems that R2 is elected DR instead of R5, despite of the fact that R5's
interface priority is 10, others are 1.
More wired things comes one when I revoked the eligibility of being a
DR/BDR:
Rack1R2#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Rack1R2(config)#int s0
Rack1R2(config-if)#ip ospf pri 0
Rack1R2(config-if)#^Z
Rack1R2#
Now it's R1's turn to be DR:
Rack1R5#clear ip ospf pro
Reset ALL OSPF processes? [no]: y
Rack1R5#
*Mar 1 02:21:21.791: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.1.1 on
Serial0.125 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar 1 02:21:21.799: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.2.2 on
Serial0.125 from 2WAY to DOWN, Neighbor Down: Interface down or detached
Rack1R5#
*Mar 1 02:23:27.087: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.1.1 on
Serial0.125 from LOADING to FULL, Loading Done
Rack1R5#
*Mar 1 02:23:32.043: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.2.2 on
Serial0.125 from LOADING to FULL, Loading Done
Rack1R5#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
150.1.1.1 1 FULL/DR 00:01:58 173.1.125.1
Serial0.125
150.1.2.2 0 FULL/DROTHER 00:01:50 173.1.125.2
Serial0.125
As R5 has to be DR for P2MP network, I further revoked R1's eligibility:
Rack1R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Rack1R1(config)#int s0
Rack1R1(config-if)#ip ospf pri 0
Rack1R1(config-if)#^Z
Rack1R1#^Z
Then the thing comes to an end, R5-R2 neighbour relationship is gone after I
clear the ospf processs!!
Rack1R5#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
150.1.1.1 0 FULL/DROTHER 00:01:56 173.1.125.1
Serial0.125
Rack1R5#clear ip ospf prot
^
% Invalid input detected at '^' marker.
Rack1R5#clear ip ospf proc
Reset ALL OSPF processes? [no]: y
Rack1R5#
*Mar 1 03:57:10.795: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.1.1 on
Serial0.125 from 2WAY to DOWN, Neighbor Down: Interface down or detached
Rack1R5#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
150.1.1.1 0 FULL/DROTHER 00:01:59 173.1.125.1
Serial0.125
Rack1R5#
*Mar 1 03:59:16.167: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.1.1 on
Serial0.125 from LOADING to FULL, Loading Done
Rack1R5#
Rack1R5#sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
150.1.1.1 0 FULL/DROTHER 00:01:58 173.1.125.1
Serial0.125
I checked the output of show ip ospf interface command, nothing found:
Rack1R1#sh ip ospf int s0
Serial0 is up, line protocol is up
Internet Address 173.1.125.1/24, Area 0.0.0.0
Process ID 1, Router ID 150.1.1.1, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
Designated Router (ID) 150.1.5.5, Interface address 173.1.125.5
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:20
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 4
Last flood scan time is 4 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 150.1.5.5 (Designated Router)
Suppress hello for 0 neighbor(s)
Rack1R2#sh ip ospf int s0
Serial0 is up, line protocol is up
Internet Address 173.1.125.2/24, Area 0.0.0.0
Process ID 1, Router ID 150.1.2.2, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DROTHER, Priority 0
No designated router on this network
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:11
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 3
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
Rack1R5#sh ip ospf int s0.125
Serial0.125 is up, line protocol is up
Internet Address 173.1.125.5/24, Area 0.0.0.0
Process ID 1, Router ID 150.1.5.5, Network Type NON_BROADCAST, Cost: 64
Transmit Delay is 1 sec, State DR, Priority 255
Designated Router (ID) 150.1.5.5, Interface address 173.1.125.5
No backup designated router on this network
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:24
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 8
Last flood scan time is 0 msec, maximum is 8 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 150.1.1.1
Suppress hello for 0 neighbor(s)
Rack1R5#
Reviewed my final OSPF configuration, it seems also OK:
Rack1R1#sh run | b router ospf
router ospf 1
router-id 150.1.1.1
log-adjacency-changes
network 150.1.1.1 0.0.0.0 area 0.0.0.0
network 173.1.13.1 0.0.0.0 area 0.0.0.0
network 173.1.125.1 0.0.0.0 area 0.0.0.0
network 173.1.137.1 0.0.0.0 area 0.0.0.137
!
Rack1R2#sh run | b router osp
router ospf 1
router-id 150.1.2.2
log-adjacency-changes
area 0.0.0.23 nssa
network 150.1.2.2 0.0.0.0 area 0.0.0.0
network 173.1.23.2 0.0.0.0 area 0.0.0.23
network 173.1.32.2 0.0.0.0 area 0.0.0.0
network 173.1.125.2 0.0.0.0 area 0.0.0.0
!
Rack1R5#sh run | b router ospf 1
router ospf 1
router-id 150.1.5.5
log-adjacency-changes
redistribute eigrp 10 metric-type 1 subnets
network 150.1.5.5 0.0.0.0 area 0.0.0.0
network 173.1.125.5 0.0.0.0 area 0.0.0.0
!
Anybody got some hint on what is really happening? And how to correct
this? Thanks a lot!!
This archive was generated by hypermail 2.1.4 : Wed Nov 01 2006 - 07:29:04 ART