From: David Timmons (masterdt@yahoo.com)
Date: Thu Sep 21 2006 - 15:39:15 ART
That makes sense,
I know that the address is made up of the IPv4 routing table; however, I never saw where they said you must have a route to other IPv4 address for this connectivity to be successul. Also, I wonder why you would need a relay agent if it had a route to the IPv4 destination. Would you not assume it could build a tunnel directly to the IPv4 peer using 6to4 tunnel? In the Docs and RFC, they give me the impression that you must have a relay agent. Thanks for the info!
dt
----- Original Message ----
From: Radoslav Vasilev <deckland@gmail.com>
To: David Timmons <masterdt@yahoo.com>
Cc: CCIElab <ccielab@groupstudy.com>
Sent: Wednesday, September 20, 2006 4:59:51 PM
Subject: Re: Automatic 6to4 (HELP)
Hi David,
It's a simple concept:
1. you have IPv4 core network
2. you want to provide IPv6 transport over the core using tunneling
without configuring full-mesh tunnel infrastructure
Solution:
1. you build ipv6 address using 2002::/16 and your IPv4 address (in
hex!!!) (the ipv6 prefix is therefore /48 prefix
2. you can subnet the /48 prefix for addressing the different ipv6 sites
3. configure the tunnels on your border routers (connecting the ipv6
sites to the ipv4 core):
interface Ethernet0
description IPv4 uplink
ip address 192.168.99.1 255.255.255.0
interface Tunnel0
description IPv6 uplink
no ip address
ipv6 address 2002:c0a8:6301::1/64
tunnel source Ethernet 0
tunnel mode ipv6ip 6to4
If you noticed, the address above is within the prefix: 2002:c0a8:6301::/48
c0a8:6301 is actually 192.168.99.1 in hex.
When the router needs to send ipv6 packets to destination routed out
this tunnel interface, the destination will be automatically
determined based on the destination IPv6
address - like in the shown local router configuration, the remote
router(s) have ipv6 addresses corresponding to an IPv4 address
reachable through the core ipv4 network.
For example, if the local router receives packet for
2002:c0a8:6302::3, it will determine that the corresponding ipv4
address is 192.168.99.2 and this will be the tunnel destination
Rado
On 9/20/06, David Timmons <masterdt@yahoo.com> wrote:
> Hi,
>
> I was trying to figure out how Automatic IPV6 6to4 tunnels works. At the moment, I am most interested in how they are able to discover the remote side. Cisco's website has said that it uses the IPV4 address to find the other side. They have also said that no configuration is required to discover the other side. I have also read that you must have static and or BGP/routing. Since most of the examples I have seen do not have the IPV4 part of the IP on the adjacent router, I don't see how it could be used with respect to the IPV4 routing table. I have seen mentions of 6to4 IPV6 anycast. Really, I just don't understand how this technology is working. Can anyone provide some information or good sources?
>
> looked at links like:
> http://www.cisco.com/en/US/partner/tech/tk872/technologies_design_guide09186a00800d6a19.shtml
>
> This PP seems to show up in many of Cisco's documents:
> 6to4 tunneling is a technique where the tunnel endpoint is determined by the globally unique IPv4 address embedded in a 6to4 address. A 6to4 IPv6 address is a combination of the unique routing prefix 2002::/16 and a globally unique 32-bit IPv4 address. (IPv4-compatible IPv6 addresses are a different format from 6to4 IPv6 addresses. IPv4-compatible IPv6 addresses are not used in 6to4 tunneling.) 6to4 tunnels are configured between border routers, or between a border router and a host. 6to4 tunnels require that a 6bone 6to4 relay site be identified to provide the 6to4 relay service to the enterprise. The 6to4 relay site will configure a dual-stack border router that will become the endpoint for the enterprise 6to4 tunnel. After the 6to4 relay site sets up for 6to4 tunneling, its management burden is minimal. At the enterprise end, a simple router configuration enables access to the 6bone through the 6to4 tunnel.
>
>
> These are my current notes:
> d. Automatic 6to4
> i. http://www.ietf.org/rfc/rfc3964.txt
> ii. Not point-to-point
> iii. Point to multipoint
> iv. IPV4 address is embedded in IPV6 Address
> 1) Used to find other end
> 2) IPV4 address does not need to be on same subnet
> v. Normally used to connect multiple sites
> 1) Network is treated as a NBMA
> vi. Virtual no broadcast multi-access (NBMA) link
> vii. uses 6to4 IPV4 anycast RFC 3068
> viii. Limitations
> B7 This solution is limited to static or BGP4+ routing
>
>
>
> ix. Example
> interface Tunnel0
> description IPv6 uplink
> no ip address
> ipv6 address 2002:c0a8:6301::1/64
> tunnel source Ethernet 0
> tunnel mode ipv6ip 6to4
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:41 ART