From: Chris Broadway (midatlanticnet@gmail.com)
Date: Sun Sep 03 2006 - 17:45:23 ART
Hey all...I am really bad at QoS and decided to make myself some study notes
that go thru each QoS mechanism and the legacy/MQC method for it. Can
someone that is very proficient at QoS go over these notes? If they are
good, they are for all to enjoy. Alot of the commands were typed out and
not "cut and paste", so please leave out the critiques on spelling and
grammar. This is very long but hopefully should contain the foundation we
all need.
Congestion management:
* Legacy*-WWW traffic in a higher queue that all other traffic
queue-list 1 protocol ip 1 tcp WWW
queue-list 1 protocol ip 2 default
!
int eth 0/0
custom-queue-list 1
Shows web traffic in queue one
Rack1R4#sh queueing interface e0/0
Interface Ethernet0/0 queueing strategy: custom
Output queue utilization (queue/count)
0/32 1/2 2/4186 3/0 4/0 5/0 6/0 7/0 8/0
9/0 10/0 11/0 12/0 13/0 14/0 15/0 16/0
*MQC*-WWW traffic is given a minimum bandwidth (3MEG) in times of
congestion
access-list 100 permit tcp any eq www any
access-list 100 permit ip any any
!
class-map match-all WEB_CLASS
match access access-group 100
!
policy-map WEB_POLICY
class WEB_CLASS
bandwidth 3000000
!
int eth 0/0
service-policy output WEB_POLICY
Shows web traffic polcy
Rack1R4#sh policy-map int e0/0
Ethernet0/0
Service-policy output: WEB_POLICY
Class-map: WEB_CLASS (match-all)
2 packets, 116 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
Queueing
Output Queue: Conversation 265
Bandwidth 3000 (kbps) Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
23 packets, 2010 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
-----------------------------------------
Prioritization:
*Legacy*-WWW traffic is given a higher priority than all other traffic
priority-list 1 protocol ip high tcp www
priority-list 1 default normal
!
int eth 0/0
priority-group 1
Shows web traffic in high queue
Rack1R4#sh queueing int e0/0
Interface Ethernet0/0 queueing strategy: priority
Output queue utilization (queue/count)
high/100 medium/0 normal/64 low/0
*MQC*-WWW traffic will have a guarentee of 2 meg when there is congestion
access-list 100 permit tcp any any eq www
!
class-map match-all PRIORITY_CLASS
match access-group 100
!
policy-map PRI_POLICY
class PRIORITY_CLASS
priority 2000
!
int eth 0/0
service-policy output PRI_POLCY
shows web traffic queue and bandwidth
Rack1R4#sh policy-map in e0/0
Ethernet0/0
Service-policy output: PRI_POLICY
Class-map: PRIORITY_CLASS (match-all)
4 packets, 232 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 100
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 2000 (kbps) Burst 50000 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
1070 packets, 119926 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:39 ART