From: sabrina pittarel (sabri_esame@yahoo.com)
Date: Sat Sep 02 2006 - 02:03:52 ART
I agree with you theoretically, but I see how my routers are behaving (never said I'm happy with what I'm seeing). You are welcome to explain it to me ;-)
Let me show you.
Topology:
---------------
Lo0 R3 ----------------------- R6---------------
Area 0 Area10 Area20
R3#sh run | b router ospf
router ospf 1
router-id 150.1.3.3
log-adjacency-changes
area 10 virtual-link 150.1.6.6
network 136.1.36.0 0.0.0.255 area 10
network 150.1.3.3 0.0.0.0 area 0
R6#sh run | b router ospf
router ospf 1
router-id 150.1.6.6
log-adjacency-changes
area 10 virtual-link 150.1.3.3
network 136.1.36.0 0.0.0.255 area 10
network 150.1.6.6 0.0.0.0 area 20
R3#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
150.1.6.6 0 FULL/ - 00:00:36 136.1.36.6 Virtual-Access1
R3#
R3#sh ip ospf virtual-links
Virtual Link OSPF_VL0 to router 150.1.6.6 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 10, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R3#
R3#sh ip ospf | i Area BACKBONE
Area BACKBONE(0) (Inactive)
R3#
Now let me add another link on area 0:
R3#
R3(config)#
R3(config)#router ospf 1
R3(config-router)#network 136.1.23.0 0.0.0.255 area 0
R3(config-router)#
R3#
*Sep 2 04:59:30.508: %SYS-5-CONFIG_I: Configured from console by console
R3#
*Sep 2 04:59:42.220: %OSPF-5-ADJCHG: Process 1, Nbr 150.1.6.6 on OSPF_VL0 from LOADING to FULL, Loading Done
R3#
R3#
R3#
R3#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
150.1.6.6 0 FULL/ - - 136.1.36.6 OSPF_VL0
150.1.6.6 0 FULL/ - 00:00:30 136.1.36.6 Virtual-Access1
R3#sh ip ospf virtual-links
Virtual Link OSPF_VL0 to router 150.1.6.6 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 10, via interface Serial1/0, Cost of using 10
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 1
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
R3#
Sabrina
----- Original Message ----
From: Victor Cappuccio <cvictor@protokolgroup.com>
To: sabrina pittarel <sabri_esame@yahoo.com>; beatccielab <beatccielab@gmail.com>; swm@emanon.com
Cc: ccielab@groupstudy.com
Sent: Friday, September 1, 2006 9:48:51 PM
Subject: RE: Virtual Link
Sabrina, that does not really matters, I have seen a discuss near this days
between Scott and Brain about the need of an interface in area 0 that is
pretty good to read.
Now for the other part is this configuration looks good for you?
R1(config-router)#do show ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Vl0 1 0 150.1.13.1/24 64 P2P 0/1
Lo0 1 0 150.1.1.1/24 1 LOOP 0/0
Se0/1 1 10 150.1.13.1/24 64 P2P 1/1
R1(config-router)#do s
%OSPF-5-ADJCHG: Process 1, Nbr 151.1.3.3 on OSPF_VL0 from LOADING to FULL,
Loading Done
===========
R3(config-router)#do show ip ospf neigh
Neighbor ID Pri State Dead Time Address Interface
151.1.1.1 0 FULL/ - - 150.1.13.1 OSPF_VL1
1511.1.1.1 0 FULL/ - 00:00:38 150.1.13.1 Serial0/2
R3(config-router)#do show ip ospf inter brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Vl1 1 0 150.1.13.3/24 64 P2P 1/1
Se0/2 1 10 150.1.13.3/24 64 P2P 1/1
Lo0 1 264 150.1.3.3/24 1 P2P 0/0
Saludos,
Victor.-
-----Mensaje original-----
De: nobody@groupstudy.com [mailto:nobody@groupstudy.com] En nombre de
sabrina pittarel
Enviado el: Viernes, 01 de Septiembre de 2006 11:48 p.m.
Para: beatccielab; swm@emanon.com
CC: ccielab@groupstudy.com
Asunto: Re: Virtual Link
Sorry,
just checked your configs. You *are* using a loopback to simulate Area0
Try using a physical port.
Sabrina
----- Original Message ----
From: sabrina pittarel <sabri_esame@yahoo.com>
To: beatccielab <beatccielab@gmail.com>; swm@emanon.com
Cc: ccielab@groupstudy.com
Sent: Friday, September 1, 2006 8:46:01 PM
Subject: Re: Virtual Link
Are you using a loopback interface on R5 to represent area 0?
I've just lab it out and I saw your same behavior (even the area 0
inactive) until I haven't used a real link for my area 0.
Sabrina
----- Original Message ----
From: beatccielab <beatccielab@gmail.com>
To: swm@emanon.com
Cc: ccielab@groupstudy.com
Sent: Friday, September 1, 2006 8:16:21 PM
Subject: Re: Virtual Link
Dear All,
There is my configuration before issued virtual-link command...
interface loopback 0
ip address 1.1.1.1 255.255.255.0
interface Serial0/1/0
no ip address
encapsulation frame-relay
frame-relay interface-dlci 501 ppp Virtual-Template1
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Virtual-Template1
ip address 172.16.1.5 255.255.255.0
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 172.16.1.5 0.0.0.0 area 10
R5#sh ip os nei
2.2.2.2 0 FULL/ - 00:00:39 172.16.1.6
Virtual-Access1
R5#
R5#sh ip int br
Interface IP-Address OK? Method Status
Protocol
Serial0/1/0 unassigned YES NVRAM up
up
Virtual-Access1 172.16.1.5 YES TFTP up
up
Virtual-Template1 172.16.1.5 YES NVRAM down
down
Virtual-Access2 unassigned YES unset down
down
Loopback0 1.1.1.1 YES NVRAM up
up
R5#
R5#ping 172.16.1.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
R5#
R5#ping 192.1.24.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.1.24.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R5#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms
R6
interface loopback 0
ip address 2.2.2.2 255.255.255.0
!
interface Serial0/2/0
no ip address
encapsulation frame-relay
frame-relay interface-dlci 105 ppp Virtual-Template1
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Virtual-Template1
ip address 172.16.1.6 255.255.255.0
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 10
network 172.16.1.6 0.0.0.0 area 10
network 192.1.24.2 0.0.0.0 area 24
R6#sh ip int br
Interface IP-Address OK? Method Status
Protocol
FastEthernet0/0 unassigned YES NVRAM up
up
FastEthernet0/0.13 192.1.24.2 YES NVRAM up
up
Serial0/0/0 unassigned YES NVRAM administratively down
down
Serial0/0/1 unassigned YES NVRAM administratively down
down
Serial0/2/0 unassigned YES NVRAM up
up
Virtual-Access1 172.16.1.6 YES TFTP up
up
Virtual-Template1 172.16.1.6 YES NVRAM down
down
Virtual-Access2 unassigned YES unset down
down
Loopback0 2.2.2.2 YES NVRAM up
up
R6#
R6#sh ip osp nei
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:31 172.16.1.5
Virtual-Access1
150.1.3.3 1 FULL/BDR 00:00:36 192.1.24.3
FastEthernet0/0.13
R6#ping 172.16.1.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/60/68 ms
R6#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
R6#
the connectivity has been done.. but if i issued virtual link command, Area
0 bacbbone is inactive at R6. and virtual link still down..
On 9/2/06, Scott Morris <swm@emanon.com> wrote:
>
> A few things to keep in mind:
>
> 1. OSPF won't be enabled on your serial interfaces since you are just
> running "ppp" at that level (no ip address)
>
> 2. Your virtual-template is NOT an interface, so it will always show
> down.
>
> 3. Check on your virtual-ACCESS interfaces as these are what dynamically
> gets created by the PPP process actually working.
>
> 4. Brian is right, make sure you have a "normal" peering relationship
> working on the interface BEFORE attempting to build the virtual
> link. That
> way if/when something doesn't work, your troubleshooting process is much
> smaller!
>
> Don't forget the basics there!
>
> HTH,
>
>
> Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713, JNCIE
> #153, CISSP, et al.
> CCSI/JNCI-M/JNCI-J
> IPExpert VP - Curriculum Development
> IPExpert Sr. Technical Instructor
> smorris@ipexpert.com
> http://www.ipexpert.com
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> beatccielab
> Sent: Friday, September 01, 2006 1:28 PM
> To: Brian Dennis
> Cc: ccielab@groupstudy.com
> Subject: Re: Virtual Link
>
> Hi Brian,
>
> This result Show ip ospf interface from R5 and R2
>
> R5#sh ip osp int s0/0/0
> %OSPF: OSPF not enabled on Serial0/0/0
> R5#sh ip osp int virtua
> R5#sh ip osp int virtual-te
> R5#sh ip osp int virtual-template 1
> Virtual-Template1 is down, line protocol is down
> Internet Address 172.16.1.5/24, Area 10
> Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
> Transmit Delay is 1 sec, State DOWN,
> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> oob-resync timeout 40
> R5#
>
> R2#show ip ospf interface virtual-template 1
> Virtual-Template1 is down, line protocol is down
> Internet Address 172.16.1.6/24, Area 10
> Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_POINT, Cost: 1
> Transmit Delay is 1 sec, State DOWN,
> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> oob-resync timeout 40
> R2#show ip ospf interface s0/2/0
> %OSPF: OSPF not enabled on Serial0/2/0
>
> I was verify the connection before configure virtual link but all
> connection
> from R5 and R2 can reach, but after i was configure virtual link, virtual
> link still down..
>
> Rgrds,
> Felix
>
>
> On 9/2/06, Brian Dennis <bdennis@internetworkexpert.com> wrote:
> >
> > You actually show a neighbor on R2 to R1 across the PPPoFR link but
> > you don't have a network statement for the PPPoFR link on R2. Can you
> > send a show ip ospf interface from R2?
> >
> > router ospf 1
> > router-id 2.2.2.2
> > area 10 virtual-link 1.1.1.1
> > network 2.2.2.2 0.0.0.0 area 10
> > network 192.1.24.2 0.0.0.0 area 24
> > !
> >
> > R2#sh ip osp nei
> >
> > Neighbor ID Pri State Dead Time Address Interface
> > 1.1.1.1 0 FULL/ - 00:00:30 172.16.1.5
> > Virtual-Access1
> > 150.1.3.3 1 FULL/DR 00:00:35 192.1.24.5
> > FastEthernet0/0
> >
> > HTH,
> >
> > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > bdennis@internetworkexpert.com
> >
> > Internetwork Expert, Inc.
> > http://www.InternetworkExpert.com
> > Toll Free: 877-224-8987
> > Direct: 775-745-6404 (Outside the US and Canada)
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> > Of Brian Dennis
> > Sent: Friday, September 01, 2006 9:36 AM
> > To: beatccielab; ccielab@groupstudy.com
> > Subject: RE: Virtual Link
> >
> > On R6 you do not have OSPF enabled on the PPPoFR connection.
> >
> > router ospf 1
> > router-id 2.2.2.2
> > area 10 virtual-link 1.1.1.1
> > network 2.2.2.2 0.0.0.0 area 10
> > network 192.1.24.2 0.0.0.0 area 24
> >
> > You should always check to ensure that the OSPF neighbors have formed
> > BEFORE configuring a virtual link.
> >
> > 1) Bring up the link
> > 2) Ping across the link
> > 3) Enable OSPF on the link
> > 4) Verify the OSPF neighbors
> > 5) Configure the OSPF virtual link
> >
> > HTH,
> >
> > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > bdennis@internetworkexpert.com
> >
> > Internetwork Expert, Inc.
> > http://www.InternetworkExpert.com
> > Toll Free: 877-224-8987
> > Direct: 775-745-6404 (Outside the US and Canada)
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> > Of beatccielab
> > Sent: Friday, September 01, 2006 8:25 AM
> > To: ccielab@groupstudy.com
> > Subject: Virtual Link
> >
> > Hi all,
> >
> > I have problem with my configuration OSPF virtual link over ppp over
> > frame relay..
> >
> > Configuration Scenario like this :
> >
> > area 0 ---R5--- FRS/area10 --- R2--- area24 ---Cat1
> >
> > my case say: R2 not use subinterface..
> >
> > i already configure like this :
> >
> > R5:
> > interface Serial0/1/0
> > no ip address
> > encapsulation frame-relay
> > frame-relay interface-dlci 501 ppp Virtual-Template1 no frame-relay
> > inverse-arp !
> >
> >
> > interface Virtual-Template1
> > ip address 172.16.1.5 255.255.255.0
> >
> > router ospf 1
> > router-id 1.1.1.1
> > area 10 virtual-link 2.2.2.2
> > network 1.1.1.1 0.0.0.0 area 10
> > network 172.16.1.5 0.0.0.0 area 10
> >
> > R5#sh ip os nei
> >
> > Neighbor ID Pri State Dead Time Address
> > Interface
> > 2.2.2.2 0 FULL/ - 00:00:38 172.16.1.6
> > Virtual-Access1
> >
> > R5#sh ip os vi
> > Virtual Link OSPF_VL0 to router 2.2.2.2 is down
> > Run as demand circuit
> > DoNotAge LSA allowed.
> > Transit area 5, Cost of using 65535
> > Transmit Delay is 1 sec, State DOWN,
> > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> >
> >
> > R6:
> > interface Serial0/1/0
> > no ip address
> > encapsulation frame-relay
> > frame-relay interface-dlci 105 ppp Virtual-Template1 no frame-relay
> > inverse-arp !
> > interface Virtual-Template1
> > ip address 172.16.1.6 255.255.255.0
> > !
> > interface FastEthernet0/0
> > no ip address
> > !
> > interface FastEthernet0/0.24
> > encapsulation dot1Q 24
> > ip address 192.1.24.2 255.255.255.0
> > !
> > router ospf 1
> > router-id 2.2.2.2
> > area 10 virtual-link 1.1.1.1
> > network 2.2.2.2 0.0.0.0 area 10
> > network 192.1.24.2 0.0.0.0 area 24
> > !
> >
> > R2#sh ip os vir
> > Virtual Link OSPF_VL0 to router 1.1.1.1 is down
> > Run as demand circuit
> > DoNotAge LSA allowed.
> > Transit area 5, Cost of using 65535
> > Transmit Delay is 1 sec, State DOWN,
> > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> >
> > R2#sh ip osp nei
> >
> > Neighbor ID Pri State Dead Time Address
> > Interface
> > 1.1.1.1 0 FULL/ - 00:00:30 172.16.1.5
> > Virtual-Access1
> > 150.1.3.3 1 FULL/DR 00:00:35 192.1.24.5
> > FastEthernet0/0.
> >
> >
> > Cat1
> >
> > interface FastEthernet0/1
> > switchport trunk encapsulation dot1q
> > switchport trunk allowed vlan 24
> > switchport mode trunk
> >
> > interface Loopback0
> > ip address 150.1.3.3 255.255.255.0
> >
> > interface Vlan13
> > ip address 192.1.24.5 255.255.255.0
> >
> > router ospf 1
> > router-id 150.1.3.3
> > log-adjacency-changes
> > network 150.1.3.3 0.0.0.0 area 24
> > network 198.1.24.5 0.0.0.0 area 24
> >
> >
> > If issued show ip ospf virtual always down whereas if we issued sh ip
> > ospf nei the router another site appears...
> > Please advice me how to fix it this problem...
> >
> > Regards,
> > beatccielab
> >
> > ______________________________________________________________________
> > _ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > ______________________________________________________________________
> > _ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
-- Regards, beatccielab
This archive was generated by hypermail 2.1.4 : Sun Oct 01 2006 - 16:55:39 ART