From: Petr Lapukhov (petr@internetworkexpert.com)
Date: Sat Aug 26 2006 - 03:53:01 ART
Hello guys,
One may also use QoS pre-classify to match "PPP-encapsulated" packets
on *physical* interface:
interface Serial0/0/0.1 point-to-point
frame-relay interface-dlci 201 ppp Virtual-Template1
service-policy output SHAPE
interface Virtual-Template1
ip address 54.1.7.6 255.255.255.0
qos pre-classify
ppp chap hostname ROUTER6
ppp chap password 0 CISCO
class-map match-all ICMP
match access-group name ICMP
!
!
policy-map QOS
class ICMP
priority 16
policy-map SHAPE
class class-default
shape average 64000
service-policy QOS
------------------------------------
Rack1R6#ping 54.1.7.254 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 54.1.7.254, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 28/33/128 ms
Rack1R6#show policy-map interface serial 0/0/0.1
Serial0/0/0.1
Service-policy output: SHAPE
Class-map: class-default (match-any)
243 packets, 13874 bytes
5 minute offered rate 3000 bps, drop rate 0 bps
Match: any
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
64000/64000 2000 8000 8000 125 1000
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 0 243 13874 0 0 no
Service-policy : QOS
Class-map: ICMP (match-all)
100 packets, 10600 bytes
5 minute offered rate 3000 bps, drop rate 0 bps
Match: access-group name ICMP
Queueing
Strict Priority
Output Queue: Conversation 24
Bandwidth 16 (kbps) Burst 400 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
143 packets, 3274 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
HTH
-- Petr Lapukhov, CCIE #16379 petr@internetworkexpert.comInternetwork Expert, Inc. http://www.InternetworkExpert.com Toll Free: 877-224-8987 Outside US: 775-826-4344
2006/8/26, Brian Dennis <bdennis@internetworkexpert.com>: > > Here is the interface's configuration: > > interface Serial1/0 > no ip address > encapsulation frame-relay > ! > interface Serial1/0.1 point-to-point > frame-relay interface-dlci 301 ppp Virtual-Template1 > > HTH, > > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security) > bdennis@internetworkexpert.com > > Internetwork Expert, Inc. > http://www.InternetworkExpert.com > Toll Free: 877-224-8987 > Direct: 775-745-6404 (Outside the US and Canada) > > From: James Nendel [mailto:james.nendel@gmail.com] > Sent: Friday, August 25, 2006 11:05 PM > To: Brian Dennis > Cc: ccielab@groupstudy.com > Subject: Re: QoS -- SCOTT or the BRIANS > > Brian > > Please can you show me the configuration of the physical interface that > holds the Virtual-template, I just do not get why I can not do this in > subinterfaces > > Thanks > James > On 8/26/06, Brian Dennis <bdennis@internetworkexpert.com> wrote: > Maybe I'm missing the point of your question but when you apply a > policy-map to a virtual template interface the policy will be inherited > by the virtual access interface when the PPPoFR connection comes up. > See below: > > hostname Rack1R3 > ! > class-map match-all PPPoFR_MAP > match any > ! > policy-map PPPoFR_POLICY > class PPPoFR_MAP > police 8000 conform-action transmit exceed-action drop > ! > interface Virtual-Template1 > ip address 155.1.13.3 255.255.255.0 > service-policy output PPPoFR_POLICY > > > Rack1R3#sho policy-map interface virtual-template 1 > Virtual-Template1 > > Service-policy output: PPPoFR_POLICY > > Service policy content is displayed for cloned interfaces only such > as vaccess and sessions > Rack1R3# > Rack1R3#sho policy-map interface virtual-access 1 > Virtual-Access1 > > Service-policy output: PPPoFR_POLICY > > Class-map: PPPoFR_MAP (match-all) > 1 packets, 14 bytes > 5 minute offered rate 0 bps, drop rate 0 bps > Match: any > police: > cir 8000 bps, bc 1500 bytes > conformed 0 packets, 0 bytes; actions: > transmit > exceeded 0 packets, 0 bytes; actions: > drop > conformed 0 bps, exceed 0 bps > > Class-map: class-default (match-any) > 0 packets, 0 bytes > 5 minute offered rate 0 bps, drop rate 0 bps > Match: any > Rack1R3#ping 155.1.13.1 > > Type escape sequence to abort. > Sending 5, 100-byte ICMP Echos to 155.1.13.1, timeout is 2 seconds: > !!!!! > Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/36 ms > Rack1R3#sho policy-map interface virtual-access 1 > Virtual-Access1 > > Service-policy output: PPPoFR_POLICY > > Class-map: PPPoFR_MAP (match-all) > 7 packets, 558 bytes > 5 minute offered rate 0 bps, drop rate 0 bps > Match: any > police: > cir 8000 bps, bc 1500 bytes > conformed 5 packets, 530 bytes; actions: > transmit > exceeded 0 packets, 0 bytes; actions: > drop > conformed 0 bps, exceed 0 bps > > Class-map: class-default (match-any) > 0 packets, 0 bytes > 5 minute offered rate 0 bps, drop rate 0 bps > Match: any > Rack1R3#ping 155.1.13.1 size 1500 > > Type escape sequence to abort. > Sending 5, 1500-byte ICMP Echos to 155.1.13.1, timeout is 2 seconds: > ..... > Success rate is 0 percent (0/5) > Rack1R3#sho policy-map interface virtual-access 1 > Virtual-Access1 > > Service-policy output: PPPoFR_POLICY > > Class-map: PPPoFR_MAP (match-all) > 14 packets, 8116 bytes > 5 minute offered rate 3000 bps, drop rate 3000 bps > Match: any > police: > cir 8000 bps, bc 1500 bytes > conformed 5 packets, 530 bytes; actions: > transmit > exceeded 5 packets, 7530 bytes; actions: > drop > conformed 0 bps, exceed 3000 bps > > Class-map: class-default (match-any) > 0 packets, 0 bytes > 5 minute offered rate 0 bps, drop rate 0 bps > Match: any > Rack1R3# > > As you can see the policy is allowing the packets that conform and > dropping the ones that don't. > > HTH, > > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security) > bdennis@internetworkexpert.com > > Internetwork Expert, Inc. > http://www.InternetworkExpert.com > Toll Free: 877-224-8987 > Direct: 775-745-6404 (Outside the US and Canada) > > > -----Original Message----- > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of > James Nendel > Sent: Friday, August 25, 2006 10:04 PM > To: ccielab@groupstudy.com > Subject: QoS -- SCOTT or the BRIANS > > Hi, > > How do I enable CBWFQ in a Frame-relay p2p subinterface that is using a > virtual-template ? > > config-if)#service-policy out DEFAULT > Class Based Weighted Fair Queueing will be applied only to the > Virtual-Access interfaces associated with an MLP bundle. > > #show policy-map interface virtual-template 1 > Virtual-Template1 > > Service-policy output: DEFAULT > > Service policy content is displayed only for cloned interfaces only > such as vaccess and sessions > > Please help > Thx > James > > _______________________________________________________________________ > Subscription information may be found at: > http://www.groupstudy.com/list/CCIELab.html > > _______________________________________________________________________ > Subscription information may be found at: > http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:58 ART