From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Mon Aug 21 2006 - 23:09:32 ART
Scott,
I didn't experience any problems with getting the virtual link to come up without an interface in area 0. I verified this with R1 and R5 connected across Frame Relay. The Frame Relay link is area 1. Also I tested this with IOS 12.2T, 12.3T, and 12.4T.
hostname Rack1R1
!
interface Loopback0
ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 155.1.146.1 255.255.255.0
!
interface Serial0/0
encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
ip address 155.1.0.1 255.255.255.0
ip ospf network non-broadcast
ip ospf hello-interval 2
frame-relay interface-dlci 105
!
router ospf 1
router-id 150.1.1.1
area 1 virtual-link 150.1.5.5
network 155.1.0.0 0.0.0.255 area 1
!
end
hostname Rack1R5
!
interface Loopback0
ip address 150.1.5.5 255.255.255.0
!
interface Ethernet0/0
ip address 155.1.58.5 255.255.255.0
!
interface Serial0/0
ip address 155.1.0.5 255.255.255.0
encapsulation frame-relay
ip ospf hello-interval 2
frame-relay map ip 155.1.0.1 501 broadcast
no frame-relay inverse-arp
!
router ospf 1
router-id 150.1.5.5
area 1 virtual-link 150.1.1.1
network 155.1.0.0 0.0.0.255 area 1
neighbor 155.1.0.1
!
end
Rack1R1#show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Vl1 1 0 0.0.0.0/0 64 P2P 1/1
Se0/0.1 1 1 155.1.0.1/24 64 BDR 1/1
Rack1R1#show ip ospf virtual-links
Virtual Link OSPF_VL1 to router 150.1.5.5 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface Serial0/0.1, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 0
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 0, maximum is 0
Last retransmission scan time is 0 msec, maximum is 0 msec
Rack1R1#
Rack1R5#show ip ospf interface brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Vl0 1 0 155.1.0.5/24 64 P2P 1/1
Se0/0 1 1 155.1.0.5/24 64 DR 1/1
Rack1R5#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 150.1.1.1 is up
Run as demand circuit
DoNotAge LSA allowed.
Transit area 1, via interface Serial0/0, Cost of using 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:08
Adjacency State FULL (Hello suppressed)
Index 1/2, retransmission queue length 0, number of retransmission 5
First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
Last retransmission scan length is 1, maximum is 1
Last retransmission scan time is 0 msec, maximum is 0 msec
Number of retransmissions for last database description packet 2
Rack1R5#
HTH,
Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security) bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Scott Morris
Sent: Monday, August 21, 2006 4:30 PM
To: Brian McGahan; 'Tim Chan'; slammer@broadpark.no; ccielab@groupstudy.com
Subject: RE: IEWB CORE Lab3 Virtual link
You sure about that? It would violate RFC (IMHO), and doesn't jive with the
code I'm using....
R2
interface Loopback0
ip address 22.22.22.22 255.255.255.0
interface FastEthernet1/0
no switchport
ip address 11.11.11.2 255.255.255.0
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
area 11 virtual-link 1.1.1.1
network 11.11.11.2 0.0.0.0 area 11
network 22.22.22.22 0.0.0.0 area 22
R1
interface Loopback0
ip address 12.12.12.12 255.255.255.0
interface Loopback1
ip address 111.111.111.111 255.255.255.0
interface FastEthernet0/0
ip address 11.11.11.1 255.255.255.0
duplex auto
speed auto
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
area 11 virtual-link 2.2.2.2
network 11.11.11.1 0.0.0.0 area 11
network 12.12.12.12 0.0.0.0 area 12
R1(config-router)#do sh ip o v
Virtual Link OSPF_VL0 to router 2.2.2.2 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 11, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R1(config-router)#
R1(config-router)#do sh ip o d
OSPF Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 11)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 44 0x80000003 0x00548F 1
2.2.2.2 2.2.2.2 49 0x80000009 0x000ACA 1
Net Link States (Area 11)
Link ID ADV Router Age Seq# Checksum
11.11.11.2 2.2.2.2 50 0x80000001 0x0038CA
Router Link States (Area 12)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 54 0x80000001 0x0048B1 1
R1(config-router)#
Nothing in area 0 at all....
(15 minutes pass for good measure)
R1#sh ip o vi
Virtual Link OSPF_VL0 to router 2.2.2.2 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 11, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R1#
R1#sh ip o d
OSPF Router with ID (1.1.1.1) (Process ID 1)
Router Link States (Area 11)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 779 0x80000003 0x00548F 1
2.2.2.2 2.2.2.2 784 0x80000009 0x000ACA 1
Net Link States (Area 11)
Link ID ADV Router Age Seq# Checksum
11.11.11.2 2.2.2.2 785 0x80000001 0x0038CA
Router Link States (Area 12)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 789 0x80000001 0x0048B1 1
R1#
Still nothing.
R2#sh ip o v
Virtual Link OSPF_VL0 to router 1.1.1.1 is down
Run as demand circuit
DoNotAge LSA allowed.
Transit area 11, Cost of using 65535
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
R2#
Nothing here either.
R2#sh ip o i
OSPF_VL0 is down, line protocol is down
Internet Address 0.0.0.0/0, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type VIRTUAL_LINK, Cost: 65535
Configured as demand circuit.
Run as demand circuit.
DoNotAge LSA allowed.
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
FastEthernet1/0 is up, line protocol is up
Internet Address 11.11.11.2/24, Area 11
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 11.11.11.2
Backup Designated router (ID) 1.1.1.1, Interface address 11.11.11.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:09
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
Internet Address 22.22.22.22/24, Area 22
Process ID 1, Router ID 2.2.2.2, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
R2#
R1#sh ip o i
OSPF_VL0 is down, line protocol is down
Internet Address 0.0.0.0/0, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type VIRTUAL_LINK, Cost: 65535
Configured as demand circuit.
Run as demand circuit.
DoNotAge LSA allowed.
Transmit Delay is 1 sec, State DOWN,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
FastEthernet0/0 is up, line protocol is up
Internet Address 11.11.11.1/24, Area 11
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 11.11.11.2
Backup Designated router (ID) 1.1.1.1, Interface address 11.11.11.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Index 1/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 2
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up
Internet Address 12.12.12.12/24, Area 12
Process ID 1, Router ID 1.1.1.1, Network Type LOOPBACK, Cost: 1
Loopback interface is treated as a stub Host
R1#
After we enable SOMETHING in Area 0 - things will work.
R1
router ospf 1
network 111.111.111.111 0.0.0.0 area 0
R1(config-router)#
*Aug 21 23:15:28.361: OSPF: Interface Loopback1 going Up
*Aug 21 23:15:28.861: OSPF: Build router LSA for area 0, router ID 1.1.1.1,
seq 0x80000001
*Aug 21 23:15:28.861: OSPF: Build router LSA for area 11, router ID 1.1.1.1,
seq 0x80000004
*Aug 21 23:15:28.861: OSPF: Build router LSA for area 12, router ID 1.1.1.1,
seq 0x80000002
*Aug 21 23:15:29.981: OSPF: Rcv hello from 2.2.2.2 area 11 from
FastEthernet0/0 11.11.11.2
*Aug 21 23:15:29.981: OSPF: End of hello processing
*Aug 21 23:15:33.861: OSPF: Rcv hello from 2.2.2.2 area 0 from OSPF_VL0
11.11.11.2
*Aug 21 23:15:35.113: OSPF: Send hello to 224.0.0.5 area 11 on
FastEthernet0/0 from 11.11.11.1
*Aug 21 23:15:39.977: OSPF: Rcv hello from 2.2.2.2 area 11 from
FastEthernet0/0 11.11.11.2
*Aug 21 23:15:39.977: OSPF: End of hello processing
*Aug 21 23:15:43.365: OSPF: Interface OSPF_VL0 going Up
*Aug 21 23:15:43.365: OSPF: Send hello to 11.11.11.2 area 0 on OSPF_VL0 from
11.11.11.1
*Aug 21 23:15:43.857: OSPF: Rcv hello from 2.2.2.2 area 0 from OSPF_VL0
11.11.11.2
*Aug 21 23:15:43.861: OSPF: 2 Way Communication to 2.2.2.2 on OSPF_VL0,
state 2WAY
*Aug 21 23:15:43.861: OSPF: Send DBD to 2.2.2.2 on OSPF_VL0 seq 0x1CAC opt
0x72 flag 0x7 len 32
*Aug 21 23:15:43.861: OSPF: End of hello processing
*Aug 21 23:15:43.861: OSPF: Rcv DBD from 2.2.2.2 on OSPF_VL0 seq 0x2375 opt
0x72 flag 0x7 len 32 mtu 0 state EXSTART
*Aug 21 23:15:43.861: OSPF: NBR Negotiation Done. We are the SLAVE
*Aug 21 23:15:43.861: OSPF: Send DBD to 2.2.2.2 on OSPF_VL0 seq 0x2375 opt
0x72 flag 0x2 len 92
*Aug 21 23:15:43.861: OSPF: Rcv DBD from 2.2.2.2 on OSPF_VL0 seq 0x2376 opt
0x72 flag 0x3 len 92 mtu 0 state EXCHANGE
*Aug 21 23:15:43.865: OSPF: Send DBD to 2.2.2.2 on OSPF_VL0 seq 0x2376 opt
0x72 flag 0x0 len 32
*Aug 21 23:15:43.865: OSPF: Database request to 2.2.2.2
*Aug 21 23:15:43.865: OSPF: sent LS REQ packet to 11.11.11.2, length 36
*Aug 21 23:15:43.865: OSPF: Rcv DBD from 2.2.2.2 on OSPF_VL0 seq 0x2377 opt
0x72 flag 0x1 len 32 mtu 0 state EXCHANGE
*Aug 21 23:15:43.865: OSPF: Exchange Done with 2.2.2.2 on OSPF_VL0
*Aug 21 23:15:43.865: OSPF: Send DBD to 2.2.2.2 on OSPF_VL0 seq 0x2377 opt
0x72 flag 0x0 len 32
*Aug 21 23:15:43.865: OSPF: Synchronized with 2.2.2.2 on OSPF_VL0, state
FULL
*Aug 21 23:15:43.869: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on OSPF_VL0
from LOADING to FULL, Loading Done
*Aug 21 23:15:44.369: OSPF: Build router LSA for area 11, router ID 1.1.1.1,
seq 0x80000005
*Aug 21 23:15:44.369: OSPF: Build router LSA for area 0, router ID 1.1.1.1,
seq 0x80000002
*Aug 21 23:15:45.113: OSPF: Send hello to 224.0.0.5 area 11 on
FastEthernet0/0 from 11.11.11.1
*Aug 21 23:15:49.977: OSPF: Rcv hello from 2.2.2.2 area 11 from
FastEthernet0/0 11.11.11.2
*Aug 21 23:15:49.977: OSPF: End of hello processing
R1(config-router)#
Magic happens now. The funny thing is that if you REMOVE the area 0
loopback from the process, the virtual link appear to remain up. But in
order to get it started, some other interface MUST be in area 0 as I would
expect.
The concept of a virtual link is to extend area 0 out to over another area
(transit) to a different ABR. In order to extend something, it must already
exist logically.
Even if I add the 111.111.111.111 back in as a new area, things still
continue to work:
R1(config-router)#network 111.111.111.111 0.0.0.0 area 111
R1(config-router)#
*Aug 21 23:21:32.501: OSPF: Interface Loopback1 going Up
*Aug 21 23:21:33.001: OSPF: Build router LSA for area 111, router ID
1.1.1.1, seq 0x80000001
R1(config-router)#
R2#
*Aug 21 23:20:17.705: RT: SET_LAST_RDB for 111.111.111.111/32
NEW rdb: via 11.11.11.1
*Aug 21 23:20:17.705: RT: add 111.111.111.111/32 via 11.11.11.1, ospf metric
[110/2]
*Aug 21 23:20:17.709: RT: NET-RED 111.111.111.111/32
R2#
But nothing started without an area 0 interface in an up state.
I'm running 12.3(11r)T1 on a 3825, and 12.4(3a) on a 2811. *shrug*
Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713, JNCIE
#153, CISSP, et al.
CCSI/JNCI-M/JNCI-J
IPExpert VP - Curriculum Development
IPExpert Sr. Technical Instructor
smorris@ipexpert.com
http://www.ipexpert.com
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Brian McGahan
Sent: Monday, August 21, 2006 3:52 PM
To: Tim Chan; slammer@broadpark.no; ccielab@groupstudy.com
Subject: RE: IEWB CORE Lab3 Virtual link
The virtual-link is area 0. You don't need a physical interface to be
assigned to area 0 for this to work.
Brian McGahan, CCIE #8593
bmcgahan@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Tim Chan
> Sent: Monday, August 21, 2006 2:12 PM
> To: slammer@broadpark.no; ccielab@groupstudy.com
> Subject: Re: IEWB CORE Lab3 Virtual link
>
> I would agree that you need an area 0 to implement a virtual link.
But if
> you read in the IE
> forum, someone got this to work without an area 0 just by changing the
IOS
> to 12.2.15-T17.
>
>
>
> ----- Original Message ----
> From: slammer@broadpark.no
> To: ccielab@groupstudy.com
> Sent: Monday, August 21, 2006 11:14:52 AM
> Subject: IEWB CORE Lab3 Virtual link
>
> Is it necessary for at least one interface to be in area 0 on R3 in
order
> to fulfill task 4.5 and 4.8?
>
> RFC3509 seems to indicate that Cisco requires an ABR to have at least
one
> active interface in the backbone area in order for the VL,s to become
> active Cant get this thing working
>
> Help anyone !!!!!!!!!!!!!!!!
>
>
This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:58 ART