QoS / NBAR / Matching

From: CCIEBOB (cciebob@comcast.net)
Date: Wed Aug 09 2006 - 18:51:37 ART


Hello all. I am trying to "lab-up" a QoS configuration and it is not working to my expectations. Any thoughts or suggestions would be helpful.

The idea here is to use NBAR to match / mark traffic. I want to set up my queues as follows:

EF - voice
AF31 - business apps
AF21 - business apps
AF22 - I want this to be the default queue - match any
BE - FTP - SMTP

The issue I am seeing is that when I assign the AF22 to match any any, FTP is matched in AF22 and not BE. Should I be using the no match protocol ftp in AF22?

Here is the config.

ip nbar port-map ftp tcp 20 21

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

class-map match-any EF

  match ip dscp ef

class-map match-any AF21

  match protocol telnet

class-map match-any AF31

  match protocol citrix

class-map match-any AF32

  match protocol snmp

class-map match-any BE

  match protocol ftp

class-map match-any AF22

  match protocol http

  match any

!

!

policy-map MPLS

  class EF

   priority percent 30

   set ip dscp ef

  class AF31

   set ip dscp af31

   bandwidth remaining percent 30

  class AF21

   set ip dscp af21

   bandwidth remaining percent 15

  class AF22

   set ip dscp af22

   bandwidth remaining percent 15

  class BE

   set ip dscp default

   bandwidth remaining percent 10

!

!

!

!

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

!

interface Ethernet1/0

 ip address 192.168.20.1 255.255.255.0

 half-duplex

!

interface Serial1/0

 bandwidth 1536

 no ip address

 ip nbar protocol-discovery

 encapsulation frame-relay IETF

 frame-relay lmi-type cisco

 service-policy output MPLS

!

interface Serial1/0.1 point-to-point

 bandwidth 1536

 ip address 192.168.1.10 255.255.255.252

 no cdp enable

 frame-relay interface-dlci 102



This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:56 ART