From: Radoslav Vasilev (deckland@gmail.com)
Date: Wed Aug 09 2006 - 12:55:02 ART
Brian,
Just tested you configuration - using IP Unnumbered on both sides works
pefectly fine.
Yet there's a difference when the ip address is not unnumbered but
negotiated.
For my testing I'm usign R4 and R5 (R5 assigning address to R4):
R4:
interface Serial0/1
ip address negotiated
encapsulation ppp
clock rate 64000
end
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
R5:
interface Serial0/1
ip address 5.5.5.5 255.255.255.0
encapsulation ppp
peer default ip address 5.5.5.4
end
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
R4 gets ip through ipcp:
Rack1R4#sh ip route connected
155.1.0.0/24 is subnetted, 1 subnets
C 155.1.0.0 is directly connected, Serial0/0
5.0.0.0/32 is subnetted, 2 subnets
C 5.5.5.5 is directly connected, Serial0/1
C 5.5.5.4 is directly connected, Serial0/1
150.1.0.0/24 is subnetted, 1 subnets
C 150.1.4.0 is directly connected, Loopback0
even R4 thinks it have adj. with R5:
Rack1R4#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
150.1.5.5 1 FULL/DR 00:01:35 155.1.0.5 Serial0/0
But check out R5:
Rack1R5#sh ip os neighbor
Neighbor ID Pri State Dead Time Address Interface
150.1.4.4 0 INIT/ - 00:00:36 5.5.5.4 Serial0/1
debug ip ospf adj:
*Mar 10 05:40:44.929: OSPF: Interface Serial0/1 going Up
*Mar 10 05:40:45.429: OSPF: Build router LSA for area 0, router ID 150.1.5.5,
seq 0x8000000C
*Mar 10 05:40:45.913: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to up
I know that the mask should be ingored over P2P links so it's not strange R4
declares the adj as up but why R5 doesn't i can't think of a reason.
Could you check this with your routers - mine are running 12.3(16a).
On 8/9/06, Brian McGahan <bmcgahan@internetworkexpert.com> wrote:
>
> Here's an example of OSPF forming adjacency when it's not on the same
> subnet as its connected neighbor. R1 and R3 are connected via a PPP
> serial link:
>
> R1#
> interface Loopback0
> ip address 150.1.1.1 255.255.255.255
> !
> interface FastEthernet0/0
> ip address 10.1.1.1 255.255.0.0
> !
> interface Serial0/1
> ip unnumbered Loopback0
> encapsulation ppp
> !
> router ospf 1
> network 0.0.0.0 255.255.255.255 area 0
>
> R3#
> interface Loopback0
> ip address 150.1.3.3 255.255.255.255
> !
> interface Ethernet0/0
> ip address 10.3.3.3 255.255.0.0
> !
> interface Serial1/2
> ip unnumbered Loopback0
> encapsulation ppp
> clockrate 64000
> !
> router ospf 1
> network 0.0.0.0 255.255.255.255 area 0
>
> R1#show ip route
> Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external type 2
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
> inter area
> * - candidate default, U - per-user static route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 10.0.0.0/16 is subnetted, 2 subnets
> O 10.3.0.0 [110/74] via 150.1.3.3, 00:00:50, Serial0/1
> C 10.1.0.0 is directly connected, FastEthernet0/0
> 150.1.0.0/32 is subnetted, 2 subnets
> C 150.1.3.3 is directly connected, Serial0/1
> C 150.1.1.1 is directly connected, Loopback0
>
> R1#show ip ospf neighbor
>
> Neighbor ID Pri State Dead Time Address
> Interface
> 150.1.3.3 0 FULL/ - 00:00:38 150.1.3.3
> Serial0/1
>
> R1#ping 150.1.3.3
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 150.1.3.3, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms
>
> R1#ping 10.3.3.3
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 10.3.3.3, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms
>
>
>
>
> Brian McGahan, CCIE #8593
> bmcgahan@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987 x 705
> Outside US: 775-826-4344 x 705
> 24/7 Support: http://forum.internetworkexpert.com
> Live Chat: http://www.internetworkexpert.com/chat/
>
>
> > -----Original Message-----
> > From: Schulz, Dave [mailto:DSchulz@dpsciences.com]
> > Sent: Tuesday, August 08, 2006 9:25 PM
> > To: Brian McGahan; Olopade Olorunloba; Cisco certification
> > Subject: RE: Routing through a ppp ipcp negotiated interface
> >
> > Brian -
> >
> > Actually, the RIP works fine. However, OSPF does not. Someone
> > mentioned that this was due to the peer neighbor route, which shows up
> > as a connected route (not a subnet issue). Therefore the routing
> > protocol won't build its adjancency (since it is connected). Do you
> see
> > it this way?
> >
> >
> > Dave Schulz,
> > Email: dschulz@dpsciences.com
> >
> >
> > -----Original Message-----
> > From: Brian McGahan [mailto:bmcgahan@internetworkexpert.com]
> > Sent: Tuesday, August 08, 2006 1:53 PM
> > To: Olopade Olorunloba; Schulz, Dave; Cisco certification
> > Subject: RE: Routing through a ppp ipcp negotiated interface
> >
> > OSPF does not require devices to be on the same subnet to
> > establish adjacency, so it should work fine. In RIP this behavior can
> > be disabled with the "no validate-update-source" process level
> command.
> >
> >
> > HTH,
> >
> > Brian McGahan, CCIE #8593
> > bmcgahan@internetworkexpert.com
> >
> > Internetwork Expert, Inc.
> > http://www.InternetworkExpert.com
> > Toll Free: 877-224-8987 x 705
> > Outside US: 775-826-4344 x 705
> > 24/7 Support: http://forum.internetworkexpert.com
> > Live Chat: http://www.internetworkexpert.com/chat/
> >
> >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> > Of
> > > Olopade Olorunloba
> > > Sent: Tuesday, August 08, 2006 12:37 PM
> > > To: 'Schulz, Dave'; 'Cisco certification'
> > > Subject: RE: Routing through a ppp ipcp negotiated interface
> > >
> > > OSPF does not form because the mask negotiated is a host route, and
> > > therefore the router believes that the remote end is not on the same
> > > subnet.
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> > Of
> > > Schulz, Dave
> > > Sent: 04 August 2006 21:41
> > > To: Cisco certification
> > > Subject: Routing through a ppp ipcp negotiated interface
> > >
> > > I discovered something interesting while setting up a network in my
> > lab
> > > with using ppp ipcp to negotiate the address across a serial link.
> In
> > > the following scenario, the address is negotiated fine. However, I
> am
> > > trying to run the various protocols across the link. EIGRP, but RIP
> > > will not allow the database to be received at the router with the
> > > negotiated interface. OSPF will not allow the adjacency to form.
> > > BTW....I can get the routes to be sent from the negotiated interface
> > to
> > > the remote (negotiating) interface of the remote router. I am just
> > > trying things and investigating ....so this may not be valid to do
> > this.
> > > Just wondering why EIGRP works in this way, but OSPF and RIP do not.
> > > Thoughts?
> > >
> > > On RIP...I get the following debug error.....(I tried this both
> > > multicast and unicast updates, with no difference).
> > >
> > > *Mar 16 11:07:12.927: RIP: ignored v2 update from bad source
> 25.5.5.5
> > on
> > > Serial0/1
> > >
> > > Here are the configs at the interface level......
> > >
> > > R3.....
> > >
> > > !
> > > interface Serial1
> > > ip address negotiated
> > > encapsulation ppp
> > > end
> > >
> > >
> > > R5......
> > > !
> > > interface Serial0/1
> > > ip address 35.5.5.5 255.255.255.0
> > > encapsulation ppp
> > > peer default ip address 35.5.5.3
> > > clock rate 2000000
> > > end
> > >
> > >
> > >
> > > Dave Schulz, CCDP, CCNP, CCSP
> > > Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com >
> > >
> > >
> >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:56 ART