From: Victor Cappuccio (cvictor@protokolgroup.com)
Date: Thu Aug 03 2006 - 14:08:49 ART
AFIAK there are 3 ways to send a Summary Address from RIP
Say we have this basic RIP configuration
Sw2(config-router)#int lo 10
Sw2(config-if)#ip add 200.200.44.1 255.255.255.0
Sw2(config-if)#ip add 150.16.1.1 255.255.255.0 sec
Sw2(config-if)#ip add 1.1.25.1 255.255.255.0 sec
router rip
version 2
passive-interface default
no passive-interface Vlan11
network 1.0.0.0
network 150.16.0.0
network 200.200.44.0
network 200.200.178.0
no auto-summary
By normal means Ver 2 will send this
1d04h: RIP: sending v2 flash update to 224.0.0.9 via Vlan11 (200.200.178.8)
1d04h: RIP: build flash update entries
1d04h: 1.1.25.0/24 via 0.0.0.0, metric 1, tag 0
1d04h: 150.16.1.0/24 via 0.0.0.0, metric 1, tag 0
1d04h: 200.200.44.0/24 via 0.0.0.0, metric 1, tag 0
1.- Send RIP Ver 1 Updates
interface Vlan11
ip address 200.200.178.8 255.255.255.0
ip rip send version 1
1d04h: RIP: sending v1 flash update to 255.255.255.255 via Vlan11
(200.200.178.8)
1d04h: RIP: build flash update entries
1d04h: network 1.0.0.0 metric 1
1d04h: network 150.16.0.0 metric 1
1d04h: network 200.200.44.0 metric 1
2.- Leave Auto-Summary Turn on
Sw2(config-if)#int vlan 11
Sw2(config-if)#no ip rip send ver 1
Sw2(config-if)#router rip
Sw2(config-router)#auto
Sw2(config-router)#do clear ip route *
Sw2(config-router)#
1d04h: RIP: sending request on Vlan11 to 224.0.0.9
1d04h: RIP: sending request on Vlan11 to 224.0.0.9
1d04h: RIP: sending request on Vlan11 to 224.0.0.9
Sw2(config-router)#
1d04h: RIP: sending v2 flash update to 224.0.0.9 via Vlan11 (200.200.178.8)
1d04h: RIP: build flash update entries
1d04h: 1.0.0.0/8 via 0.0.0.0, metric 1, tag 0
1d04h: 150.16.0.0/16 via 0.0.0.0, metric 1, tag 0
1d04h: 200.200.44.0/24 via 0.0.0.0, metric 1, tag 0
And 3 the one you know- Ip Summary under the interface.
I'm CC the Group, so see if there are any other ways
Regards
Victor.-
_____
De: Sami [mailto:sy1977@gmail.com]
Enviado el: Jueves, 03 de Agosto de 2006 11:07 a.m.
Para: Victor Cappuccio
Asunto: Re: RIP offset-list
Victor,
Do you know any way other than summary address by which we can advertise
summary in rip..
Thanks
On 8/3/06, Sami <sy1977@gmail.com> wrote:
Victor,
Could you please paste full configuration including access.list
Thanks
On 8/3/06, Victor Cappuccio <cvictor@protokolgroup.com
<mailto:cvictor@protokolgroup.com> > wrote:
Hi Sami
router rip
version 2
offset-list 2 out 2
offset-list 1 out 3 Vlan11
offset-list 1 out 3 FastEthernet0/13
network 150.150.0.0 <http://150.150.0.0/>
network 166.166.0.0 <http://166.166.0.0/>
network 200.200.178.0 <http://200.200.178.0/>
no auto-summary
1d01h: <http://150.150.0.0/16> 150.150.0.0/16 via 0.0.0.0
<http://0.0.0.0/> , metric 4, tag 0
1d01h: <http://166.166.1.0/24> 166.166.1.0/24 via 0.0.0.0
<http://0.0.0.0/> , metric 3, tag 0
At the remote side:
Sw1(config-router)#do show ip route rip
166.166.0.0/24 is subnetted, 1 subnets
R 166.166.1.0 <http://166.166.1.0/> [120/3] via 200.200.178.8
<http://200.200.178.8/> , 00:00:28, Vlan11
R <http://150.150.0.0/16> 150.150.0.0/16 [120/4] via 200.200.178.8
<http://200.200.178.8/> , 00:00:28, Vlan11
Sw1(config-router)#
Victor.-
-----Mensaje original-----
De: nobody@groupstudy.com [mailto: <mailto:nobody@groupstudy.com>
nobody@groupstudy.com] En nombre de Sami
Enviado el: Martes, 01 de Agosto de 2006 08:42 a.m.
Para: ccielab
Asunto: RIP offset-list
Group,
One of task say send out 155.155.0.0/16 ( aggregate) with metric 4 and
166.166.1.0/24 <http://166.166.1.0/24> with metrci 3.
I tried to use offset-list but can't achieve the desired result. I was
thinking to use route-map with distribute list but it seems route-map is not
supported with distribute list in RIP.
How can I achieve this ?
Thanks
This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:55 ART