Re: per-port per-vlan classification

From: nikolai (niko@4ovek.com)
Date: Thu Aug 03 2006 - 01:16:07 ART


Per Cisco: "The per-port per-VLAN QoS feature enables you to specify
different QoS configurations on different VLANs on a given interface.
Typically, you will use this feature on trunk or voice VLANs (Cisco IP
Phone) ports, as they belong to multiple VLANs."
***********************************************
mls qos
!
class-map match-all ANY
   match access-group 1
!
class-map match-all VLAN
   match vlan 1-10
   match class-map ANY
!
policy-map VLAN_IP
   class VLAN
    set precedence 5
!
interface GigabitEthernet0/7
  switchport trunk encapsulation dot1q
  switchport mode trunk
  service-policy input VLAN_IP
!
access-list 1 permit any
**********************************************
SW2#sh policy-map interface GigabitEthernet0/7
  GigabitEthernet0/7

   Service-policy input: VLAN_IP

     Class-map: VLAN (match-all)
       0 packets, 0 bytes
       5 minute offered rate 0 bps, drop rate 0 bps
       Match: vlan 1-10
       Match: class-map match-all ANY
         Match: access-group 1

     Class-map: class-default (match-any)
       0 packets, 0 bytes
       5 minute offered rate 0 bps, drop rate 0 bps
       Match: any
         0 packets, 0 bytes
         5 minute rate 0 bps
********************************************************************
You can apply the service policy inbound on a TRUNK static port (the
example below lists access, though). However, I agree the it might not
work at all on an access port, or a trunk and native VLAN, where there
are no tags. Furthermore, the class-map VLAN is match-all, and we must
match both on VLAN id AND other criteria.

-- nikolai

lenny lim wrote:
> May i know how can you match VLAN on a Access Port ?? Thought VLAN tags
> are only on trunk links....
>
> Thanks
>
>
> */nikolai <niko@4ovek.com>/* wrote:
>
> mls qos
> !
> class-map match-any MATCH_ANY
> match any
>
> class-map match-all VLAN
> match vlan 11 22-24 -> 1st
> match class-map MATCH_ANY -> 2nd
> !
> policy-map VLAN_IP
> class VLAN
> set ip precedence 5
> !
> interface FastEthernet0/1
> switchport access vlan 11
> switchport mode access -> static ACCESS or Trunk only
> service-policy input VLAN_IP -> inbound only
> *****************************************************************
> My understanding is that this feature allows you to match packets
> (policy-map VLAN_IP) on both VLAN ID (class-map match-all VLAN) AND by
> other criteria (class-map match-any MATCH_ANY) on an MLS such as
> Cat3550/3560/3750. The thing I noted is that you can apply the service
> policy inbound on a physical interface only (access or trunk static
> port) - no routed ports, or virtual (logical) interfaces such as SVI.
>
> -- nikolai
>
> Bozhidar Batev wrote:
> > Does anyone can explain me what exactly per-port per-vlan
> classification
> > do. What could be the reason to use it.
> >
> >
> _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
> Yahoo! Music Unlimited - Access over 1 million songs. Try it free.
> <http://pa.yahoo.com/*http://us.rd.yahoo.com/evt=36035/*http://music.yahoo.com/unlimited/



This archive was generated by hypermail 2.1.4 : Fri Sep 01 2006 - 15:41:55 ART