Re: Multicast AutoRP

From: Radoslav Vasilev (deckland@gmail.com)
Date: Tue Jul 25 2006 - 09:32:55 ART


Nick,

When a negative group-range is received through Auto-RP, a group in the
range will be treated as dense mode group.
What's more important is that even if you had another RP advertising a
normal (positive) group-range, the negative one will override it across your
PIM domain.

Here's my testing of the override process:

R1 and R4 connected through a common ethernet segment:

hostanme Rack1R1
ip multicast-routing

interface Loopback0
 ip address 150.1.1.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-dense-mode
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 no ip directed-broadcast
 ip pim sparse-dense-mode

ip pim send-rp-announce Loopback0 scope 10 group-list 1
ip pim send-rp-discovery scope 10
!
access-list 1 deny 239.0.0.0 0.0.0.255
access-list 1 permit 224.0.0.0 7.255.255.255

hostname Rack1R4
ip multicast-routing

interface Loopback0
 ip address 150.1.4.4 255.255.255.0
 ip pim sparse-dense-mode

interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto

ip pim send-rp-announce Loopback0 scope 10 group-list 1
ip pim rp-candidate Loopback0 group-list 10 priority 1

access-list 1 permit 239.0.0.0 0.0.0.255

As you see, Router1 announces 224/5 but also (negativelly) 239/8.
Router 4 announces 239/8 normally.

Check R4's opinion on the group-to-rp mapping:
Rack1R4#sh ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is a candidate RP (v2)

Group(s) 224.0.0.0/5
  RP 150.1.1.1 (?), v2v1
    Info source: 150.1.1.1 (?), elected via Auto-RP
         Uptime: 00:04:45, expires: 00:02:11
Group(s) (-)239.0.0.0/24
  RP 150.1.1.1 (?), v2v1
    Info source: 150.1.1.1 (?), elected via Auto-RP
         Uptime: 00:04:45, expires: 00:02:09
Rack1R4#

Although R4 announes 239/8 :

Auto-RP(0): Build RP-Announce for 150.1.4.4, PIMv2/v1, ttl 10, ht 181
Auto-RP(0): Build announce entry for (239.0.0.0/24)
Auto-RP(0): Send RP-Announce packet on FastEthernet0/1

R1(the mapping agent) ignores and send the -239/8:

Auto-RP(0): Build RP-Announce for 150.1.4.4, PIMv2/v1, ttl 10, ht 181
Auto-RP(0): Build announce entry for (239.0.0.0/24)
Auto-RP(0): Send RP-Announce packet on FastEthernet0/1

On 7/25/06, Nick Davey <nicky.davey@gmail.com> wrote:
>
> Thanks Rado,
>
> So does that mean that this group does not have an RP ?
>
> Nick
>
>
> On 7/25/06, Radoslav Vasilev < deckland@gmail.com> wrote:
> >
> > Hi Nick,
> >
> > What you've done is a negative announcement for the administrativelly
> > scoped range 239/8.
> > This happen when you have a deny statement in the standard ACL you use
> > on the RP.
> >
> > I think the "negative prefix" feauture for Auto-RP was addes somewhere
> > in 12.0
> >
> >
> > Cheers,
> > Rado
> >
> >
> >
> > On 7/25/06, Nick Davey < nicky.davey@gmail.com> wrote:
> >
> > > Hi all,
> >
> > I configured autorp as follows:
> >
> > ip pim send-rp-announce Loopback0 scope 16 group-list MCast
> >
> > ip access-list standard MCast
> > deny 239.0.0.0 0.255.255.255
> > permit 232.0.0.0 7.255.255.255
> >
> >
> > When i do a show ip pim rp mapping i see the following
> >
> > Group(s) 232.0.0.0/5
> > RP 150.1.6.6 (?), v2v1
> > Info source: 150.1.6.6 (?), elected via Auto-RP
> > Uptime: 00:32:43, expires: 00:02:13
> > Group(s) (-)239.0.0.0/8
> > RP 150.1.6.6 (?), v2v1
> > Info source: 150.1.6.6 (?), elected via Auto-RP
> > Uptime: 00:32:43, expires: 00:02:16
> >
> >
> > Why is group 239.0.0.0 assigned an RP when it is denied in the ACL?
> >
> > And what does the (-) before 239.0.0.0/8 mean?
> >
> > Hope someone can answer this
> >
> > Regards,
> >
> > Nick
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Tue Aug 01 2006 - 07:13:48 ART