From: Pierre-Alex (paguanel@hotmail.com)
Date: Tue Jun 06 2006 - 09:35:01 ART
Hi Group,
Here is an interesting challenge
The problem is solved but your comments are welcome ...
Pierre-Alex
Diagram:
*************
R1------------------------R3==========R4-------(-128K)
--------R2--Loobpack(150.1.2.2 /32)
R3 and R4 are connected via e 0/0 and e 0/1
Eigrp is running on all interfaces
Task:
*************
Send one every 3 packets on e 0/0 outbound (1 packet is sent on e 0/0 then 3
packets are sent on e 0/1 and so on ...)
Theory:
*************
"To load balance, the router divide the traffic into the larges metric, rounds
DOWN to the nearest integer andn uses this number as the traffic share count"
- from CISCO DOC
"The variance is calculated as the round UP value of the calculation: highest
metric / lowest metric "
Strategy:
*************
We increase the delay on e 0/0 to make the metric 3 times worse than the
metric via e 0/1
Calculation of delay to put on e 0/0:
-----------------------------------------------------------
x = metric
a = 10^7/lowest bandwidth
b = sum of eigrp delays / 10
then x = (a + b) * 256
and b = x/256 - a
if we set x = 3 * FD to have a route metric 3 times higher then,
b= (3*FD) /256 - a
Here we have FD is 20665600 from e 0/1 route ( from show ip eigrp topology)
b = (3*20665600)/256 - 10^7/128
b = 164050
Configuration:
***********************
interface Ethernet0/0
ip address 10.3.4.1 255.255.255.252
ip load-sharing per-packet ------> necessary to make it work
no ip route-cache cef
no ip route-cache
load-interval 30
delay 164050 ! ------> Delay
half-duplex
end
!
interface Ethernet0/1
ip address 10.3.4.5 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
no ip route-cache
load-interval 30
half-duplex
end
router eigrp 100
variance 4
network 10.1.3.0 0.0.0.255
network 10.3.4.0 0.0.0.3
network 10.3.4.4 0.0.0.3
no auto-summary
eigrp router-id 150.1.3.3
!
r3#sh ip eigrp top 150.1.2.2 255.255.255.255
IP-EIGRP (AS 100): Topology entry for 150.1.2.2/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 20665600
Routing Descriptor Blocks:
10.3.4.6 (Ethernet0/1), from 10.3.4.6, Send flag is 0x0
Composite metric is (20665600/20640000), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 26000 microseconds
Reliability is 255/255
Load is 90/255
Minimum MTU is 1500
Hop count is 2
10.3.4.2 (Ethernet0/0), from 10.3.4.2, Send flag is 0x0
Composite metric is (62636800/20640000), Route is Internal
Vector metric:
Minimum bandwidth is 128 Kbit
Total delay is 1665500 microseconds
Reliability is 255/255
Load is 90/255
Minimum MTU is 1500
Hop count is 2
Verification of metric ratio after putting the delay on the interface:
from show eigrp topology detail
10.3.4.2 (Ethernet0/0), from 10.3.4.2, Send flag is 0x0
Composite metric is (62636800/20640000), Route is Internal
highest metric/ lowest metric = 20665600 / 62636800 = 3,030969
Verification that trafffic is load balanced outbound:
r3#sh int | i output rate
30 second output rate 474000 bits/sec, 40 packets/sec
30 second output rate 1412000 bits/sec, 119 packets/sec
This archive was generated by hypermail 2.1.4 : Sat Jul 01 2006 - 07:57:32 ART