RE: ??: RE: Voice VLAN and data VLAN configuration

From: Carlos Chorao (cchorao@solvertech.co.nz)
Date: Tue Jun 06 2006 - 05:19:35 ART


Albert,
Your apporach will work .And I think its good to know how to achieve a given
end result using as many diffrent methods as possible. However, imo, its to
much work :-) , and there is more direct approach.
The correct approach depends on the question . However if nothing is said I
would use the approach I have listed below.

The following will do the same job :-

interface FastEthernet0/7
 switchport mode access
switchport access vlan 11
 switchport voice vlan 200
 mls qos trust device cisco-phone
 spanning-tree portfast
end

I use the above for Cisco and Non Cisco (Nortel) and it works fine.

cheers,

carlos.chorao.#11351.r/s

________________________________

From: nobody@groupstudy.com on behalf of Albert Ip
Sent: Tue 06/06/2006 00:02
To: ccielab@groupstudy.com
Subject: ??: RE: Voice VLAN and data VLAN configuration

Hey Guy,

So, what is the "CORRECT" answer if I face the voice
vlan question in CCIE lab exam???

Is it correct??

mls qos
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 11,200
 switchport mode trunk
 switchport voice vlan 200
 mls qos trust device cisco-phone
 spanning-tree portfast
!

Assuming voice vlan is 200, data vlan is 100

Please advise!!!

Thanks!!!

Albert

--- "Hosking, Darren" <dhosking@commander.com> ;!!G

> If it's not a Cisco phone then there is no reason to
> use "switchport
> voice vlan" because a non-Cisco phone won't listen
> to CDP. CDP and DTP
> should probably be turned off too.
>
> Nortel documentation talks about LLDP (Link Layer
> Discovery Protocol) as
> an industry standard way of doing this, however,
> there is no mention of
> this protocol on the Cisco web site.
>
> I'm connecting Nortel phones to a Cisco switch and
> am concerned about
> forcing every port to be a trunk. The native VLAN is
> the data VLAN so a
> PC directly plugged in will work but I've seen some
> performance issues.
>
> How do others configure Cisco switches for non-Cisco
> IP phones with
> daisy chained PC's or just PC's (ie one config needs
> to work for both
> with no performance penalty)?
>
> Even if the port is not hard coded to be a trunk the
> switch (tried on
> 3750) still accepts tagged voice and untagged data,
> although this means
> DTP is on which probably shouldn't be sent to Nortel
> (and possibly
> other) IP phones.
>
> Thanks, Darren
>
> -----Original Message-----
> From: David Bombal
> [mailto:davidbombal@davidbombal.com]
> Sent: Monday, 5 June 2006 2:37 AM
> To: Hosking, Darren
> Cc: ccielab@groupstudy.com
> Subject: RE: Voice VLAN and data VLAN configuration
>
> Hi Darren,
>
> The same configuration can be used with other
> vendors. The Cisco IP
> Phones
> use CDP to determine which VLAN they should be in
> (Voice Vlan ID). Other
> vendors use a DHCP server with specific options to
> tell their phones
> which
> vlan they belong to. The switch configuration
> remains the same as far as
> I
> am aware.
>
> David Bombal
> CCIE, CCSI, CCSP, CCIP
> http://www.ConfigureTerminal.com <http://www.configureterminal.com/>
>
> -----Original Message-----
> From: Hosking, Darren
> [mailto:dhosking@commander.com]
> Sent: 04 June 2006 11:13
> To: David Bombal
> Subject: RE: Voice VLAN and data VLAN configuration
>
>
> What about for non-Cisco IP phones?
>
> Thanks, Darren
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of
> David Bombal
> Sent: Sunday, 4 June 2006 2:40 AM
> To: 'Albert Ip'; ccielab@groupstudy.com
> Subject: RE: Voice VLAN and data VLAN configuration
>
> Hi Albert,
>
> Previously it was recommended to hardcode the port
> to trunk for ports
> that
> have phones connected to them. These days the
> recommended way to
> configure
> the voice ports is as follows:
>
> EXAMPLE 1:
> CAT3550(config)#interface FastEthernet0/1
> CAT3550(config-if)# switchport access vlan 10 !
> DVLAN
> CAT3550(config-if)# switchport voice vlan 110 !
> VVLAN
> CAT3550(config-if)# mls qos trust device cisco-phone
> !
> Conditional Trust
> CAT3550(config-if)# service-policy input
> IPPHONE+PC-BASIC !
> Attaches
> policy
>
> EXAMPLE 2:
> CAT2970(config)#interface GigabitEthernet0/1
> CAT2970(config-if)#
> switchport
> access vlan 10 ! DVLAN CAT2970(config-if)#
> switchport voice vlan 110 !
> VVLAN
> CAT2970(config-if)# service-policy input
> IPPHONE+PC-BASIC ! Attaches
> policy
>
> The reason for the change was to stop broadcasts
> from other VLANS
> killing
> phones.
>
> I hope this helps.
>
> Thank you,
> David Bombal
> CCIE, CCSI, CCSP, CCIP etc
> http://www.ConfigureTerminal.com <http://www.configureterminal.com/>
>
>
>
>
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of
> Albert Ip
> Sent: 03 June 2006 10:29
> To: ccielab@groupstudy.com
> Subject: Voice VLAN and data VLAN configuration
>
> Hi All,
>
>
> Please help me clarify the following configuration
> is correct or not,
> thanks!!!
>
> Voice vlan 200
> Data vlan 100
> Config on port f0/13
>
> #
> vlan 100
> name VLAN_Data
> vlan 200
> name VLAN_Voice
> #
> int f0/13
> sw encap dot1q
> sw mode trunk
> sw voice vlan 200
> sw access vlan 100
> #
>
>
> Please kindly advise, thanks!!!!
>
>
> Albert
>
> _______________________________________
> YM - Bw=u0T.'
>
>
>
4N:b'A(S&3$W:t!A'A*:*B$M$4%i%H/d$U0T.'59'A!A7m'A$W:t.I4N/`%_'Y,](l!A%t&s
> ;!8\
> 3#IN(+%"!C
> http://messenger.yahoo.com.hk <http://messenger.yahoo.com.hk/>
>
>



This archive was generated by hypermail 2.1.4 : Sat Jul 01 2006 - 07:57:32 ART