From: Chris Lewis (chrlewiscsco@gmail.com)
Date: Sun May 14 2006 - 11:15:04 ART
The example is the documentation is actually wrong, I have asked for it to
be changed, but that takes a long time. The ip directed broadcast for the
last hop router is on the wrong interface.
The following is a correctly configured example with an illustration of how
to use trace to test the configuration, as trace will send a UDP stream.
R3---R1---R2---R4
R1 config
interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
ip pim dense-mode
ip multicast helper-map broadcast 227.0.0.2 100
duplex auto
speed auto
!
interface Serial0/1
ip address 12.12.12.1 255.255.255.0
ip pim dense-mode
clockrate 128000
!
ip forward-protocol udp 30017
ip forward-protocol udp 30018
ip forward-protocol udp 30019
!
access-list 100 permit udp any any gt 30000
R2
interface FastEthernet0/0
ip address 24.24.24.2 255.255.255.0
ip directed-broadcast
duplex auto
speed auto
!
interface Serial0/1
ip address 12.12.12.2 255.255.255.0
ip pim dense-mode
ip multicast helper-map 227.0.0.2 24.24.24.255 100
ip forward-protocol udp 30018
ip forward-protocol udp 30019
ip route 13.13.13.0 255.255.255.0 12.12.12.1
!
access-list 100 permit udp any any gt 30000
R1 sees the following debug
*Mar 1 01:43:03.375: IP: s=13.13.13.3 (FastEthernet0/0), d=255.255.255.255,
len 28,
R2 sees
*Mar 1 01:42:31.543: IP: s=13.13.13.3 (Serial0/1), d=227.0.0.2, len 28,
rcvd 0
R4 sees
*Mar 1 01:42:53.935: IP: s=13.13.13.3 (FastEthernet0/0), d=255.255.255.255,
len 28,
On 5/14/06, Petr Lapukhov <petrsoft@gmail.com> wrote:
>
> There seems to be enough information in command reference
> (+ an example, too :)
>
>
>
http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cr/himc_r/
> mlt_i1h.htm#wp1075964
>
> HTH
> Petr
>
> 2006/5/14, Magmax <magmax@bigpond.net.au>:
> >
> > Guys,
> >
> >
> > Can anyone else me understand multicast helper maps. Examples may be.
> > Where
> > is it on Cisco DOC DVD or reference
> >
> > I don't know but I am finding it hard to swallow
> >
> >
> > Ubaid
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Thu Jun 01 2006 - 06:33:21 ART