From: Victor Cappuccio (cvictor@protokolgroup.com)
Date: Mon May 08 2006 - 10:06:38 ART
Dave but k2 = 0
So the formula is metric = k1*bandwidth + k3*delay
Why you say Bandwidth + Bandwidth/256 + Delay (K1 and K3 being equal to
"1").
?
http://www.cisco.com/en/US/tech/tk365/technologies_white_paper09186a0080094c
b7.shtml#feasibleandreported
Let us compute the metrics. EIGRP calculates the total metric by scaling the
bandwidth and delay metrics. EIGRP uses the following formula to scale the
bandwidth:
* bandwidth = (10000000/bandwidth(i)) * 256
where bandwidth(i) is the least bandwidth of all outgoing interfaces
on the route to the destination network represented in kilobits.
EIGRP uses the following formula to scale the delay:
* delay = delay(i) * 256
where delay(i) is the sum of the delays configured on the interfaces, on the
route to the destination network, in tens of microseconds. The delay as
shown in the show ip eigrp topology or show interface commands is in
microseconds, so you must divide by 10 before you use it in this formula.
Throughout this paper, we use delay as it is configured and shown on the
interface.
EIGRP uses these scaled values to determine the total metric to the network:
* metric = [K1 * bandwidth + (K2 * bandwidth) / (256 - load) + K3 *
delay] * [K5 / (reliability + K4)]
Note: These K values should be used after careful planning. Mismatched K
values prevent a neighbor relationship from being built, which can cause
your network to fail to converge.
Note: If K5 = 0, the formula reduces to Metric = [k1 * bandwidth + (k2 *
bandwidth)/(256 - load) + k3 * delay].
The default values for K are:
* K1 = 1
* K2 = 0
* K3 = 1
* K4 = 0
* K5 = 0
For default behavior, you can simplify the formula as follows:
metric = bandwidth + delay
-----Mensaje original-----
De: Schulz, Dave [mailto:DSchulz@dpsciences.com]
Enviado el: Lunes, 08 de Mayo de 2006 08:52 a.m.
Para: Victor Cappuccio; petrsoft@gmail.com
CC: ccielab@groupstudy.com
Asunto: RE: EIGRP metric question
Thanks, Victor. I see that formulae by Petr's explanation. And, the
same formulae in the IGRP url. I am trying to see how this formulae
fits into the one on the docCD the the K-values. Basically, the
formulae that Petr mentioned appears to work well....just trying to take
this a step further and see how these two work together (I racked the
calculator on this one, and haven't been able to make it fit)....
So, the question is.....
This one....
256*[10^7/Bw+(Delay/10)]
Versus, this one.....
[K1*bandwidth + (K2*bandwidth)/(256 - load) + K3*delay] *
[K5/(reliability + K4)]
Since bandwidth and delay are only considerations by default....we can
simplify this to.....
Bandwidth + Bandwidth/256 + Delay (K1 and K3 being equal to "1").
I know I'm missing something, somewhere....
Dave
Dave Schulz,
Email: dschulz@dpsciences.com
-----Original Message-----
From: Victor Cappuccio [mailto:cvictor@protokolgroup.com]
Sent: Monday, May 08, 2006 7:59 AM
To: Schulz, Dave; petrsoft@gmail.com
Cc: ccielab@groupstudy.com
Subject: RE: EIGRP metric question
Hello Dave,
The formula set on the Cisco Page is ok, try the formula again but this
time
using 256*[10^7/Bw+(Delay/10)]
http://www.cisco.com/warp/public/103/3.html
States: "To find the bandwidth, find the smallest of all the bandwidths
in
Kbps from outgoing interfaces and divide 10,000,000 by that number. (The
bandwidth is scaled by 10,000,000 in kilobits per second.)
In order to find the delay, add all of the delays (in microseconds) from
the
outgoing interfaces and divide this number by 10. (The delay is in
tenths of
microseconds.)"
And as you probably know the show ip route and the show ip eigrp
topology
Net Netmask would help you seeing these values.
HTH
Victor.
-----Mensaje original-----
De: nobody@groupstudy.com [mailto:nobody@groupstudy.com] En nombre de
Schulz, Dave
Enviado el: Lunes, 08 de Mayo de 2006 07:05 a.m.
Para: petrsoft@gmail.com
CC: ccielab@groupstudy.com
Asunto: Re: EIGRP metric question
Thanks, Petr. I see your explanation and it is very clear. Thanks.
However, I was trying to see how this relates to the formulae in the
docCD
for " values, which is slightly different. Any thuoghts?
Dave Schulz
*** Sent from my Blackberry ***
-----Original Message-----
From: Petr Lapukhov <petrsoft@gmail.com>
To: Schulz, Dave <DSchulz@dpsciences.com>
CC: ccielab@groupstudy.com <ccielab@groupstudy.com>
Sent: Mon May 08 00:51:43 2006
Subject: Re: EIGRP metric question
Dave,
You see, basic EIGRP metric is:
256*[10^7/Bw+Delay]
(Bw is measured in Kb/s)
So here we go:
You have minimum Bw = 64, Delay = 1 + 2000
(2000 is standard delay for serial interface)
256*[10^7/64 + 2000 + 1] = 40512256
Petr
2006/5/8, Schulz, Dave <DSchulz@dpsciences.com>:
Group -
I am working with EIGRP metric and trying to plan for a metric
that
is being
redistributed from ospf into eigrp on a router (R1) and
forwarded to
R4 via
EIGRP. So, I have a link between R1 and R4 set up as 64k and R1
looks like
this:
router eigrp 100
redistribute ospf 1 metric 10000 1 255 1 1500
network 172.16.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
redistribute eigrp 100 subnets
network 192.168.1.0 0.0.0.255 area 0
neighbor 192.168.1.2
neighbor 192.168.1.3
Based on the K-values (default) 1 0 1 0 0, I would assume that
the
formulae
should allow us to determine the metric at R4:
metric = [K1*bandwidth + (K2*bandwidth)/(256 - load) + K3*delay]
*
[K5/(reliability + K4)]
This metric should be (64000 * 1) + (1 * 10 usec). However,
this
doesn't seem
to be case as the show ip route on R4 shows the metric at
40512256.
Gateway of last resort is not set
2.0.0.0/32 <http://2.0.0.0/32> is subnetted, 1 subnets
D EX 2.2.2.2 [170/40512256] via 172.16.14.1, 00:25:15,
Serial1/0
Can someone please help clear up this confusion. Much thanks!
Dave
This archive was generated by hypermail 2.1.4 : Thu Jun 01 2006 - 06:33:21 ART