From: Julius Kinsler (jkinsler@harbortech.com)
Date: Thu Apr 20 2006 - 19:49:41 GMT-3
Nick,
The solution is you route-map and Aggregate prefix-lists should look
something like this:
ip prefix-list AGGREGATE seq 5 permit 11.0.0.0/16
!
ip prefix-list AGGREGATE1 seq 5 permit 10.0.0.0/16
!
ip prefix-list INJECT seq 5 permit 11.0.0.0/24
ip prefix-list INJECT seq 10 permit 10.0.0.0/24
!
ip prefix-list SOURCE seq 5 permit 150.1.2.2/32
!
route-map EXISTS permit 10
match ip address prefix-list AGGREGATE
match ip route-source prefix-list SOURCE
!
route-map EXISTS permit 20
match ip address prefix-list AGGREGATE1
match ip route-source prefix-list SOURCE
!
route-map INJECT permit 10
set ip address prefix-list INJECT
Because The exist-map must have at least two match clauses:
- match ip address prefix-list specifies the aggregate based on which
to inject more specifics. Only one exact match is allowed.
- match ip route-source specifies the neighbor that sent the aggregate.
The component inherits the attributes from the aggregate if the option
copy-attributes is specified; otherwise, they are treated as locally
generated routes for some of the attributes. The NEXT_HOP is always
the eBGP peer that originated the aggregate. Additional matches can be
made for AS_PATH and community.
Not sure why the INJECT doesn't work the same way but it doesn't. If you
stagger it with the route-maps instead of the preifx-lists it should
work.
Julius
-----Original Message-----
From: Nick Griffin [mailto:ngriffin@sio.midco.net]
Sent: Thursday, April 20, 2006 5:27 PM
To: Julius Kinsler
Subject: Re: BGP Inject Map
I want to make sure were on the same page, so let me send you my
configs:
R2 config, this guys is originating the routes off of his loopback:
router bgp 200
no synchronization
bgp log-neighbor-changes
network 12.0.0.0 mask 255.255.0.0
network 13.0.0.0 mask 255.255.0.0
network 11.0.0.0 mask 255.255.0.0
network 10.0.0.0 mask 255.255.0.0
neighbor 150.1.1.1 remote-as 100
neighbor 150.1.1.1 ebgp-multihop 2
neighbor 150.1.1.1 update-source Loopback0 no auto-summary
************************************************************************
************************************************
R1 config, he is receiving the /16's and then injecting the 10.0.0.0/24
specific. I'm trying to get the 11.0.0.0/24 to be injected as well, but
it's not working
router bgp 100
no synchronization
bgp log-neighbor-changes
bgp inject-map INJECT exist-map EXISTS
neighbor 150.1.2.2 remote-as 200
neighbor 150.1.2.2 ebgp-multihop 2
neighbor 150.1.2.2 update-source Loopback0 neighbor 150.1.3.3
remote-as 300 neighbor 150.1.3.3 ebgp-multihop 2 neighbor 150.1.3.3
update-source Loopback0 no auto-summary !
ip http server
ip classless
!
!
!
ip prefix-list AGGREGATE seq 5 permit 10.0.0.0/16 ip prefix-list
AGGREGATE seq 10 permit 11.0.0.0/16 !
ip prefix-list INJECT seq 5 permit 10.0.0.0/24 ip prefix-list INJECT seq
10 permit 11.0.0.0/24 !
ip prefix-list SOURCE seq 5 permit 150.1.2.2/32 !
!
route-map EXISTS permit 10
match ip address prefix-list AGGREGATE
match ip route-source prefix-list SOURCE !
route-map INJECT permit 10
set ip address prefix-list INJECT
R1#show ip bgp
BGP table version is 6, local router ID is 150.1.1.1 Status codes: s
suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0/24 150.1.2.2 0 ?
<---------------- THE SPECIFIC I INJECTED WITH THE ABOVE CONFIG
*> 10.0.0.0/16 150.1.2.2 0 0 200 i
*> 11.0.0.0/16 150.1.2.2 0 0 200 i
<--------------NO SPECIFIC BEING INJECTED FOR SOME REASON
*> 12.0.0.0/16 150.1.2.2 0 0 200 i
*> 13.0.0.0/16 150.1.2.2 0 0 200 i
************************************************************************
************************************************
R3 config, R3 is peering directly with R1, receiving one of the
specifics but not the other, because R1 isn't originating for some
reason:
router bgp 300
no synchronization
bgp log-neighbor-changes
neighbor 150.1.1.1 remote-as 100
neighbor 150.1.1.1 ebgp-multihop 2
neighbor 150.1.1.1 update-source Loopback0 no auto-summary
R3#sh ip bgp
BGP table version is 70, local router ID is 150.1.3.3 Status codes: s
suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0/24 150.1.1.1 0 100 ?
*> 10.0.0.0/16 150.1.1.1 0 100 200 i
*> 11.0.0.0/16 150.1.1.1 0 100 200 i
*> 12.0.0.0/16 150.1.1.1 0 100 200 i
*> 13.0.0.0/16 150.1.1.1 0 100 200 i
************************************************************************
************************************************
Julius Kinsler wrote:
> Nick let me know what you come up with I am very interested.
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of Julius Kinsler
> Sent: Thursday, April 20, 2006 1:43 PM
> To: Nick Griffin
> Cc: ccielab@groupstudy.com
> Subject: RE: BGP Inject Map
>
> I would also try an extended ping using the loopback address 11.0.0.1
> as the source to the 150.1.1.1 and see if there is reachability. And
> also do a regular ping to the 11.0.0.1 network from R1.
>
> -----Original Message-----
> From: Nick Griffin [mailto:ngriffin@sio.midco.net]
> Sent: Thursday, April 20, 2006 1:29 PM
> To: Nick Griffin
> Cc: Julius Kinsler; ccielab@groupstudy.com
> Subject: Re: BGP Inject Map
>
> The prefix list source of the peering address seems to work, as I am
> able to re-originate the 10.0.0.0/24 from the 10.0.0.0/16
advertisement.
>
> I'm thinking I need to do the route-map different. I've tried separate
> prefix lists for the 11.0.0.0 network, and separate route map
> statements. Both resulted in the same outcome, the creation of the
> 10.0.0.0/24 specific, and nothing for the 11.0.0.0 network.
>
>
>
> Nick Griffin wrote:
>
>> I used neither to get the more specifics in. What you see in the BGP
>> output is the one specific 10.0.0.0/24, the rest are /16's. I used
>> the
>>
>
>
>> inject route map in correlation with the prefix list on the
>> downstream
>>
>
>
>> router, to inject more specifics from the received /16. Here's my
>> route origination source config:
>>
>> Originating Router R2
>> interface Loopback10
>> ip address 10.0.0.1 255.255.0.0
>> !
>> interface Loopback11
>> ip address 11.0.0.1 255.255.0.0
>> !
>> interface Loopback12
>> ip address 12.0.0.1 255.255.0.0
>> !
>> interface Loopback13
>> ip address 13.0.0.1 255.255.0.0
>>
>> router bgp 200
>> no synchronization
>> bgp log-neighbor-changes
>> network 10.0.0.0 mask 255.255.0.0
>> network 11.0.0.0 mask 255.255.0.0
>> network 12.0.0.0 mask 255.255.0.0
>> network 13.0.0.0 mask 255.255.0.0
>> neighbor 150.1.1.1 remote-as 100
>> neighbor 150.1.1.1 ebgp-multihop 2
>> neighbor 150.1.1.1 update-source Loopback0 no auto-summary
>>
>>
>> Julius Kinsler wrote:
>>
>>> So in this confirguration you used the network statements to get the
>>> more specific routes into the BGP table or the aggregate address
>>> command? Both should work. In looking at the configs you post the
>>>
> only
>
>>> thing I wonder about is the ip route-source what happens if you
>>>
> specify
>
>>> the AS instead of using the prefix-list SOURCE? Have you tried that?
>>>
>>>
>>> -----Original Message-----
>>> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
>>>
> Of
>
>>> Nick Griffin
>>> Sent: Thursday, April 20, 2006 11:34 AM
>>> To: Nick Griffin
>>> Cc: ccielab@groupstudy.com
>>> Subject: Re: BGP Inject Map
>>>
>>> My guess is that I am not handling this correctly with my prefix
>>>
> lists
>
>>> and route maps. Are separate prefix lists and route-map entries
>>>
> required
>
>>> to originate multiple subnets from the aggregates?
>>>
>>> Nick Griffin wrote:
>>>
>>>
>>>> In order for the bgp inject map to function correctly, does the
>>>> network your trying to produce specific subnets from have to be
>>>> originated into bgp via the aggregate address command? At first
>>>> glance, I think that originating the network via the network
>>>> statment and corresponding mask works. However when I tried to add
>>>> a
>>>>
>
>
>>>> second subnet off of a different block(utilizing same prefix
>>>> lists),
>>>>
>
>
>>>> I am unable to originate the more specifics. The setup is R2 is
>>>> originating
>>>>
>>>>
>>>
>>>
>>>> the routes from AS 200, and sending to R1 in AS100, which is
>>>> attempting to inject more specific prefixes and send them to R3 in
>>>> AS300. See below:
>>>>
>>>>
>>>> originate->(R2)--EBGP--(R1)--EBGP--(R3)
>>>>
>>>> When using the network statements (10.0.0.0 mask 255.255.0.0, and
>>>> 11.0.0.0 mask 255.255.0.0) upstream R2:
>>>> R1 Config:
>>>>
>>>> router bgp 100
>>>> bgp inject-map INJECT exist-map EXISTS !
>>>> ip prefix-list AGGREGATE seq 5 permit 10.0.0.0/16 ip prefix-list
>>>> AGGREGATE seq 10 permit 11.0.0.0/16 !
>>>> ip prefix-list INJECT seq 5 permit 10.0.0.0/24 ip prefix-list
>>>> INJECT
>>>>
>
>
>>>> seq 10 permit 11.0.0.0/24 !
>>>> ip prefix-list SOURCE seq 5 permit 150.1.2.2/32 !
>>>> !
>>>> route-map EXISTS permit 10
>>>> match ip address prefix-list AGGREGATE match ip route-source
>>>> prefix-list SOURCE !
>>>> route-map INJECT permit 10
>>>> set ip address prefix-list INJECT
>>>>
>>>> R2#sh ip bgp
>>>> BGP table version is 19, local router ID is 150.1.2.2 Status codes:
>>>> s suppressed, d damped, h history, * valid, > best, i - internal,
>>>> r RIB-failure, S Stale Origin codes: i - IGP, e - EGP,
>>>> ? - incomplete
>>>>
>>>> Network Next Hop Metric LocPrf Weight Path
>>>> *> 10.0.0.0/16 0.0.0.0 0 32768 i
>>>> *> 11.0.0.0/16 0.0.0.0 0 32768 i
>>>> *> 12.0.0.0/16 0.0.0.0 0 32768 i
>>>> *> 13.0.0.0/16 0.0.0.0 0 32768 i
>>>>
>>>> R1#sh ip bgp
>>>> BGP table version is 6, local router ID is 150.1.1.1 Status codes:
>>>> s
>>>>
>
>
>>>> suppressed, d damped, h history, * valid, > best, i - internal,
>>>> r RIB-failure, S Stale Origin codes: i - IGP, e - EGP,
>>>> ? - incomplete
>>>>
>>>> Network Next Hop Metric LocPrf Weight Path
>>>> *> 10.0.0.0/24 150.1.2.2 0 ?
>>>> *> 10.0.0.0/16 150.1.2.2 0 0 200 i
>>>> *> 11.0.0.0/16 150.1.2.2 0 0 200 i
>>>> *> 12.0.0.0/16 150.1.2.2 0 0 200 i
>>>> *> 13.0.0.0/16 150.1.2.2 0 0 200 i
>>>>
>>>>
>>>> R3#sh ip bgp
>>>> BGP table version is 50, local router ID is 150.1.3.3 Status codes:
>>>> s suppressed, d damped, h history, * valid, > best, i - internal,
>>>> r RIB-failure, S Stale Origin codes: i - IGP, e - EGP,
>>>> ? - incomplete
>>>>
>>>> Network Next Hop Metric LocPrf Weight Path
>>>> *> 10.0.0.0/24 150.1.1.1 0 100 ?
>>>> *> 10.0.0.0/16 150.1.1.1 0 100
200
>>>>
> i
>
>>>> *> 11.0.0.0/16 150.1.1.1 0 100
200
>>>>
> i
>
>>>> *> 12.0.0.0/16 150.1.1.1 0 100
200
>>>>
> i
>
>>>> *> 13.0.0.0/16 150.1.1.1 0 100
200
>>>>
> i
>
>>>> It seems when I used the aggregate address to originate the
>>>> 10.0.0.0
>>>>
>
>
>>>> and 11.0.0.0 subnets I was able to inject more specific subnets
>>>> from
>>>>
>
>
>>>> both blocks. Just trying to get this straight. Thoughts are
>>>>
>>>>
>>> appreciated.
>>>
>>>
>>>> Thanks,
>>>>
>>>> Nick Griffin
>>>>
>>>>
>>>
> ______________________________________________________________________
> _
>
>>> Subscription information may be found at:
>>> http://www.groupstudy.com/list/CCIELab.html
>>>
>
> ______________________________________________________________________
> _ Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Mon May 01 2006 - 11:41:58 GMT-3