From: Chris Lewis (chrlewiscsco@gmail.com)
Date: Wed Apr 19 2006 - 22:50:26 GMT-3
Mohammed,
Good, so you tried one thing and saw that it fixed the problem, so the next
thing to figure out is why.
The initial problem is the olist on R6 was empty. Putting the join on the
ethernet of R2 sends a join directly to R6 and creates an entry in the
olist, so it is no longer empty and BB1 can get it packets forwarded through
R6. Using the igmp helper from the R3 side of R2 achieves much the same
thing, in terms of getting an entry in the olist of R6.
However, these are workarounds, they are not fixing what is really broken
with the setup you have.
When a source starts sending, the first multicast router to receive that
mutlicast packet in a sparse mode network will encapsulate the multicast
packet with a unicast header addressed to the RP. This process is known as
the PIM register process.
If you get rid of the extra joins and helpers and get back to the original
configuration when BB1 cannot ping the group, you should see that taking PIM
off the BB1 interface enables pings to happen, now the question is why? Why
can R6 now register the source with the RP? Think about which router can
send the register packets on the multi-access network between BB1 and R6?
You see this by looking at the output of the sho ip pim neighbor command on
BB1 or R6. Then think about why that router is not sending a register
packet. If you can answer this, you'll know why the setup was not working
originally and how you can get it working.
Let us know how your investigation goes.
Chris
On 4/19/06, Shamin <ccie.xpert@gmail.com> wrote:
>
> Chris , Vikram ,Brian,Shculz and the rest.....
>
> Sorry for the long mail,but have included all possible details...
>
> I have tried what you suggested, i.e to join the R2 ethernet interface
> connected to R6 to 228.28.28.28
>
> I tried pinging the 228.28.28.28 address from BB1 and intrstingly i
> got replies from all the devices in the domain which had members to
> this group.
> The output of ping was as follows.
>
> BB1#ping 228.28.28.28
>
> Type escape sequence to abort.
> Sending 1, 100-byte ICMP Echos to 228.28.28.28, timeout is 2 seconds:
>
> Reply to request 0 from 132.1.26.2, 84 ms
> Reply to request 0 from 132.1.17.7, 172 ms
> Reply to request 0 from 132.1.0.3, 128 ms
>
>
> The show ip mroute on R6 was as follows:
>
> Rack1R6#sh ip mroute
> IP Multicast Routing Table
>
> (*, 228.28.28.28), 00:08:40/stopped, RP 150.1.2.2, flags: SJPC
> Incoming interface: Ethernet0/0.26, RPF nbr 132.1.26.2
> Outgoing interface list: Null
>
> (54.1.2.254, 228.28.28.28), 00:03:19/00:02:55, flags: T
> Incoming interface: Serial0/0, RPF nbr 0.0.0.0
> Outgoing interface list:
> Ethernet0/0.26, Forward/Sparse, 00:03:19/00:03:06
>
> (*, 224.0.1.40), 00:29:04/00:02:55, RP 150.1.2.2, flags: SJCL
> Incoming interface: Ethernet0/0.26, RPF nbr 132.1.26.2
> Outgoing interface list:
> Serial0/0, 54.1.2.254, Forward/Sparse, 00:27:47/00:02:59
> Ethernet0/0.6, Forward/Sparse, 00:29:04/00:02:45
>
> I then removed the membership from the interface of R2, and was not
> able to get reply at all.
>
>
>
>
******************************X*******************X**************************
*
>
> Brian, I am posting all the configs on R6,R2 and BB1 below.
>
> Rack1R2#
> hostname Rack1R2
> !!
> enable password cisco
> !
> !
> !
> ip cef
> no ip domain lookup
> !
> !
> ip multicast-routing
> ipv6 unicast-routing
> !!
> !
> interface Loopback0
> ip address 150.1.2.2 255.255.255.0
> !
> interface Loopback1
> no ip address
> ipv6 address 2001:CC1E:1::2/128
> !
> interface Ethernet0/0
> ip address 132.1.26.2 255.255.255.0
> ip pim sparse-mode
> half-duplex
> !
> interface Serial0/0
> ip address 132.1.0.2 255.255.255.0
> ip pim nbma-mode
> ip pim sparse-mode
> encapsulation frame-relay
> ip ospf network point-to-multipoint
> ipv6 address 2001:CC1E:1:2323::2/64
> no dce-terminal-timing-enable
> frame-relay map ipv6 2001:CC1E:1:2323::3 203 broadcast
> frame-relay lmi-type cisco
> !
> interface Serial0/1
> ip address 132.1.23.2 255.255.255.0
> compress stac
> no dce-terminal-timing-enable
> !
> router eigrp 10
> network 132.1.23.2 0.0.0.0
> network 132.1.26.2 0.0.0.0
> network 150.1.2.2 0.0.0.0
> distance eigrp 90 109
> no auto-summary
> eigrp router-id 150.1.2.2
> neighbor 132.1.26.6 Ethernet0/0
> !
> router ospf 1
> router-id 150.1.2.2
> log-adjacency-changes
> network 132.1.0.2 0.0.0.0 area 0
> distance 171 0.0.0.0 255.255.255.255 6
> !
> router bgp 200
> no synchronization
> bgp router-id 150.1.2.2
> bgp log-neighbor-changes
> neighbor 132.1.0.4 remote-as 200
> neighbor 132.1.26.6 remote-as 100
> no auto-summary
> !
> ip http server
> !
> !
> ip pim rp-address 150.1.2.2
> ip mroute 132.1.0.0 255.255.255.0 132.1.0.1
> !
> access-list 6 permit 132.1.6.0
>
>
>
*************************X******************************X********************
**********
>
> Rack1R6#
> hostname Rack1R6
> !
> boot-start-marker
> boot-end-marker
> !
> enable password cisco
> !
> !
> !
> ip cef
> no ip domain lookup
> !
> !
> ip multicast-routing
> !
> !
> !
> interface Loopback0
> ip address 150.1.6.6 255.255.255.0
> !
> interface Ethernet0/0
> no ip address
> half-duplex
> !
> interface Ethernet0/0.6
> encapsulation dot1Q 6 native
> ip address 132.1.6.6 255.255.255.0
> ip pim sparse-mode
> no snmp trap link-status
> !
> interface Ethernet0/0.26
> encapsulation dot1Q 26
> ip address 132.1.26.6 255.255.255.0
> ip pim sparse-mode
> ip summary-address eigrp 10 200.0.0.0 255.255.252.0 5
> no snmp trap link-status
> !
> interface Serial0/0
> ip address 54.1.2.6 255.255.255.0
> ip pim nbma-mode
> ip pim sparse-mode
> encapsulation frame-relay
> no dce-terminal-timing-enable
> no fair-queue
> !
> interface TokenRing0/0
> no ip address
> shutdown
> ring-speed 16
> !
> interface Ethernet1/0
> no ip address
> shutdown
> half-duplex
> !
> router eigrp 10
> network 54.1.2.6 0.0.0.0
> network 132.1.26.6 0.0.0.0
> network 150.1.6.6 0.0.0.0
> no auto-summary
> eigrp router-id 150.1.6.6
> neighbor 132.1.26.2 Ethernet0/0.26
> !
> router bgp 100
> no synchronization
> bgp router-id 150.1.6.6
> bgp log-neighbor-changes
> neighbor 54.1.2.254 remote-as 54
> neighbor 132.1.26.2 remote-as 200
> no auto-summary
> !
> ip http server
> !
> !
> ip pim rp-address 150.1.2.2
> ip mroute 0.0.0.0 255.255.255.255 54.1.2.254
> !
> !
>
> *******************X******************X**********************************
>
> BB1#
> hostname BB1
>
> ip subnet-zero
> !
> ip multicast-routing
> !
> !
> interface Loopback0
> ip address 200.1.0.1 255.255.255.0
> !
> interface Loopback1
> ip address 200.1.1.1 255.255.255.0
> !
> interface Loopback2
> ip address 200.1.2.1 255.255.255.0
> !
> interface Loopback3
> ip address 200.1.3.1 255.255.255.0
> !
> interface Loopback11
> ip address 150.1.11.11 255.255.255.0
> !
> interface Ethernet0
> no ip address
> shutdown
> !
> interface Serial0
> ip address 54.1.2.254 255.255.255.0
> ip pim nbma-mode
> ip pim sparse-mode
> encapsulation frame-relay
> !
> interface Serial1
> no ip address
> shutdown
> !
> router eigrp 10
> network 54.1.2.254 0.0.0.0
> network 150.1.11.11 0.0.0.0
> network 200.1.0.1 0.0.0.0
> network 200.1.1.1 0.0.0.0
> network 200.1.2.1 0.0.0.0
> network 200.1.3.1 0.0.0.0
> no auto-summary
> eigrp router-id 150.1.11.11
> no eigrp log-neighbor-changes
> !
> router bgp 54
> bgp log-neighbor-changes
> neighbor 54.1.2.6 remote-as 100
> !
> ip classless
> ip http server
> ip pim rp-address 150.1.2.2
>
>
>
*********************************X****************************X**************
***********
>
> Unicast routing table of R2
>
> Rack1R2#sh ip route
> Gateway of last resort is not set
>
> D EX 204.12.1.0/24 [109/2560512256] via 132.1.23.3, 00:40:15, Serial0/1
> D 200.1.0.0/24 [90/2323456] via 132.1.26.6, 00:40:23, Ethernet0/0
> 20.0.0.0/32 is subnetted, 1 subnets
> B 20.20.20.20 [200/0] via 132.1.35.5, 00:38:00
> 54.0.0.0/24 is subnetted, 1 subnets
> D 54.1.2.0 [90/2195456] via 132.1.26.6, 00:40:51, Ethernet0/0
> D 200.1.1.0/24 [90/2323456] via 132.1.26.6, 00:40:23, Ethernet0/0
> D 200.1.2.0/24 [90/2323456] via 132.1.26.6, 00:40:23, Ethernet0/0
> D 200.1.3.0/24 [90/2323456] via 132.1.26.6, 00:40:24, Ethernet0/0
> 132.1.0.0/16 is variably subnetted, 10 subnets, 2 masks
> D EX 132.1.0.4/32 [109/2560512256] via 132.1.23.3, 00:40:16, Serial0/1
> D EX 132.1.0.1/32 [109/2560512256] via 132.1.23.3, 00:40:16, Serial0/1
> C 132.1.0.0/24 is directly connected, Serial0/0
> D EX 132.1.3.0/24 [109/2560512256] via 132.1.23.3, 00:40:45, Serial0/1
> O 132.1.0.3/32 [110/64] via 132.1.0.3, 00:40:08, Serial0/0
> C 132.1.23.0/24 is directly connected, Serial0/1
> D EX 132.1.17.0/24 [109/2560512256] via 132.1.23.3, 00:40:21, Serial0/1
> C 132.1.26.0/24 is directly connected, Ethernet0/0
> D EX 132.1.33.0/24 [109/2560512256] via 132.1.23.3, 00:40:45, Serial0/1
> D 132.1.35.0/24 [90/2681856] via 132.1.23.3, 00:40:39, Serial0/1
> 150.1.0.0/16 is variably subnetted, 8 subnets, 2 masks
> D EX 150.1.7.0/24 [109/2560512256] via 132.1.23.3, 00:40:21, Serial0/1
> D 150.1.6.0/24 [90/409600] via 132.1.26.6, 00:41:44, Ethernet0/0
> B 150.1.5.0/24 [200/0] via 132.1.35.5, 00:38:12
> D 150.1.3.0/24 [90/2297856] via 132.1.23.3, 00:40:45, Serial0/1
> C 150.1.2.0/24 is directly connected, Loopback0
> D EX 150.1.4.4/32 [109/2560512256] via 132.1.23.3, 00:40:21, Serial0/1
> D EX 150.1.1.1/32 [109/2560512256] via 132.1.23.3, 00:40:21, Serial0/1
> D 150.1.11.0/24 [90/2323456] via 132.1.26.6, 00:40:29, Ethernet0/0
>
>
>
************************X*************************X**************************
********
>
> Edited Show ip route on R6
>
> Rack1R6#sh ip route
> Gateway of last resort is not set
>
> D EX 204.12.1.0/24 [170/2560537856] via 132.1.26.2, 00:41:42,
> Ethernet0/0.26
> D 200.1.0.0/24 [90/2297856] via 54.1.2.254, 00:41:49, Serial0/0
> 20.0.0.0/32 is subnetted, 1 subnets
> B 20.20.20.20 [20/0] via 132.1.26.2, 00:39:02
> 54.0.0.0/24 is subnetted, 1 subnets
> C 54.1.2.0 is directly connected, Serial0/0
> D 200.1.1.0/24 [90/2297856] via 54.1.2.254, 00:41:49, Serial0/0
> D 200.1.2.0/24 [90/2297856] via 54.1.2.254, 00:41:49, Serial0/0
> D 200.1.3.0/24 [90/2297856] via 54.1.2.254, 00:41:50, Serial0/0
> 132.1.0.0/16 is variably subnetted, 9 subnets, 2 masks
> D EX 132.1.0.4/32 [170/2560537856] via 132.1.26.2, 00:41:43,
> Ethernet0/0.26
> C 132.1.6.0/24 is directly connected, Ethernet0/0.6
> D EX 132.1.0.1/32 [170/2560537856] via 132.1.26.2, 00:41:43,
> Ethernet0/0.26
> D EX 132.1.3.0/24 [170/2560537856] via 132.1.26.2, 00:42:10,
> Ethernet0/0.26
> D 132.1.23.0/24 [90/2195456] via 132.1.26.2, 00:42:32,
> Ethernet0/0.26
> D EX 132.1.17.0/24
> [170/2560537856] via 132.1.26.2, 00:41:47, Ethernet0/0.26
> C 132.1.26.0/24 is directly connected, Ethernet0/0.26
>
>
>
>
***********************X*******************************X*********************
**
This archive was generated by hypermail 2.1.4 : Mon May 01 2006 - 11:41:58 GMT-3