From: Alex (alex.arseniev@gmail.com)
Date: Thu Feb 16 2006 - 06:50:44 GMT-3
For iBGP that will work as long as neighbor addresses are specified
correctly on both sides because TTL in iBGP TCP packets is >1.
For eBGP it may work if You do something like:
R1:
interface Serial0
description Link to R2
ip address 10.10.10.1 255.255.255.0
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
router bgp 1
neighbor 10.10.10.2 remote-as 2
neighbor 10.10.10.2 update-source lo0
R2:
interface Serial0
ip address 10.10.10.2 255.255.255.0
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
router bgp 2
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop
!
ip route 1.1.1.1 255.255.255.255 Serial0
What happens in this situation is R2 sends out packets to 1.1.1.1 with
TTL=255 and they are getting to R1. R1 sends out packets to 10.10.10.2 with
source address of 1.1.1.1 and TTL=1 and they also are getting to R2 because
these neighbors are directly connected.
HTH
Cheers
Alex
----- Original Message -----
From: "Maneesh Chawla" <coolmaneesh@gmail.com>
To: <ccielab@groupstudy.com>
Sent: Thursday, February 16, 2006 6:52 AM
Subject: BGP : update-source
> Hi ,
> Can anyone explain -- when we do a BGP peering between loop
> backs,
> it is enuf to give update-source loopback on one side and the peering will
> happen, can anyone explain how ?
>
>
> Thanks
> Maneesh
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Mar 01 2006 - 11:28:18 GMT-3