From: easyman.lin (easyman.lin@msa.hinet.net)
Date: Sat Feb 11 2006 - 21:31:01 GMT-3
Dear GS folks,
I'm doing the advanced technology lab today.
My configuration as following
R1
interface Ethernet0/0
ip address 16.0.0.1 255.0.0.0
half-duplex
R2
interface Ethernet0/0
ip address 26.0.0.2 255.0.0.0
half-duplex
Sw1
interface FastEthernet0/1
switchport access vlan 16
switchport mode dynamic desirable
interface FastEthernet0/2
switchport access vlan 26
switchport mode dynamic desirable
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk native vlan 26
switchport mode trunk
switchport nonegotiate
R6
interface Ethernet0/0
no ip address
half-duplex
!
interface Ethernet0/0.16
encapsulation dot1Q 16
ip address 16.0.0.6 255.0.0.0
!
interface Ethernet0/0.26
encapsulation dot1Q 26 native
ip address 26.0.0.6 255.0.0.0
Everything is ok in the previous lab. (PS: without native vlan command)
But after adding the native parameter under interface E0/0.16 on R6 and "
switchport trunk native vlan 16" on Sw1.
R6 is not able to communicate to R1.
I also tried adding the native parameter under interface E0/0.26 on R6 and
"switchport trunk native vlan 26" on Sw1.
The same result as previous one.
To debug this issue, I add a SVI 26 on Sw1, and enable debug ip packet on
Sw1 and R6.
By observing the output I noticed there is an "encapsulation failed" error.
Rack1R6(config-subif)#do p 26.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 26.0.0.2, timeout is 2 seconds:
*Mar 1 00:12:35: IP: tableid=0, s=26.0.0.6 (local), d=26.0.0.2
(Ethernet0/0.26), routed via RIB
*Mar 1 00:12:35: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, sending
*Mar 1 00:12:35: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, encapsulation failed.
*Mar 1 00:12:37: IP: tableid=0, s=26.0.0.6 (local), d=26.0.0.2
(Ethernet0/0.26), routed via RIB
*Mar 1 00:12:37: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, sending
*Mar 1 00:12:37: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, encapsulation failed.
*Mar 1 00:12:39: IP: tableid=0, s=26.0.0.6 (local), d=26.0.0.2
(Ethernet0/0.26), routed via RIB
*Mar 1 00:12:39: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, sending
*Mar 1 00:12:39: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, encapsulation failed.
*Mar 1 00:12:41: IP: tableid=0, s=26.0.0.6 (local), d=26.0.0.2
(Ethernet0/0.26), routed via RIB
*Mar 1 00:12:41: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, sending
*Mar 1 00:12:41: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, encapsulation failed.
*Mar 1 00:12:43: IP: tableid=0, s=26.0.0.6 (local), d=26.0.0.2
(Ethernet0/0.26), routed via RIB
*Mar 1 00:12:43: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, sending
*Mar 1 00:12:43: IP: s=26.0.0.6 (local), d=26.0.0.2 (Ethernet0/0.26), len
100, encapsulation failed.
Rack1SW1#p 26.0.0.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 26.0.0.6, timeout is 2 seconds:
*Mar 1 00:58:27: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
sending
*Mar 1 00:58:27: ICMP type=8, code=0
*Mar 1 00:58:27: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
encapsulation failed
*Mar 1 00:58:27: ICMP type=8, code=0.
*Mar 1 00:58:29: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
sending
*Mar 1 00:58:29: ICMP type=8, code=0
*Mar 1 00:58:29: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
encapsulation failed
*Mar 1 00:58:29: ICMP type=8, code=0.
*Mar 1 00:58:31: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
sending
*Mar 1 00:58:31: ICMP type=8, code=0
*Mar 1 00:58:31: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
encapsulation failed
*Mar 1 00:58:31: ICMP type=8, code=0.
*Mar 1 00:58:33: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
sending
*Mar 1 00:58:33: ICMP type=8, code=0
*Mar 1 00:58:33: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
encapsulation failed
*Mar 1 00:58:33: ICMP type=8, code=0.
*Mar 1 00:58:35: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
sending
*Mar 1 00:58:35: ICMP type=8, code=0
*Mar 1 00:58:35: IP: s=26.0.0.7 (local), d=26.0.0.6 (Vlan26), len 100,
encapsulation failed
*Mar 1 00:58:35: ICMP type=8, code=0.
Success rate is 0 percent (0/5)
The only diferrence between my Home Labs and the solution example is the
interface type of R6.
I use a 10Mbps on R6, the solution example use 100Mbps.
Does that mean "native" parameter is only to be worked on 100Mbps
fastethernet but no 10Mbps ethernet.
Thanks.
Regards,
Lin
This archive was generated by hypermail 2.1.4 : Wed Mar 01 2006 - 11:28:17 GMT-3