Re: OSPF Virtual Links

From: Chris Lewis (chrlewiscsco@gmail.com)
Date: Thu Jan 26 2006 - 12:56:01 GMT-3


Mushtaq,

Looks like you are suffering from the infamous order of operations issue.
Try to create the virtual-link first, then assign it to a DLCI.

I ran up this on my routers and it worked fine.

R1#
interface Virtual-Template1
 ip address 135.1.12.1 255.255.255.0
interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 122 ppp Virtual-Template1
!
int e0/0
ip addr 135.1.1.1 255.255.255.0
int s3/0
ip addr 135.1.145.1 255.255.255.0
router ospf 1
 router-id 135.1.1.1
 log-adjacency-changes
 area 12 virtual-link 135.1.2.2
 network 135.1.1.1 0.0.0.0 area 12
 network 135.1.12.0 0.0.0.255 area 12
 network 135.1.145.0 0.0.0.255 area 0

R2#
interface Virtual-Template1
 ip address 135.1.12.2 255.255.255.0
interface Serial1/0
 no ip address
 encapsulation frame-relay
 frame-relay interface-dlci 221 ppp Virtual-Template1
!
int e0/0
ip addr 135.1.2.2 255.255.255.0
int s2/0
ip addr 135.1.22.2 255.255.255.0
!
router ospf 1
 router-id 135.1.2.2
 log-adjacency-changes
 area 12 virtual-link 135.1.1.1
 network 135.1.2.2 0.0.0.0 area 12
 network 135.1.12.0 0.0.0.255 area 12
 network 135.1.22.0 0.0.0.255 area 2
!
Router1(config-router)#do sho ip ospf virt
Virtual Link OSPF_VL0 to router 135.1.2.2 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 12, via interface Virtual-Access1, Cost of using 1
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec
Router1(config-router)#

     172.16.0.0/28 is subnetted, 1 subnets
C 172.16.15.0 is directly connected, Ethernet1/0
C 192.168.1.0/24 is directly connected, Loopback0
     135.1.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 135.1.145.0/24 is directly connected, Serial3/0
O 135.1.2.0/24 [110/11] via 135.1.12.2, 00:12:47, Virtual-Access1
C 135.1.1.0/24 is directly connected, Ethernet0/0
C 135.1.12.2/32 is directly connected, Virtual-Access1
C 135.1.12.0/24 is directly connected, Virtual-Access1
O IA 135.1.22.0/24 [110/65] via 135.1.12.2, 00:12:26, Virtual-Access1
Router1(config-router)#

On 1/26/06, Mushtaq A. Khan <mak.ccie2b@gmail.com> wrote:
>
> I also had somewhat similar issue with virtual link but in my case virtual
> link was keep showing down. In my case, I'm was using PPP over
> Frame-Relay.
> I tried all the possible options but couldn't get it resolved. However,
> when
> I changed my configuration to simple Frame Relay, the virtual link came
> up.
> Can anyone give me some good tips to resolve this. The IOS version I used
> is
> 12.3(14)T4.
>
> Here are my configs for reference:
>
> R1#
> interface Serial0/1
> no ip address
> encapsulation frame-relay
> frame-relay interface-dlci 102 ppp Virtual-Template1
> !
> interface Virtual-Template1
> ip address 135.1.12.1 255.255.255.0
> !
> !
> router ospf 1
> router-id 135.1.1.1
> log-adjacency-changes
> area 12 virtual-link 135.1.2.2
> network 135.1.1.1 0.0.0.0 area 12
> network 135.1.12.0 0.0.0.255 area 12
> network 135.1.145.0 0.0.0.255 area 0
>
> R2#
> interface Serial0/1
> no ip address
> encapsulation frame-relay
> frame-relay interface-dlci 201 ppp Virtual-Template1
> !
> interface Virtual-Template1
> ip address 135.1.12.2 255.255.255.0
> !
> router ospf 1
> router-id 135.1.2.2
> log-adjacency-changes
> area 12 virtual-link 135.1.1.1
> network 135.1.2.2 0.0.0.0 area 12
> network 135.1.12.0 0.0.0.255 area 12
> network 135.1.22.0 0.0.0.255 area 2
> !
>
> Thanks,
> Mushtaq
>
> On 1/26/06, Jonathan Stevens <jonathanstevens.net@googlemail.com> wrote:
> >
> > I've noticed that this seems to vary across platform/IOS
> >
> >
> > Scott Smith wrote:
> >
> > >It should...
> > >
> > >Rack1R1#sh ip ospf nei
> > >Neighbor ID Pri State Dead Time Address
> > Interface
> > >150.1.4.4 0 FULL/ - 00:00:28 155.1.146.4
> > OSPF_VL0
> > >150.1.4.4 1 FULL/DR 00:00:33 155.1.146.4
> > Ethernet0/0
> > >
> > >Rack1R1#sh ip ospf int
> > >OSPF_VL0 is up, line protocol is up
> > > Internet Address 0.0.0.0/0, Area 0
> > > Process ID 1, Router ID 150.1.1.1, Network Type VIRTUAL_LINK, Cost:
> 10
> > > Configured as demand circuit.
> > > Run as demand circuit.
> > > DoNotAge LSA allowed.
> > > Transmit Delay is 1 sec, State POINT_TO_POINT,
> > > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> > > oob-resync timeout 40
> > > Hello due in 00:00:07
> > > Index 2/3, flood queue length 0
> > > Next 0x0(0)/0x0(0)
> > > Last flood scan length is 1, maximum is 1
> > > Last flood scan time is 0 msec, maximum is 0 msec
> > > Neighbor Count is 1, Adjacent neighbor count is 1
> > > Adjacent with neighbor 150.1.4.4 (Hello suppressed)
> > > Suppress hello for 1 neighbor(s)
> > >
> > >IOS Version 12.2(15)T14.
> > >
> > >I believe in previous versions IOS did not show this.
> > >
> > >-Scott
> > >
> > >On 1/14/06, Victor Cappuccio <cvictor@protokolgroup.com> wrote:
> > >
> > >
> > >>Why, If OSPF Virtual Links are considered to be an Interface in Area
> 0,
> > they
> > >>do not appear in the show ip ospf neighbor and they do not appear also
> > in
> > >>the show ip ospf interface??
> > >>
> > >>
> > >>
> > >>Rack1R4#show ip ospf neighbor
> > >>Neighbor ID Pri State Dead Time
> > Address Interface
> > >>1.1.1.1 1 FULL/ - 00:00:32 136.1.41.1
> > Serial0.41
> > >>3.3.3.3 1 FULL/ - 00:01:51 136.1.234.3
> > Serial0.234
> > >>2.2.2.2 1 FULL/ - 00:01:54 136.1.234.2
> > Serial0.234
> > >>3.3.3.3 1 FULL/ - 00:00:34 136.1.43.3
> Serial1
> > >>
> > >>
> > >>Rack1R4#show ip ospf interface | in is up
> > >>Serial0.41 is up, line protocol is up
> > >>Loopback0 is up, line protocol is up
> > >>Serial0.234 is up, line protocol is up
> > >>Serial1 is up, line protocol is up
> > >>
> > >>
> > >>Rack1R4#show ip ospf virtual-links
> > >>Virtual Link OSPF_VL0 to router 3.3.3.3 is up
> > >> Run as demand circuit
> > >> DoNotAge LSA allowed.
> > >> Transit area 34, via interface Serial1, Cost of using 64
> > >> Transmit Delay is 1 sec, State POINT_TO_POINT,
> > >> Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> > >> Hello due in 00:00:04
> > >> Adjacency State FULL (Hello suppressed)
> > >> Index 4/5, retransmission queue length 0, number of retransmission
> 0
> > >> First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
> > >> Last retransmission scan length is 0, maximum is 0
> > >> Last retransmission scan time is 0 msec, maximum is 0 msec
> > >> Message digest authentication enabled
> > >> Youngest key id is 1
> > >>Rack1R4#
> > >>
> > >>Thanks
> > >>Victor.
> > >>
> >
> >>_______________________________________________________________________
> > >>Subscription information may be found at:
> > >>http://www.groupstudy.com/list/CCIELab.html
> > >>
> > >>
> > >
> > >_______________________________________________________________________
> > >Subscription information may be found at:
> > >http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Feb 01 2006 - 07:45:50 GMT-3