From: Charles, Lee (seajay76@nate.com)
Date: Sun Jan 08 2006 - 14:41:41 GMT-3
Oh, it's great you found the problem at L2!!
I don't quite understand how the hello was sent via non static DLCI, though,
here is how you can use only static maps.
Router#conf t
Router(config)#int s0/0
Router(config-if)#encap frame-relay
Router(config-if)#no frame-relay inverse-arp
Router(config-if)#NO SHUT
Router(config-if)#end
Router#
The interface s0/0 must be down/admin down before you designate the encapsulation type as frame-relay.
You can't enter "no frame-relay inverse-arp" command before setting the encapsulation type.
So, the interface should stay shut initially.
If the interface is already up, enter the configuration above and reload the router.
However, this shouldn't be the problem when the router boots up w/o startup-config
because the interfaces would be administratively shut.
You can just proceed the configuration above then.
Just remember that once the encap. type is set to frame-relay,
the active interface will start to populate the frame-relay map dynamically.
HTH, and please somebody add comments if I'm wrong.
Regards,
Charles
----- Original Message -----
From: <siegfried.droogmans@skynet.be>
To: <ccielab@groupstudy.com>
Sent: Monday, January 09, 2006 1:40 AM
Subject: RE: Eigrp over FR problem
> Hi,
>
> I seems I ran into problems because hello's were sent out with other, non static DLCIs. That way, spokes were still setting up a neighbor relationship.
> I used:
> interface Serial4/0
> ip address 150.50.100.6 255.255.255.0
> encapsulation frame-relay
> frame-relay map ip 150.50.100.2 602 broadcast
> frame-relay map ip 150.50.100.5 602 broadcast
> no frame-relay inverse-arp
> end
>
> But show fram map gives this:
> r6#show fram map
> Serial4/0 (up): ip 0.0.0.0 dlci 605(0x25D,0x94D0)
> broadcast,
> CISCO, status defined, active
> Serial4/0 (up): ip 0.0.0.0 dlci 604(0x25C,0x94C0)
> broadcast,
> CISCO, status defined, inactive
> Serial4/0 (up): ip 0.0.0.0 dlci 602(0x25A,0x94A0)
> broadcast,
> CISCO, status defined, active
> Serial4/0 (up): ip 0.0.0.0 dlci 601(0x259,0x9490)
> broadcast,
> CISCO, status defined, active
> Serial4/0 (up): ip 150.50.100.2 dlci 602(0x25A,0x94A0), static,
> broadcast,
> CISCO, status defined, active
> Serial4/0 (up): ip 150.50.100.5 dlci 602(0x25A,0x94A0), static,
> broadcast,
> CISCO, status defined, active
> r6#
> Can someone tell me what to do if I don't want to use these non-static dlcis?
>
> cheers,
> Ziggy
>
> ----------------------------------------
> Long mail for a basic issue with EIGRP:
>
> I want to test EIGRP split-horizon in a Hub-and-Spoke setup. Hub is R6, Spokes are R2 and R5:
>
> 206
> -------- R2
> 602 /
> R6 ------- FR-switch
> 605 \\
> -------- R5
> 506
>
> There is a network on R5 that I do NOT want to receive on R2 because of split-horizon in R6. Sadly enough that is not what is happening:
>
> r2#show ip route
> ....
> 150.50.0.0/16 is variably subnetted, 2 subnets, 2 masks
> D 150.50.7.0/25 [90/2172416] via 150.50.100.5, 00:10:24, Serial0/1/0 ----> ???
> C 150.50.100.0/24 is directly connected, Serial0/1/0
> r2
>
> R6:
> interface Serial4/0
> no ip address
> encapsulation frame-relay
> !
> interface Serial4/0.256 multipoint
> ip address 150.50.100.6 255.255.255.0
> no arp frame-relay
> frame-relay map ip 150.50.100.2 602 broadcast
> frame-relay map ip 150.50.100.5 605 broadcast
> no frame-relay inverse-arp
> !
> router eigrp 1
> network 150.50.0.0
> no auto-summary
>
> R2:
> interface Serial0/1/0
> ip address 150.50.100.2 255.255.255.0
> encapsulation frame-relay
> no arp frame-relay
> frame-relay map ip 150.50.100.5 206 broadcast
> frame-relay map ip 150.50.100.6 206 broadcast
> no frame-relay inverse-arp
> !
> router eigrp 1
> network 150.50.0.0
> no auto-summary
>
> R5:
> interface FastEthernet0/0
> ip address 150.50.7.5 255.255.255.128
> duplex auto
> speed auto
> !
> interface Serial0/1/0
> ip address 150.50.100.5 255.255.255.0
> encapsulation frame-relay
> no arp frame-relay
> frame-relay map ip 150.50.100.2 506 broadcast
> frame-relay map ip 150.50.100.6 506 broadcast
> no frame-relay inverse-arp
>
> The problem is that R5 DOES receive the route. The traces are a bit confusing. Here's the trace when I 'no shut' F0/0 on R5:
> R6:
> r6#
> *Jan 8 09:25:28.223: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
> *Jan 8 09:25:28.223: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 M 2172416 - 1657856 514560 SM 28160 - 25600 2560
> *Jan 8 09:25:28.239: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 metric 2172416 - 1657856 514560
> *Jan 8 09:25:28.255: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 metric 2172416 - 1657856 514560
> *Jan 8 09:25:28.259: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
> *Jan 8 09:25:28.259: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 M 4294967295 - 1657856 4294967295 SM 4294967295 - 1657856 4294967295
> r6#
>
> R2:
> r2#
> *Jan 8 09:31:07.315: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
> *Jan 8 09:31:07.315: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 M 2172416 - 1657856 514560 SM 28160 - 25600 2560
> *Jan 8 09:31:07.315: IP-EIGRP(Default-IP-Routing-Table:1): route installed for 150.50.7.0 ()
> *Jan 8 09:31:07.331: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 metric 2172416 - 1657856 514560
> *Jan 8 09:31:07.343: IP-EIGRP(Default-IP-Routing-Table:1): Processing incoming UPDATE packet
> *Jan 8 09:31:07.343: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 M 4294967295 - 1657856 4294967295 SM 4294967295 - 1657856 4294967295
> r2#
> *Jan 8 09:31:07.347: IP-EIGRP(Default-IP-Routing-Table:1): Int 150.50.7.0/25 metric 2172416 - 1657856 514560
> r2#
>
> I'm working on ProctorLabs gear. FR-Switch config is below.
> R2: 3800 12.4(3a)
> R5: 2800 12.4(3a)
> R6: 7200 12.1
>
>
> FYI: split-horizon on R6 works fine: it does not advertise the route out Serial4/0.256 (when I configure \"no ip split-horizon eigrp 1 I CAN see \"do advertise out Serial4/0.256\")
>
> I just don't understand why/how R2 is receiving the route.
>
>
> Any help would be most welcome!
>
> Ziggy
>
> FR-switch:
>
> interface Serial0
> description Connection to R2 INT S0/1/0
> no ip address
> encapsulation frame-relay
> no ip mroute-cache
> no fair-queue
> clockrate 4000000
> frame-relay intf-type dce
> frame-relay route 104 interface Serial1 401
> frame-relay route 105 interface Serial2 501
> frame-relay route 106 interface Serial3 601
> frame-relay route 204 interface Serial1 402
> frame-relay route 205 interface Serial2 502
> frame-relay route 206 interface Serial3 602
> no shut
> !
> interface Serial1
> description Connection to R4 INT s0/0/0
> no ip address
> encapsulation frame-relay
> clockrate 4000000
> frame-relay intf-type dce
> frame-relay route 401 interface Serial0 104
> frame-relay route 402 interface Serial0 204
> frame-relay route 405 interface Serial2 504
> frame-relay route 406 interface Serial3 604
> no shut
> !
> interface Serial2
> description Connection to R5 int S0/1/0
> no ip address
> encapsulation frame-relay
> clockrate 4000000
> clockrate 115200
> frame-relay intf-type dce
> frame-relay route 501 interface Serial0 105
> frame-relay route 502 interface Serial0 205
> frame-relay route 504 interface Serial1 405
> frame-relay route 506 interface Serial3 605
> no shut
> !
> interface Serial3
> description Connection to R6 Int S4/0
> no ip address
> encapsulation frame-relay
> clockrate 4000000
> clockrate 115200
> frame-relay intf-type dce
> frame-relay route 601 interface Serial0 106
> frame-relay route 602 interface Serial0 206
> frame-relay route 604 interface Serial1 406
> frame-relay route 605 interface Serial2 506
> no shut
> !
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Wed Feb 01 2006 - 07:45:47 GMT-3