From: Chris (chris_atkins@Blueyonder.co.uk)
Date: Thu Dec 15 2005 - 04:31:53 GMT-3
Hi all
Sorry for delay been sleeping ;o) I hope I have covered all your questions.
1. Configs below.
2.Running static RP.
3.100 Pings out of intrest, have failed lab 4 times now so looking deep into
what UI am doimg.
4.The issues seems to be with R1 see below.
5. The fault occurs sometimes straight away now as well.
Thanks in advance.
Chris
Lab_R1#ping 225.5.5.5
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 225.5.5.5, timeout is 2 seconds:
Reply to request 0 from 172.16.1.1, 8 ms
Reply to request 0 from 172.16.34.4, 200 ms
Reply to request 0 from 172.16.123.2, 180 ms
Reply to request 0 from 172.16.34.4, 164 ms
Reply to request 0 from 172.16.123.3, 136 ms
Reply to request 0 from 172.16.123.2, 120 ms
Reply to request 0 from 172.16.123.3, 64 ms
Lab_R1#sh ip mroute 225.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.5.5.5), 08:27:55/00:03:14, RP 172.16.1.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0/1.1, 172.16.123.2, Forward/Sparse, 08:27:40/00:03:14
Serial0/1.1, 172.16.123.3, Forward/Sparse, 08:27:46/00:02:33
Loopback0, Forward/Sparse, 08:27:55/00:02:12
(172.16.1.1, 225.5.5.5), 00:01:10/00:02:22, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0/1.1, 172.16.123.3, Forward/Sparse, 00:01:11/00:02:32
Serial0/1.1, 172.16.123.2, Forward/Sparse, 00:01:11/00:03:13
(172.16.4.4, 225.5.5.5), 00:18:49/00:02:52, flags: LT
Incoming interface: Serial0/1.1, RPF nbr 172.16.123.3
Outgoing interface list:
Loopback0, Forward/Sparse, 00:18:49/00:02:11
(172.16.34.4, 225.5.5.5), 00:09:08/00:02:55, flags: LT
Incoming interface: Serial0/1.1, RPF nbr 172.16.123.3
Outgoing interface list:
Loopback0, Forward/Sparse, 00:09:09/00:02:04
(172.16.123.1, 225.5.5.5), 00:01:19/00:01:40, flags: L
Incoming interface: Serial0/1.1, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:01:19/00:02:03
Serial0/1.1, 172.16.123.3, Forward/Sparse, 00:01:20/00:01:39
Serial0/1.1, 172.16.123.2, Forward/Sparse, 00:01:20/00:01:39
############################################################
Lab_R1#
R1
!ip multicast-routing
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255
ip pim sparse-mode
ip igmp join-group 225.5.5.5
!
!
!
interface Serial0/1.1 multipoint
ip address 172.16.123.1 255.255.255.128
ip pim nbma-mode
ip pim sparse-mode
no ip split-horizon
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
!
!
router rip
version 2
passive-interface default
no passive-interface Serial0/1.1
network 172.16.0.0
neighbor 172.16.123.3
neighbor 172.16.123.2
!
ip pim rp-address 172.16.1.1
############################################################################
###################################
hostname Lab_R2
!
ip multicast-routing
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255
ip pim sparse-mode
ip igmp join-group 225.5.5.5
!
interface Serial0
ip address 172.16.123.2 255.255.255.128
ip pim sparse-mode
encapsulation frame-relay
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.3 201 broadcast
no frame-relay inverse-arp
!
router rip
version 2
passive-interface default
no passive-interface Serial0
network 172.16.0.0
neighbor 172.16.123.1
!
ip pim rp-address 172.16.1.1
############################################################################
#############################################
hostname Lab_R3
!
ip multicast-routing
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255
ip pim sparse-mode
ip igmp join-group 225.5.5.5
!
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0/0.1 point-to-point
ip address 172.16.34.3 255.255.255.128
ip pim sparse-mode
frame-relay interface-dlci 304
!
interface Serial0/0.3 point-to-point
ip address 172.16.123.3 255.255.255.128
ip pim sparse-mode
frame-relay interface-dlci 301
!
router rip
version 2
redistribute static metric 2
passive-interface default
no passive-interface Serial0/0.1
no passive-interface Serial0/0.3
network 172.16.0.0
neighbor 172.16.123.1
!
ip route 172.16.200.13 255.255.255.255 172.16.35.5
!
ip pim rp-address 172.16.1.1
!
############################################################################
###################################
hostname Lab_R4
!
ip multicast-routing
!interface Loopback0
ip address 172.16.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip igmp join-group 225.5.5.5
!
!
interface Serial0/0
ip address 172.16.34.4 255.255.255.128
encapsulation frame-relay
frame-relay map ip 172.16.34.3 403 broadcast
no frame-relay inverse-arp
!
router rip
version 2
passive-interface default
no passive-interface Serial0/0
network 4.0.0.0
network 172.16.0.0
!
ip pim rp-address 172.16.1.1
############################################################################
######################################
During failure.
R1
Lab_R1#sh ip mroute 225.5.5.5
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.5.5.5), 08:16:14/00:03:23, RP 172.16.1.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial0/1.1, 172.16.123.2, Forward/Sparse, 08:16:00/00:03:03
Serial0/1.1, 172.16.123.3, Forward/Sparse, 08:16:06/00:03:23
Loopback0, Forward/Sparse, 08:16:14/00:02:55
(172.16.4.4, 225.5.5.5), 00:07:08/00:02:58, flags: LT
Incoming interface: Serial0/1.1, RPF nbr 172.16.123.3
Outgoing interface list:
Loopback0, Forward/Sparse, 00:07:09/00:02:54
###############################################################
R2
Lab_R2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.5.5.5), 15:22:47/00:02:40, RP 172.16.1.1, flags: SJCLF
Incoming interface: Serial0, RPF nbr 172.16.123.1
Outgoing interface list:
Loopback0, Forward/Sparse, 15:22:47/00:02:40
(*, 224.0.1.40), 15:22:48/00:02:39, RP 172.16.1.1, flags: SJCL
Incoming interface: Serial0, RPF nbr 172.16.123.1
Outgoing interface list:
Loopback0, Forward/Sparse, 15:22:48/00:02:39
##########################################################
R3
Lab_R3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.5.5.5), 13:04:53/00:03:26, RP 172.16.1.1, flags: SJCLF
Incoming interface: Serial0/0.3, RPF nbr 172.16.123.1
Outgoing interface list:
Serial0/0.1, Forward/Sparse, 12:41:26/00:03:26
Loopback0, Forward/Sparse, 13:04:53/00:02:06
(172.16.4.4, 225.5.5.5), 00:08:46/00:02:55, flags: LT
Incoming interface: Serial0/0.1, RPF nbr 172.16.34.4
Outgoing interface list:
Serial0/0.3, 172.16.123.1, Forward/Sparse, 00:08:46/00:02:51
Loopback0, Forward/Sparse, 00:08:47/00:02:05
(*, 224.0.1.40), 13:04:54/00:02:49, RP 172.16.1.1, flags: SJCL
Incoming interface: Serial0/0.3, RPF nbr 172.16.123.1
Outgoing interface list:
Serial0/0.1, Forward/Sparse, 12:41:27/00:02:49
Loopback0, Forward/Sparse, 13:04:54/00:02
----- Original Message -----
From: "John Matus" <jmatus@pacbell.net>
To: "Schulz, Dave" <DSchulz@dpsciences.com>; "Godswill Oletu "
<oletu@inbox.lv>; <nobody@groupstudy.com>; "Chris "
<chris_atkins@Blueyonder.co.uk>; <ccielab@groupstudy.com>
Sent: Thursday, December 15, 2005 4:07 AM
Subject: Re: Pim Issue
> very interesting.........
> but who would test by sending over 100 pings unless there was an rpf
failure
> and you were trying to debug ip mpacket...............
>
>
> Regards,
>
> John D. Matus
> MCSE, CCNP
> Office: 818-782-2061
> Cell: 818-430-8372
> jmatus@pacbell.net
> ----- Original Message -----
> From: "Schulz, Dave" <DSchulz@dpsciences.com>
> To: "Godswill Oletu " <oletu@inbox.lv>; <nobody@groupstudy.com>; "Chris "
> <chris_atkins@Blueyonder.co.uk>; <ccielab@groupstudy.com>
> Sent: Wednesday, December 14, 2005 6:32 PM
> Subject: RE: Pim Issue
>
>
> > These are all great questions, Godswill. But I am wondering which ones
> > could
> > possibly cause the pings to start and then fail. Hmmmm.
> >
> > Dave
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com
> > To: Chris; ccielab@groupstudy.com
> > Sent: 12/14/2005 8:34 PM
> > Subject: Re: Pim Issue
> >
> > couple of questions:
> >
> > 1. which router joined the group 225.5.5.5?
> > 2. Are you running Auto-RP or static RP?
> > 3. If Auto-RP, which Router is your MA?
> > 4 If static-RP, hope it is configured on all Routers?
> > 4. If Auto-RP, did you enable nbma-mode on R1?
> > 5. If Auto-RP, did youu enable Auto-RP listener?
> >
> > Answer to these questions, will give one a better understanding of your
> > scenario.
> >
> > HTH
> > Godswill Oletu
> >
> > ----- Original Message -----
> > From: "Chris" <chris_atkins@Blueyonder.co.uk>
> > To: <ccielab@groupstudy.com>
> > Sent: Wednesday, December 14, 2005 6:19 PM
> > Subject: Pim Issue
> >
> >
> >> R4----------------------R3
> >> |
> >> |
> >> |
> >> R1------------- R2
> >>
> >> Hi
> >> I hope someone can help me with this as pulling hair out.
> >>
> >> R1is hub and R2 and R3 are spokes NBMA multipoint.
> >>
> >> R4 to R3 is serial HDLC.
> >>
> >> Running pim sparse RP is R1.
> >>
> >> Can ping fine, however pings( multicast group 225.5.5.5) from R4 time
> > out
> >> aftrer approx 90 - 100 pings. A bit lost what going on (If restart
> > ping
> >> still
> >> fails.), any help most apprciated in advance.
> >>
> >> Cheers
> >>
> >> Chris
> >>
> >>
> > _______________________________________________________________________
> >> Subscription information may be found at:
> >> http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Mon Jan 09 2006 - 07:07:51 GMT-3