Re: Injecting default route only with loss of IP route WAS: Re:

From: Arun Arumuganainar (aarumuga@hotmail.com)
Date: Thu Dec 08 2005 - 11:30:26 GMT-3


Hi Brian

Cool . My topology looks like this

GooD----Edge---ISIS-Cloud

Here Edge is a L1 ISIS Router that connects to backbone...Nick Named as
GOOD. FYI : All backbone routers are good routers as we need not spend time
configuring this . Back Bone advertises only default route to Edge router .
Edge will have to advertise default route back in to the ISIS network .

Pls. note : Redistribution of Default route is not possible in ISIS . Hence
we resort to default-originate command . Here the advertisement is
conditional . Condition is that , BGP advertised default route should be
installed in the routing table . We use route map to achieve the same .

FYI : My setup is a bigger setup. And I dismantled it some time back .Hence
I am not able to capture the "show ip route" with and with out bgp
default-route now . Probably I would try to create a simpler version of the
setup in the next few days and provide you with the o/p.

At the moment ...Believe me ...This is very much a working config .

Thanks and Regards

Arun

!
version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Edge

!

no logging console

!

memory-size iomem 10

ip subnet-zero

!

!

ip tcp synwait-time 5

no ip domain-lookup

ip host Core-2 172.2.1.4

ip host Edge 172.2.1.3

ip host Core-1 172.1.1.2

ip host Site-1 172.1.1.1

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Loopback0

 ip address 172.2.1.3 255.255.255.255

!

interface FastEthernet0/0

 description Edge to Good

 ip address 192.168.20.2 255.255.255.0

 speed auto

 half-duplex

!

interface Serial0/0

 no ip address

 encapsulation frame-relay

 frame-relay lmi-type cisco

!

interface Serial0/0.1 point-to-point

 description Edge to Core-2

 ip address 192.168.1.5 255.255.255.252

 ip router isis

 isis circuit-type level-1

 frame-relay interface-dlci 100

!

interface FastEthernet0/1

 no ip address

 shutdown

 speed auto

 half-duplex

!

interface Serial0/1

 no ip address

 shutdown

!

router isis

 passive-interface Loopback0

 default-information originate route-map bgp-default-check

 net 49.0002.0000.0000.0003.00

 is-type level-1

 metric-style wide

!

router bgp 65002

 bgp log-neighbor-changes

 redistribute connected route-map conn-loopback

 redistribute isis level-1 route-map loopback-into-bgp

 neighbor 192.168.20.20 remote-as 65001

 no auto-summary

!

ip classless

no ip http server

ip pim bidir-enable

!

!

ip access-list standard bgp-default

 permit 0.0.0.0

ip access-list standard loopbacks

 permit 172.0.0.0 0.255.255.255

route-map conn-loopback permit 10

 match interface Loopback0

!

route-map bgp-default-check permit 10

 match ip address bgp-default

 set level level-1

!

route-map loopback-into-bgp permit 10

 match ip address loopbacks

!

!

!

dial-peer cor custom

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

 ip netmask-format decimal

line aux 0

line vty 0 4

 privilege level 15

 logging synchronous

 no login

!

no scheduler allocate

end

----- Original Message -----
From: "Brian McGahan" <bmcgahan@internetworkexpert.com>
To: "Arun Arumuganainar" <aarumuga@hotmail.com>
Cc: "Cisco certification" <ccielab@groupstudy.com>
Sent: Thursday, December 08, 2005 7:23 PM
Subject: RE: Injecting default route only with loss of IP route WAS: Re: IE
Lab 6 conditional default route advertisement

> Post the config along with the pre and post routing tables when
> the tracked network is up and down.
>
> Brian McGahan, CCIE #8593
> bmcgahan@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987 x 705
> Outside US: 775-826-4344 x 705
> 24/7 Support: http://forum.internetworkexpert.com
> Live Chat: http://www.internetworkexpert.com/chat/
>
>
> > -----Original Message-----
> > From: Arun Arumuganainar [mailto:aarumuga@hotmail.com]
> > Sent: Thursday, December 08, 2005 12:22 AM
> > To: Brian McGahan; Andrew Lissitz (alissitz); Mike Flanagan
> > Cc: Cisco certification
> > Subject: Re: Injecting default route only with loss of IP route WAS:
> Re:
> > IE Lab 6 conditional default route advertisement
> >
> > Hi Brian ,
> >
> > I have tried this with ISIS . Its was working perfectly .
> >
> > Thanks and Regards
> > Arun
> >
> > ----- Original Message -----
> > From: "Brian McGahan" <bmcgahan@internetworkexpert.com>
> > To: "Andrew Lissitz (alissitz)" <alissitz@cisco.com>; "Mike Flanagan"
> > <mikenoc@mindspring.com>; "Arun Arumuganainar" <aarumuga@hotmail.com>
> > Cc: "Cisco certification" <ccielab@groupstudy.com>
> > Sent: Thursday, December 08, 2005 11:02 AM
> > Subject: RE: Injecting default route only with loss of IP route WAS:
> Re:
> > IE
> > Lab 6 conditional default route advertisement
> >
> >
> > > Only BGP supports this via conditional advertisement.
> > >
> > > Brian McGahan, CCIE #8593
> > > bmcgahan@internetworkexpert.com
> > >
> > > Internetwork Expert, Inc.
> > > http://www.InternetworkExpert.com
> > > Toll Free: 877-224-8987 x 705
> > > Outside US: 775-826-4344 x 705
> > > 24/7 Support: http://forum.internetworkexpert.com
> > > Live Chat: http://www.internetworkexpert.com/chat/
> > >
> > >
> > > > -----Original Message-----
> > > > From: Andrew Lissitz (alissitz) [mailto:alissitz@cisco.com]
> > > > Sent: Wednesday, December 07, 2005 11:02 PM
> > > > To: Mike Flanagan; Brian McGahan; Arun Arumuganainar
> > > > Cc: Cisco certification
> > > > Subject: RE: Injecting default route only with loss of IP route
> WAS:
> > > Re:
> > > > IE Lab 6 conditional default route advertisement
> > > >
> > > > Hey Arun, Mike, Brian, and group,
> > > >
> > > > In a separate email, Arun suggested the default-information
> command
> > > that
> > > > referenced a route-map. I configured this and got it to work for
> a
> > > > route that was in the routing table. Nice feature, thanks Arun
> for
> > > > suggesting this.
> > > >
> > > > As Mike asks however, how to do this for a route not in the table
> via
> > > an
> > > > IGP?
> > > >
> > > >
> > > >
> > > > -----Original Message-----
> > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> Behalf
> > > Of
> > > > Mike Flanagan
> > > > Sent: Wednesday, December 07, 2005 6:25 PM
> > > > To: Brian McGahan
> > > > Cc: Cisco certification
> > > > Subject: Re: Injecting default route only with loss of IP route
> WAS:
> > > Re:
> > > > IE Lab 6 conditional default route advertisement
> > > >
> > > > I was thinking of doing this in the IGP like OSPF. Similar to
> how
> > > you
> > > > have in your Internetwork Expert lab 6 for conditional default
> route
> > > > injection. Only difference is that instead of advertising when you
> > > have
> > > > a route only advertising when the out leaves.
> > > >
> > > >
> > > > On Dec 7, 2005, at 6:11 PM, Brian McGahan wrote:
> > > >
> > > > > You could do this with BGP conditional advertisement.
> > > > >
> > > > >
> > > > > HTH,
> > > > >
> > > > > Brian McGahan, CCIE #8593
> > > > > bmcgahan@internetworkexpert.com
> > > > >
> > > > > Internetwork Expert, Inc.
> > > > > http://www.InternetworkExpert.com
> > > > > Toll Free: 877-224-8987 x 705
> > > > > Outside US: 775-826-4344 x 705
> > > > > 24/7 Support: http://forum.internetworkexpert.com
> > > > > Live Chat: http://www.internetworkexpert.com/chat/
> > > > >
> > > > >
> > > > > -----Original Message-----
> > > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> Behalf
> > > > > Of Mike Flanagan
> > > > > Sent: Wednesday, December 07, 2005 3:29 PM
> > > > > To: Mike Flanagan
> > > > > Cc: Cisco certification
> > > > > Subject: Injecting default route only with loss of IP route WAS:
> > > > > Re: IE
> > > > > Lab 6 conditional default route advertisement
> > > > >
> > > > > Is there a way to only send a default route if you loose a
> route
> > > in
> > > >
> > > > > the IP routing table ?
> > > > >
> > > > >
> > > > >
> > > > > On Dec 7, 2005, at 12:06 PM, Mike Flanagan wrote:
> > > > >
> > > > >
> > > > >> In this section for injecting a default route you only do it
> if
> > > your
> > > >
> > > > >> route-map matches the networks in question. Like for instance
> as
> > > long
> > > >
> > > > >> as I have a route to 192.10.1.0/24 advertise the default route.
> > > Well
> > > > >> what if I wanted to advertise the default route if I lost a
> route
> > > in
> > > > >> my route table ? Like for instance lets say if I lost my
> connection
> > > > >> to BB2 would I use
> > > > >>
> > > > >> router ospf 1
> > > > >> default-information originate always route-map CONDITION
> > > > >>
> > > > >> ip prefix-list BB2 seq 5 permit 192.10.1.0/24
> > > > >>
> > > > >> ip prefix-list BB3 seq 5 permit 204.12.1.0/24
> > > > >>
> > > > >> route-map CONDITION deny 10
> > > > >> match ip address prefix-list BB2
> > > > >>
> > > > >> rute-map CONDITION deny 20
> > > > >> match ip address prefix-list BB3
> > > > >>
> > > > >> I think with this I would only advertise the default route if
> I
> > > lose
> > > >
> > > > >> either route in my route table is this correct ?
> > > > >>
> > > > >> Also with this solution would I only advertise the default
> route
> > > if
> > > > >> I lose both connections at the same time ?
> > > > >>
> > > > >> router ospf 1
> > > > >> default-information originate always route-map CONDITION
> > > > >>
> > > > >> ip prefix-list BB2 seq 5 permit 192.10.1.0/24 ip prefix-list
> BB2
> > > seq
> > > > >> 5 permit 204.12.1.0/24
> > > > >>
> > > > >> route-map CONDITION deny 10
> > > > >> match ip address prefix-list BB2
> > > > >>
> > > > >>
> > >
> _____________________________________________________________________
> > > > >> _
> > > > >>
> > > > >
> > > > >
> > > > >> _
> > > > >> Subscription information may be found
> at:http://www.groupstudy.com/
> > > > >> list/CCIELab.html
> > > > >>
> > > > >
> > > > >
> > >
> ______________________________________________________________________
> > > > > _
> > > > > Subscription information may be found at:
> > > > > http://www.groupstudy.com/list/CCIELab.html
> > > > >
> > > > >
> > >
> ______________________________________________________________________
> > > > > _
> > > > > Subscription information may be found at:
> > > > > http://www.groupstudy.com/list/CCIELab.html
> > > >
> > > >
> > >
> _______________________________________________________________________
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Mon Jan 09 2006 - 07:07:50 GMT-3