From: Godswill Oletu (oletu@inbox.lv)
Date: Sun Dec 04 2005 - 06:56:13 GMT-3
Anthony,
Attempt 1 in your post should bring up the tunnel interfaces at both end. At
least your IGP will be advertising those routes and the tunnel will be up
up.
The only ways I have been able to make this to work are:
1. Local route policy maps.
2. Using one IGP to advertise the tunnel source/destination ip addresses and
another different IGP to advertise the Loopback addresses:
The configure for the policy map will be obvious, for the second method,
this is what worked for me:
BGP Peering:
R1(s0=1.1.1.1/8)<-->(s0=1.1.1.2/0)R2(s1=2.2.2.2/8)<-->(s0=2.2.2.1/8)R3
R1:
interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface Tunnel14
ip unnumbered Loopback0
tunnel source 1.1.1.1
tunnel destination 2.2.2.1
!
interface Serial0/0
ip address 1.1.1.1 255.0.0.0
!
router eigrp 1
network 5.0.0.0
!
router rip
network 1.0.0.0
!
router bgp 1
neighbor 7.7.7.7 remote-as 1
!
------------------
R2:
!
interface Serial0
ip address 1.1.1.2 255.0.0.0
clockrate 125000
!
interface Serial1
ip address 2.2.2.2 255.0.0.0
clockrate 125000
!
router rip
network 1.0.0.0
network 2.0.0.0
!
-----------------
R3:
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Tunnel14
ip unnumbered Loopback0
tunnel source 2.2.2.1
tunnel destination 1.1.1.1
!
interface Serial0
ip address 2.2.2.1 255.0.0.0
!
router eigrp 1
network 7.0.0.0
!
router rip
network 2.0.0.0
!
router bgp 1
neighbor 5.5.5.5 remote-as 1
!
--------
To validate that the bgp traffic is going through tunnel14, do the
following on R1 & R2:
access-list 100 permit tcp any any eq bgp
access-list 100 permit tcp any eq bgp any
debug ip packet 100
clear ip bpg 1
Results:
00:21:31: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 40, rcvd 4
00:21:33: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 40, rcvd 4
00:21:41: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 44, rcvd 4
00:21:41: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 104, rcvd 4
00:21:41: %BGP-5-ADJCHANGE: neighbor 5.5.5.5 Up
00:21:41: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 131, rcvd 4
00:21:41: IP: s=5.5.5.5 (Tunnel14), d=7.7.7.7, len 40, rcvd 4
HTH
----- Original Message -----
From: "Zouta oxpf" <zouta.oxpf@gmail.com>
To: "Anthony Sequeira" <terry.francona@gmail.com>
Cc: "Cisco certification" <ccielab@groupstudy.com>
Sent: Thursday, November 24, 2005 8:11 AM
Subject: Re: Let's Tunnel BGP Due to Non-BGP Speaker in Transit Path!
> Anthony:
>
> If your interfaces are all in IGP, then using ip unnumbered to to that
> interface will recurse to that interface during route-recursion, still
> blackholing traffic. If your interfaces are not in IGP, and not on same
> subnet, BGP peering might not come up, a big dillemma.
>
> Seems like a good question for the Proctor. He/She might allow the
creation
> of a subnet from within your given address space; If it's not allowed, why
> do the Workbook vendors do it so often?
>
> Just a thought.
>
> Happy Thanksgiving to the whole of Groupstudy!
>
> ZO
>
>
> On 11/23/05, Anthony Sequeira <terry.francona@gmail.com> wrote:
> >
> > I want to tunnel my iBGP peering from R1 to R4 because R2 is not running
> > BGP. I want to use the loopback 0 interfaces for the peerings. The IGP
in
> > use is EIGRP and all of the interfaces shown below are running EIGRP.
> >
> >
> >
> > R1-----4.4.8.0/24-----R2-----4.4.12.0/24-----R4
> >
> >
> >
> > R1 lo0 4.4.1.1/24
> >
> > R4 lo0 4.4.4.4/24
> >
> >
> >
> > I have this sample scenario labbed up and I am having a heck of a time.
I
> > have tried the following with no luck:
> >
> >
> >
> > Attempt 1
> >
> > R1:
> >
> > int tunnel 0
> >
> > ip unnumbered lo0
> >
> > tunnel source 4.4.8.1
> >
> > tunnel destination 4.4.12.4
> >
> >
> >
> > R2:
> >
> > int tunnel 0
> >
> > ip unnumbered lo0
> >
> > tunnel source 4.4.12.4
> >
> > tunnel destination 4.4.8.1
> >
> >
> >
> > Attempt 2
> >
> > R1:
> >
> > int tunnel 0
> >
> > ip unnumbered lo0
> >
> > tunnel source lo0
> >
> > tunnel destination 4.4.4.4
> >
> >
> >
> > R2:
> >
> > int tunnel 0
> >
> > ip unnumbered lo0
> >
> > tunnel source lo0
> >
> > tunnel destination 4.4.1.1
> >
> >
> >
> > You see this is easy and works great if I create a new subnet for the
> > tunnel and use that in my BGP peerings the issue that I am having is
> > trying to use the loopback addresses for the peerings and still use my
> > tunnel.
> >
> >
> >
> > I notice that my tunnel interface does not show up in the routing table
> > when
> > I am pulling the address from the loopback..I guess this must be why my
> > BGP
> > is not using it????
> >
> >
> >
> > Anyone feel like labbing this one up and trying this one? Or is it
> > something
> > really simple that I am missing about tunnels?
> >
> >
> >
> > Thanks in advance for you consideration of this e-mail.
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Mon Jan 09 2006 - 07:07:50 GMT-3