RE: No Best Path with BGP

From: Scott Morris (swm@emanon.com)
Date: Sat Dec 03 2005 - 15:31:34 GMT-3


This would work as well, if BGP is the ONLY method that you are learning
that next-hop IP from. If you have a static route, or IGP or something
giving presence, that's not needed.

But it is a fun exercise nonetheless...

Just pointing out an obvious thing though, you would have already needed
ebgp-multihop to form the relationship to begin with, but if your TTL #
wasn't big enough to reach to the loopback as well, then you'd run into
problems.

Odd little creature like that. :)

Scott

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Brian Dennis
Sent: Saturday, December 03, 2005 12:50 AM
To: Anthony Sequeira; swm@emanon.com
Cc: Cisco certification
Subject: RE: No Best Path with BGP

Anthony,
        You need to add eBGP multihop to your configuration since you
changed the next hop to an IP address that isn't directly connected.

<config>
router bgp 1
 no synchronization
 neighbor 136.1.12.2 remote-as 2
 neighbor 136.1.12.2 route-map SET->NEXT->HOP in no auto-summary !
route-map SET->NEXT->HOP permit 10
 set ip next-hop 150.2.2.2
</config>

Rack2R1#sho ip bgp 172.16.0.0
BGP routing table entry for 172.16.0.0/16, version 0
Paths: (1 available, no best path)
  Not advertised to any peer
  2
    150.2.2.2 (inaccessible) from 136.1.12.2 (150.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, external Rack2R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Rack2R1(config)#router bgp 1
Rack2R1(config-router)#neighbor 136.1.12.2 ebgp-multihop 10
Rack2R1(config-router)#^Z Rack2R1# Rack2R1#clear ip bgp * Rack2R1# *Mar 1
00:59:11.201: %BGP-5-ADJCHANGE: neighbor 136.1.12.2 Down User reset *Mar 1
00:59:49.403: %BGP-5-ADJCHANGE: neighbor 136.1.12.2 Up Rack2R1#sho ip bgp
172.16.0.0 BGP routing table entry for 172.16.0.0/16, version 2
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Not advertised to any peer
  2
    150.2.2.2 (metric 11) from 136.1.12.2 (150.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, external, best Rack2R1#

HTH,

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
 
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
 

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Anthony Sequeira
Sent: Friday, December 02, 2005 9:17 PM
To: swm@emanon.com
Cc: Cisco certification
Subject: Re: No Best Path with BGP

Yes there was full reachability in the underlying IGP to all routes.

R2 has a route to the loopback of R5.

Why in the world would it say 150.1.5.5 (inaccessible) from 136.1.245.5
(
150.1.5.5)?

This is saying the Lo0 interface of R5 is unreachable from the
Serial0/0.245
subinterface of R5.

You would think it would say Lo0 interface of R5 is unreachable from an
interface of R2.

Damn - I wish I had not gotten kicked off right when I doscvered this
problem! These captures were all I was able to retrieve.

Thanks everyone for trying to help here. . .

On 12/2/05, Scott Morris <swm@emanon.com> wrote:
>
> Is 150.1.5.5 in the routing table?
>
> More importantly, is it in there with something other than a default
route
> to get to it?
>
> Seems the router is telling you the problem. :) But of course, right
at
> the end of time doesn't exactly help in testing things, does it!
>
> Scott
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Anthony Sequeira
> Sent: Friday, December 02, 2005 8:42 PM
> To: Cisco certification
> Subject: No Best Path with BGP
>
> Wow - is this interesting....sadly it happened right as I got kicked
off
> my
> rental rack today....so I need the expertise of the group to help me
> understand.....
>
> Simple BGP topology......
>
> R5(AS 200) -------------R2(AS 300)
>
> I wanted to use a route-map to change the next-hop value of incoming
> routes
> from R5 so that the next hop will be the loopback of R5. By the way -
I
> had
> best paths and everything was fine before trying this change....
>
> R2#
> !
> router bgp 300
> no synchronization
> neighbor 136.1.245.5 remote-as 200
> neighbor 136.1.245.5 route-map HOPPER in no auto-summary !
> route-map HOPPER permit 10
> set ip next-hop 150.1.5.5
>
> After this config - the next hop does change - but now no BEST PATHs:
>
> R2#show ip bgp
> BGP table version is 7, local router ID is 150.1.2.2 Status codes: s
> suppressed, d damped, h history, * valid, > best, i - internal,
> r RIB-failure, S Stale
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> * 205.90.31.0 150.1.5.5 0 200 254 ?
> * 220.20.3.0 150.1.5.5 0 200 254 ?
> * 222.22.2.0 150.1.5.5 0 200 254 ?
> I try and get some details:
>
> R2#show ip bgp 222.22.2.0
> BGP routing table entry for 222.22.2.0/24, version 7
> Paths: (1 available, no best path)
> Not advertised to any peer
> 200 254
> 150.1.5.5 (inaccessible) from 136.1.245.5 (150.1.5.5)
> Origin incomplete, localpref 100, valid, external
>
> OK - so 150.1.5.5 is inaccessible from 136.1.245.5? My goodness -
these
> interfaces are on the same router! What gives? Could it be that
> 136.1.245.5is a Frame Relay interface that is not pingable from the
> loopback
> address ( 150.1.5.5)? OK - I know I am reaching - but I am tired after
10
> hours on the rack.....
>
> Can anyone help?
>
>



This archive was generated by hypermail 2.1.4 : Mon Jan 09 2006 - 07:07:50 GMT-3