RE: IPv6 redistribution with RIP

From: Schulz, Dave (DSchulz@dpsciences.com)
Date: Wed Nov 30 2005 - 19:49:59 GMT-3


Well, after much ado....I believe that this problem is solved, but I
don't necessarily like or understand the solution. It appears to me
that Ipv6 is not quite "ready for prime-time"....or, I'm really missing
something. Anyway, the problem is in the redistribution point. It
appears that if you redistribute between 2 ipv6 protocols, that you must
also, add the statement redistribute connected....even if you are not
just looking to add the loopback interfaces into the database.
Therefore, the solution is at R3 and as follows...... (can someone
please explain to me why this works and the original one doesn't)......

ipv6 unicast-routing
!
!
interface Loopback603
 no ip address
 ipv6 address FEC0::103:1/125
!
interface Serial0.2 multipoint
 ip address 172.16.123.3 255.255.255.128
 ipv6 address FEC0::123:3/125
 ipv6 address FE80::3 link-local
 ipv6 rip FRAME-123 enable
 frame-relay map ipv6 FE80::2 301
 frame-relay map ipv6 FEC0::123:1 301 broadcast
 frame-relay map ipv6 FEC0::123:2 301
 frame-relay map ip 172.16.123.1 301 broadcast
 frame-relay map ip 172.16.123.2 301
 frame-relay map ip 172.16.123.3 301
 frame-relay map ipv6 FE80::1 301 broadcast
 no frame-relay inverse-arp
!
interface Serial0.4 point-to-point
 ip address 172.16.34.3 255.255.255.128
 no ip split-horizon
 ipv6 address FEC0::34:3/125
 ipv6 address FE80::3 link-local
 ipv6 rip FRAME-34 enable
 frame-relay interface-dlci 304
!
ipv6 router rip FRAME-34
 redistribute connected metric 1
 redistribute rip FRAME-123 metric 1
!
ipv6 router rip FRAME-123
 redistribute connected metric 1
 redistribute rip FRAME-34 metric 1
!

Dave Schulz,

Email: dschulz@dpsciences.com

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Schulz, Dave
Sent: Wednesday, November 30, 2005 11:29 AM
To: Niche; Gustavo Novais
Cc: ccielab@groupstudy.com
Subject: RE: IPv6 redistribution with RIP

It appears that the basic routing works great....the issue is now
appears to be in the redistribution between the two rip processes on
R3.......I cannot ping the 34:0 link between R3 and R4, as well as, the
loop on R4. So, now I am looking a little closer at R3.

Dave Schulz,
Email: dschulz@dpsciences.com

-----Original Message-----
From: Niche [mailto:jackyliu419@gmail.com]
Sent: Wednesday, November 30, 2005 11:08 AM
To: Schulz, Dave
Subject: Re: IPv6 redistribution with RIP

Use ipv6 access-list? I think you can give it a try but I can't figure
out a reason why match interface cannot do the same thing.

May be try add "match interface Serial0" in that route-map as well?

Try pull yourself out of the box, finish simple ipv6 routing first
(confirm you have done it correctly), then do the advance steps (e.g.
redistribution, etc).

Jacky

On 11/30/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
> Jacky -
>
> I included the interfaces in the route-map Lv6.....
>
> route-map Lv6 permit 10
> match interface Loopback604
>
> should I be using an access-list for this maybe?
>
>
>
> Dave Schulz,
> Email: dschulz@dpsciences.com
>
>
>
> -----Original Message-----
> From: Niche [mailto:jackyliu419@gmail.com]
> Sent: Wednesday, November 30, 2005 10:14 AM
> To: Schulz, Dave
> Subject: Re: IPv6 redistribution with RIP
>
> Hi Dave,
>
> If you insist to use route-map, I think you should add the related
> serial interface into the route-map as well.
>
> I take my experience when I was messing with one of the IPv6 lab
> (RIPv6 and OSPFv6). I have to redistribute the connected interface
> which is running OSPF or RIP as well when doing mutual redistribution
> between these 2 routing protocol. Your route-map excluded those
> interface.
>
> Best Regards,
> Jacky
>
> On 11/30/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
> > Ok....but if you are doing redistributed connected, where the rip
> > process is not identified under the interface....is this the best
way
> > (using a route-map). Keeping in mind, that I would want to limit
> > redistribution to the single loopback, and not have everything that
is
> > connected to join the party.
> >
> >
> > Dave Schulz,
> > Email: dschulz@dpsciences.com
> >
> >
> >
> > -----Original Message-----
> > From: Niche [mailto:jackyliu419@gmail.com]
> > Sent: Wednesday, November 30, 2005 9:58 AM
> > To: Schulz, Dave
> > Subject: Re: IPv6 redistribution with RIP
> >
> > Hi Dave,
> >
> > Have you try remove the route-map and just redistribute connected?
> > Personally I think it's not necessary in your setup cause the rip
> > process on each interface has identify which interface should be
> > redistribute in that ripv6 process.
> >
> > Best Regards,
> > Jacky
> >
> > On 11/30/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
> > > Jacky -
> > >
> > > Thanks for the response. Actually, I tried it both ways....by
> having
> > > the loopback internal to rip.....ipv6 rip FRAME-34 enable under
the
> > > Loopback interface. And, the way.... having the loopback become
an
> > > external route through redistribution connected.
> > >
> > >
> > > Dave Schulz,
> > > Email: dschulz@dpsciences.com
> > >
> > >
> > >
> > > -----Original Message-----
> > > From: Niche [mailto:jackyliu419@gmail.com]
> > > Sent: Wednesday, November 30, 2005 9:50 AM
> > > To: Schulz, Dave
> > > Subject: Re: IPv6 redistribution with RIP
> > >
> > > One more thing, was that "ipv6 rip FRAME-34 enable" missed out in
> the
> > > interface Loopback604 configuration during cut-and-paste?
> > >
> > >
> > > On 11/30/05, Niche <jackyliu419@gmail.com> wrote:
> > > > Hi Dave,
> > > >
> > > > Try remove the route-map configuration, just redistribute
connect
> > with
> > > > metric and don't do any route-map and see what happen.
> > > >
> > > > Best Regards,
> > > > Jacky
> > > >
> > > > On 11/30/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
> > > > > Here is an issue that I am having with IPv6
redistribution.....I
> > > have 4
> > > > > routers set up on two frame networks......
> > > > >
> > > > > R1------------------R3(loop603------------------------R4
> (loop604)
> > > > > \------------R2(loop602)
> > > > >
> > > > > I can see all the routes at R1, except the loop604 at R4
> (however,
> > I
> > > see
> > > > > the route to it both in the RIB and rip database. I am
> > > redistributing
> > > > > the route into rip at R4, and redistributing at R3
> (understanding
> > > that
> > > > > the loopback must still be redistributed if it is connected
> > directly
> > > to
> > > > > the router (under IPv6). I also tried to add the R4 directly
> into
> > > the
> > > > > rip process as an internal route, but it still cannot be
reached
> > by
> > > R1.
> > > > > At first, I thought this to be a split horizon issue (in rip),
> but
> > > when
> > > > > it was turned off at R1, the issue continues to exist. Here
are
> > the
> > > > > configs.....any direction would be appreciated......
> > > > >
> > > > > ---------------------------------------------
> > > > > R1#
> > > > > !
> > > > > ipv6 unicast-routing
> > > > > !
> > > > > !
> > > > > interface Serial0/0.123 multipoint
> > > > > ip address 172.16.123.1 255.255.255.128
> > > > > no ip split-horizon
> > > > > ipv6 address FEC0::123:1/125
> > > > > ipv6 address FE80::1 link-local
> > > > > ipv6 rip FRAME-123 enable
> > > > > frame-relay map ipv6 FE80::2 102 broadcast
> > > > > frame-relay map ipv6 FE80::3 103 broadcast
> > > > > frame-relay map ipv6 FEC0::123:2 102 broadcast
> > > > > frame-relay map ipv6 FEC0::123:3 103 broadcast
> > > > > frame-relay map ip 172.16.123.1 102
> > > > > frame-relay map ip 172.16.123.2 102 broadcast
> > > > > frame-relay map ip 172.16.123.3 103 broadcast
> > > > > no frame-relay inverse-arp
> > > > > !
> > > > > router rip
> > > > > version 2
> > > > > redistribute eigrp 200
> > > > > passive-interface default
> > > > > no passive-interface Serial0/0.123
> > > > > network 172.16.0.0
> > > > > neighbor 172.16.123.3
> > > > > neighbor 172.16.123.2
> > > > > default-metric 2
> > > > > no auto-summary
> > > > > !
> > > > > ipv6 router rip FRAME-123
> > > > > !
> > > > > -----------------------------------------------------
> > > > > R3#
> > > > > !
> > > > > ipv6 unicast-routing
> > > > > !
> > > > > interface Loopback603
> > > > > no ip address
> > > > > ipv6 address FEC0::103:1/125
> > > > > ipv6 rip FRAME-34 enable
> > > > > !
> > > > > interface Serial0
> > > > > no ip address
> > > > > encapsulation frame-relay
> > > > > no frame-relay inverse-arp
> > > > > frame-relay lmi-type ansi
> > > > > !
> > > > > interface Serial0.2 multipoint
> > > > > ip address 172.16.123.3 255.255.255.128
> > > > > ipv6 address FEC0::123:3/125
> > > > > ipv6 address FE80::3 link-local
> > > > > ipv6 rip FRAME-123 enable
> > > > > frame-relay map ipv6 FE80::2 301
> > > > > frame-relay map ipv6 FEC0::123:1 301 broadcast
> > > > > frame-relay map ipv6 FEC0::123:2 301
> > > > > frame-relay map ip 172.16.123.1 301 broadcast
> > > > > frame-relay map ip 172.16.123.2 301
> > > > > frame-relay map ip 172.16.123.3 301
> > > > > frame-relay map ipv6 FE80::1 301 broadcast
> > > > > no frame-relay inverse-arp
> > > > > !
> > > > > interface Serial0.4 point-to-point
> > > > > ip address 172.16.34.3 255.255.255.128
> > > > > ipv6 address FEC0::34:3/125
> > > > > ipv6 address FE80::3 link-local
> > > > > ipv6 rip FRAME-34 enable
> > > > > frame-relay interface-dlci 304
> > > > > !
> > > > > !
> > > > > ipv6 router rip FRAME-34
> > > > > redistribute connected metric 3 route-map Lv6
> > > > > redistribute rip FRAME-123 metric 2
> > > > > !
> > > > > ipv6 router rip FRAME-123
> > > > > redistribute connected metric 3 route-map Lv6
> > > > > redistribute rip FRAME-34 metric 2
> > > > > !
> > > > > !
> > > > > route-map Lv6 permit 10
> > > > > match interface Loopback603
> > > > > !
> > > > >
> > > > >
----------------------------------------------------------------
> > > > > R4#
> > > > > !
> > > > > ipv6 unicast-routing
> > > > > !
> > > > > interface Loopback604
> > > > > no ip address
> > > > > ipv6 address FEC0::104:1/126
> > > > > !
> > > > > interface Serial0
> > > > > ip address 172.16.34.4 255.255.255.128
> > > > > encapsulation frame-relay
> > > > > ipv6 address FEC0::34:4/125
> > > > > ipv6 address FE80::4 link-local
> > > > > ipv6 rip FRAME-34 enable
> > > > > frame-relay map ipv6 FE80::3 403 broadcast
> > > > > frame-relay map ip 172.16.34.3 403 broadcast
> > > > > frame-relay map ipv6 FEC0::34:3 403 broadcast
> > > > > no frame-relay inverse-arp
> > > > > frame-relay lmi-type ansi
> > > > > !
> > > > > ipv6 router rip FRAME-34
> > > > > redistribute connected metric 3 route-map Lv6
> > > > > !
> > > > > route-map Lv6 permit 10
> > > > > match interface Loopback604
> > > > > !
> > > > >
> > > > >
> > > > > R1 (sh ipv6 route).......
> > > > > R1#sh ipv rou
> > > > > IPv6 Routing Table - 11 entries
> > > > > Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
> > > > > U - Per-user Static route
> > > > > I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS -
> ISIS
> > > > > summary
> > > > > O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2
-
> > OSPF
> > > ext
> > > > > 2
> > > > > ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
> > > > > L FE80::/10 [0/0]
> > > > > via ::, Null0
> > > > > C FEC0::101:0/125 [0/0]
> > > > > via ::, Loopback601
> > > > > L FEC0::101:1/128 [0/0]
> > > > > via ::, Loopback601
> > > > > R FEC0::102:0/125 [120/4]
> > > > > via FE80::2, Serial0/0.123
> > > > > R FEC0::103:0/125 [120/4]
> > > > > via FE80::3, Serial0/0.123
> > > > > R FEC0::104:0/126 [120/3]
> > > > > via FE80::3, Serial0/0.123
> > > > > C FEC0::122:0/125 [0/0]
> > > > > via ::, FastEthernet0/0.30
> > > > > L FEC0::122:1/128 [0/0]
> > > > > via ::, FastEthernet0/0.30
> > > > > C FEC0::123:0/125 [0/0]
> > > > > via ::, Serial0/0.123
> > > > > L FEC0::123:1/128 [0/0]
> > > > > via ::, Serial0/0.123
> > > > > L FF00::/8 [0/0]
> > > > > via ::, Null0
> > > > >
> > > > >
> > > > >
> > > > > Dave Schulz,
> > > > > Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com >
> > > > >
> > > > >
> > >
> >
>



This archive was generated by hypermail 2.1.4 : Thu Dec 01 2005 - 09:12:08 GMT-3