Re: Re: 3550 QoS Marking

From: Ralph (Mandela@myrealbox.com)
Date: Mon Nov 21 2005 - 17:27:35 GMT-3


Hello V:

I agree with you. IP precedence has no relationship with CoS in this regard. IP precedence is a way of marking IP packets in layer 3. CoS is a method of marking layer 2 frames using ISL or 802.1q encapsulation, IP and non-IP traffic alike.

I also cannot see why the "mls qos cos 3" cannot be configured on an access port. The command actually classifies all "untagged" frames ingress on that port to the configured CoS value on the interface. It does not re-write the CoS value. It uses the internal cos-dscp map to classify the untagged frames on the access port.

Although ip-prec 3 and CoS 3 have the same internal dscp value, this behavior can be changed.

Here is a sample config:

R1(fa0/0)---------fa0/1(SW1)fa0/1-------------(fa0/0)R2
               
         --------------VLAN 12----------------

R1

interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 duplex auto
 speed auto
!
ip local policy route-map ICMP
!
access-list 100 permit icmp any any
!
route-map ICMP permit 10
 match ip address 100
 set ip precedence flash
!
!

R2:

interface Ethernet0/0
 ip address 1.1.1.2 255.255.255.0
 ip access-group 100 in
 half-duplex
!
access-list 100 permit icmp any any precedence flash
!

hostname SW1
!
mls qos
!
interface FastEthernet0/1
 switchport access vlan 12
 switchport mode access
 mls qos cos 3
 mls qos trust cos
!
interface FastEthernet0/2
 switchport access vlan 12
 switchport mode access
!
!
!
!
!
!
R1#ping 1.1.1.2 repeat 10

Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 1/2/4 ms
R1#

-----Original Message-----
From: "Venkataramanaiah.R" <vramanaiah@gmail.com>
To: Niche <jackyliu419@gmail.com>
Date: Mon, 21 Nov 2005 00:07:10 +0100
Subject: Re: 3550 QoS Marking

Sorry for catching up late on this thread, but just wanted to clarifiy
2 things here, because someone might read this archive later..

1) mls qos cos 3 can work in access port

2) mls qos cos does not set the precendence..

Please correct if i am wrong..

-V

On 11/15/05, Niche <jackyliu419@gmail.com> wrote:
> Hi there,
>
> "mls qos cos 3" will not kick-in cause your port is not a trunk port (and I
> assume that port is not connecting to a 7960). You can use class-default for
> marking remaining traffic to precedence 3.
>
> Cheers~
> Jacky
>
> On 11/15/05, Daniel Berlinski <Daniel.Berlinski@telecom.co.nz> wrote:
> >
> > Hi everyone.
> >
> > Will the following configs mark HTTP traffic coming from vlan 12 with
> > precedence 5 and mark the remaining traffic with precedence 3?
> >
> >
> >
> -----------------------------------------------------------------------------
> ---------------------------------------------
> > mls qos
> > access-list 170 permit tcp any any eq www
> >
> > class-map match-any HTTP
> > match access-group 170
> > class-map match-all VLAN12
> > match vlan 12
> > match class-map HTTP
> >
> > policy-map MARKING
> > class VLAN12
> > set ip precedence 5
> >
> > interface FastEthernet0/2
> > switchport access vlan 12
> > switchport mode access
> > mls qos cos 3
> > service-policy input MARKING
> >
> > Rack1SW1#sh mls qos inter fa0/2
> > FastEthernet0/2
> > Attached policy-map for Ingress: MARKING
> > trust state: not trusted
> > trust mode: not trusted
> > COS override: dis
> > default COS: 3
> > DSCP Mutation Map: Default DSCP Mutation Map
> > trust device: none
> >
> >
> -----------------------------------------------------------------------------
> ------------------------------------------------------------------
> >
> > From the documentation CD: "You cannot configure both port-based
> > classification and VLAN-based classification at the same time. When you
> > configure the match vlan vlan-list command, the class map becomes per-port
> > per-VLAN based. If you configure a policy map that contains both port-based
> > and VLAN-based class maps, the switch rejects the policy map when you
> attach
> > it to an interface"
> >
> > Will "mls qos cos 3" under the interface mark the remaining traffic with
> > precedence 3?
> >
> > Best regards
> >
> > This communication, including any attachments, is confidential. If you are
> > not the intended recipient, you should not read it - please contact me
> > immediately, destroy it, and do not copy or use any part of this
> > communication or disclose anything about it. Thank you. Please note that
> > this communication does not designate an information system for the
> purposes
> > of the Electronic Transactions Act 2002.
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Dec 01 2005 - 09:12:07 GMT-3