From: Schulz, Dave (DSchulz@dpsciences.com)
Date: Fri Nov 11 2005 - 17:15:02 GMT-3
Thanks to everyone for looking at this. This is solved, with a little
bit of research. The solution is below. By the way, I have found the
best explanation of the ntp authentication on the IE web site. You may
want to check it out as it has one of the best I've seen on this subject
......
http://www.internetworkexpert.com/resources/01700369.htm
The solution is.....
!
hostname R1
!
interface Ethernet0
ip address 192.168.150.100 255.255.255.0
!
interface Serial0
ip address 10.10.10.1 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
no ip mroute-cache
no fair-queue
frame-relay map ip 10.10.10.1 105
frame-relay map ip 10.10.10.5 105 broadcast
frame-relay map ip 10.10.10.6 106 broadcast
no frame-relay inverse-arp
!
ntp authentication-key 1 md5 cisco
ntp master 3
!
!
hostname R5
!
interface Serial0
ip address 10.10.10.5 255.255.255.0
ip pim sparse-mode
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.10.10.1 501 broadcast
frame-relay map ip 10.10.10.5 501
frame-relay map ip 10.10.10.6 501
no frame-relay inverse-arp
!
ntp authentication-key 1 md5 cisco
ntp authenticate
ntp trusted-key 1
ntp clock-period 17179785
ntp server 10.10.10.1 key 1
!
Dave Schulz,
Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com%20>
________________________________
From: Peter McCreesh [mailto:petermccreesh@gmail.com]
Sent: Friday, November 11, 2005 12:08 PM
To: Schulz, Dave
Cc: ccielab@groupstudy.com
Subject: Re: NTP authentication issue
Hi Dave,
i think you need the following on R5
ntp server 10.10.10.1 key 1
..Pete
On 11/11/05, Schulz, Dave <DSchulz@dpsciences.com> wrote:
I have NTP set up between two routers with the following configuration,
using a md5 password of "cisco". R1 is the master. Everything
synchronizes and is happy. However, I am purposely trying to break it,
by changing the password at R1 to "wellfleet" (all the old guys <like
me> will appreciate that). Unfortunately, R5 still synchronizes (and it
shouldn't). Am I missing something? Here are the configs.....
!
hostname R1
!
interface Ethernet0
ip address 192.168.150.100 255.255.255.0
!
interface Serial0
ip address 10.10.10.1 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
encapsulation frame-relay
no ip mroute-cache
no fair-queue
frame-relay map ip 10.10.10.1 105
frame-relay map ip 10.10.10.5 105 broadcast
frame-relay map ip 10.10.10.6 106 broadcast
no frame-relay inverse-arp
!
ntp authentication-key 1 md5 051C03032D4A420C1C11 7
ntp trusted-key 1
ntp master 3
!
!
hostname R5
!
interface Serial0
ip address 10.10.10.5 255.255.255.0
ip pim sparse-mode
encapsulation frame-relay
no fair-queue
frame-relay map ip 10.10.10.1 501 broadcast
frame-relay map ip 10.10.10.5 501
frame-relay map ip 10.10.10.6 501
no frame-relay inverse-arp
!
ntp authentication-key 1 md5 13061E010803 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 17179785
ntp server 10.10.10.1
!
Dave Schulz,
Email: dschulz@dpsciences.com <mailto:dschulz@dpsciences.com >
This archive was generated by hypermail 2.1.4 : Thu Dec 01 2005 - 09:12:06 GMT-3