From: Victor Cappuccio (cvictor@protokolgroup.com)
Date: Fri Oct 28 2005 - 06:36:46 GMT-3
Well this is part of the technology IMHO, I maybe need to start reading some
day RFCs (Can you indicate me please how to start doing that?) ;)
....IP Address What ever (primary)
R1 | ================Ethernet ============= R2
...Same Network Segment IP Address but Secondary|
R1 will be sending updates with a source of the primary interface: 02:35:41:
RIP: sending v2 update to 224.0.0.9 via Ethernet0 (192.168.0.1) -
R2 that is connected to the network 10.0.0.0 (same segment that R1, but by
the secondary address) will be receiving this updates, and because it does
not haves an Address in that range will discard the update..
05:32:16: RIP: ignored v2 update from bad source 192.168.0.1 on Ethernet0/0
Hope this is correct :D
R1#show run interface ethernet 0
Building configuration...
Current configuration : 112 bytes
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0 secondary
ip address 192.168.0.1 255.255.255.0
end
R1#show ip interface ethernet 0
Ethernet0 is up, line protocol is up
Internet address is 192.168.0.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Secondary address 10.10.10.1/24
R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 3 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is
Incoming update filter list for all interfaces is
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Ethernet0 2 2
Automatic network summarization is not in effect
Routing for Networks:
192.168.0.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
==================
R2#s
Interface IP-Address OK? Method Status
Protocol
Ethernet0/0 10.10.10.2 YES manual up
up
TokenRing0/0 unassigned YES unset administratively down
down
R2#ping 10.10.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 4/4/4 ms
R2#debug ip rip events
RIP event debugging is on
R2#debug ip rip database
RIP database events debugging is on
R2#
05:32:08: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (10.10.10.2) -
suppressing null update
05:32:16: RIP: ignored v2 update from bad source 192.168.0.1 on Ethernet0/0
R2#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 4 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Ethernet0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
05:32:16: RIP: ignored v2 update from bad source 192.168.0.1 on Ethernet0/0
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static
route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Ethernet0/0
R2#
R2#conf ter
Enter configuration commands, one per line. End with CNTL/Z.
R2(config)#router rip
05:35:17: RIP: sending v2 update to 224.0.0.9 via Ethernet0/0 (10.10.10.2) -
suppressing null updatep
R2(config-router)#no validate-update-source
R2(config-router)#^Z
R2#
R2#
R2#
05:35:25: %SYS-5-CONFIG_I: Configured from console by console
05:35:27: RIP: received v2 update from 6.1.1.6 on Ethernet0/0
05:35:27: RIP-DB: network_update with 1.0.0.0/8 succeeds
05:35:27: RIP-DB: adding 1.0.0.0/8 (metric 1) via 6.1.1.6 on Ethernet0/0 to
RIP database
05:35:27: RIP-DB: add 1.0.0.0/8 (metric 1) via 6.1.1.6 on Ethernet0/0
05:35:27: RIP-DB: Adding new rndb entry 1.0.0.0/8
05:35:27: RIP-DB: Created rip ndb summary entry for 1.0.0.0/8
05:35:27: RIP-DB: Adding new rndb entry 1.0.0.0/8
05:35:27: RIP-DB: network_update with 172.16.1.0/24 succeeds
05:35:27: RIP-DB: adding 172.16.1.0/24 (metric 1) via 6.1.1.6 on Ethernet0/0
to RIP database
05:35:27: RIP-DB: add 172.16.1.0/24 (metric 1) via 6.1.1.6 on Ethernet0/0
R2#deb
R2#debug
05:35:27: RIP-DB: Adding new rndb entry 172.16.1.0/24
05:35:27: RIP-DB: Created rip ndb summary entry for 172.16.0.0/16
05:35:27: RIP-DB: Adding new rndb entry 172.16.0.0/16
See the routes comming In :D
***************
Man I love Learning...
***************
----- Original Message -----
From: "Victor Cappuccio" <cvictor@protokolgroup.com>
To: "Nawaz, Ajaz" <Ajaz.Nawaz@bskyb.com>; "Scott Morris" <swm@emanon.com>;
<jnkmail4eva@yahoo.com>; <ccielab@groupstudy.com>
Sent: Friday, October 28, 2005 3:54 AM
Subject: Re: RIP question
> I know that Scott will give us the clear concept, but in the meanwhile
>
> http://www.groupstudy.com/archives/ccielab/200207/msg01224.html
>
> ----- Original Message -----
> From: "Nawaz, Ajaz" <Ajaz.Nawaz@bskyb.com>
> To: "Scott Morris" <swm@emanon.com>; <jnkmail4eva@yahoo.com>;
> <ccielab@groupstudy.com>
> Cc: "Victor Cappuccio" <cvictor@protokolgroup.com>
> Sent: Friday, October 28, 2005 3:44 AM
> Subject: RE: RIP question
>
>
> > Scott,
> >
> > So what are your thoughts about Victor's suggestion and no
> > validate-update-source?
> >
> > I have to confess I have not tested this myself yet - as you can see I'm
> > currently playing cathcup with gs reading.
> >
> > Ajaz Nawaz
> >
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Scott Morris
> > Sent: 25 October 2005 05:00
> > To: jnkmail4eva@yahoo.com; ccielab@groupstudy.com
> > Subject: RE: RIP question
> >
> > You need to actually understand what the network command does, and that
> will
> > help answer your question.
> >
> > The network command in RIP does not announce a route directly. What it
> does
> > is activate an interface as "participating" in the RIP process. That in
> > turn brings the specific route into the RIB and announces it out.
> However,
> > following that same logic, in order to activate an interface as
> > participating, you need to have an interface configured to do so.
> >
> > You aren't allowed to make things up. But, on the other hand, that's
why
> > (insert Deity-du-jour here) created loopback interfaces! ;)
> >
> > BGP is similar, but the route must exist in the routing table before it
> can
> > be brought into the BGP RIB.
> >
> > HTH,
> >
> > Scott
> >
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > jnkmail4eva@yahoo.com
> > Sent: Monday, October 24, 2005 9:01 PM
> > To: ccielab@groupstudy.com
> > Subject: RIP question
> >
> > I have playing aroud with RIP on two routers, A and B connected via
> ethernet
> > belonging to the same vlan.
> >
> > I want to see if I can announce a network from router A to B, even
though
> > there is no interface on A belonging to that network.
> >
> > ==========================================
> > router A
> > int e0/0
> > ip addres 192.168.1.1 255.255.255.0
> >
> > router rip
> > version 2
> > no auto-summary
> > network 192.168.0.0
> > netwrok 10.10.10.0
> > ==========================================
> > ==========================================
> > router B
> > int e0/0
> > ip addres 192.168.1.2 255.255.255.0
> >
> > router rip
> > version 2
> > no auto-summary
> > network 192.168.0.0
> > ==========================================
> > I don't see 10.0.0.0/8 on router B.
> > I tried introducing a loopback on A belonging to the 10.0.0.0/8 network
> but
> > i couldn't see the network on B.
> >
> > Is there anyway of having rip announcing the 10 network so it shows up
on
> > B's routing table learned via RIP.
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > -----------------------------------------
> > Information in this email may be privileged, confidential and is
intended
> > exclusively for the addressee. The views expressed may not be official
> > policy, but the personal views of the originator. If you have received
it
> > in error, please notify the sender by return e-mail and delete it from
> your
> > system. You should not reproduce, distribute, store, retransmit, use or
> > disclose its contents to anyone. Please note we reserve the right to
> > monitor all e-mail communication through our internal and external
> > networks.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Nov 06 2005 - 22:00:54 GMT-3