From: Leigh Harrison (ccileigh@gmail.com)
Date: Mon Sep 19 2005 - 07:43:03 GMT-3
Hey Bill,
I just cobbled this together using a 3750 and an 1841.
Test 1 config:-
3750
int f1/0/15
sw trunk enc do
sw trunk nat 234
sw mo trunk
int vlan 6
ip address 6.0.0.1 255.255.255.0
1841
int f0/1.6
enc dot 6
ip add 6.0.0.254 255.255.255.0
int f0/1.234
enc dot 234 nat
ip add 6.234.0.254 255.255.255.0
Test 2 config:-
3750
int f1/0/15
sw trunk enc do
sw trunk nat 234
sw mo trunk
no int vlan 6
int vlan 234
ip address 6.234.0.1 255.255.255.0
1841
int f0/1.6
enc dot 6
ip add 6.0.0.254 255.255.255.0
int f0/1.234
enc dot 234 nat
ip add 6.234.0.254 255.255.255.0
And it, erm, worked with no problems.. I did pings from the switch to
the .245 addresses.
It's odd that you're getting encapsulation errors - that's when it's got
the L3 address, but can't find the L2. From what I can see, your config
is sweet, might be worth grbbing a coffee, clearing the trunk config and
rebooting the sods!
LH
Bill.McKenzie@bisys.com wrote:
>I'm having some problems getting this configuration to work. I can't figure
>out why on a debug ip packet detail, when I ping to or from this I get
>encapsulation failed. When I delete the subinterfaces and assign the IP
>address to the physical interface and put the switchport in vlan 263, it is
>successful. After staring at my configuration for an hour , I can't see
>anything wrong with it. Can someone verify this?
>
>Switch1:
>interface FastEthernet0/6
> switchport trunk encapsulation dot1q
> switchport trunk native vlan 263
> switchport mode trunk
>
>
>R6:
>interface Ethernet0/0
> no ip address
> half-duplex
>!
>interface Ethernet0/0.6
> encapsulation dot1Q 6
> ip address 163.1.6.6 255.255.255.0
> no cdp enable
>!
>interface Ethernet0/0.263
> encapsulation dot1Q 263 native
> ip address 204.12.1.6 255.255.255.0
> no cdp enable
>
>Thanks in advance,
>Bill
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Oct 02 2005 - 14:40:15 GMT-3