From: chrlewis@cisco.com
Date: Sat Sep 17 2005 - 12:18:07 GMT-3
Yes, but you have to make sure you know the following. I' mnot asking
for help here, I know th answers, but know some folks find this topic
confusing, so I'm just listing a few issues to get clear on that I think
will help in the lab.
1. Let's say it is an access port we are looking at, and a packet comes
in marked with dscp 16
1. without global mls qos configured, what does the egress dscp get set
to
2. with trust dscp on the ingress interface, what does it get set to
3. with mls qos global and mls qos trust dscp set on the ingress, what
is the egress dscp.
Similar questions for a trunk port using trust cos, and trust dscp.
What makes the egress cos and dscp the same without explicit
configuration?
If you want to trust cos and re-mark it, but leave the dscp untouched,
what do you do?
Chris
-----Original Message-----
From: kumara.shunmugam@wipro.com [mailto:kumara.shunmugam@wipro.com]
Sent: Saturday, September 17, 2005 3:07 AM
To: Chris Lewis [chrlewis@cisco.com]; jackyliu419@gmail.com;
ccielab@groupstudy.com
Subject: RE: CAT 3550 switch again
I think the cos will only come to the picture when you are having a
trunk link.(dot1q or isl or even an IP telephone connected port).
Whether the switch is receiving cos or dscp or ip prec in the ingress,
it will first convert it to internal dscp for further internal
processes.( the cos-to-dscp, dscp mutations map or IpPrecedence-dscp map
are playing a major role here I believe ...
Shun
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
chrlewis@cisco.com
Sent: Friday, September 16, 2005 9:52 AM
To: Kumara Guru Shunmugam L (WI01 - Services); jackyliu419@gmail.com;
ccielab@groupstudy.com
Subject: RE: CAT 3550 switch again
Hi,
I verified this to be correct on a switch. For an access port if you use
set dscp in the policy-map, the dscp is set within the packet, set cos
does nothing in that configuration.
The key issue here I think is to be very familiar with the concept of
the internal DSCP, how it is set (either by classification and
policy-map set on ingress, or trust state), how it can be changed with
various maps, and changed for use within the switch, but transmitted
unaltered by the use of passthrough. The same goes for egress, how the
internal dscp is copied to the packet dscp and cos value, how that can
be altered by the use of maps and how passthrough affects things.
The 50 pages in the Flannagan book on Catalyst QoS is worth getting if
you want to fully grasp this stuff.
My 2 cents
Chris
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
kumara.shunmugam@wipro.com
Sent: Friday, September 16, 2005 2:42 AM
To: jackyliu419@gmail.com; ccielab@groupstudy.com
Subject: RE: CAT 3550 switch again
I think better we use set dscp command instead of using set cos in a
access port ??
Shun
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Niche
Sent: Friday, September 16, 2005 12:01 AM
To: ccielab@groupstudy.com
Subject: Re: CAT 3550 switch again
Hi,
May be you can try this,
Assume the incoming packet do not have any cos value pre-define,
mls qos
int fa0/1
wrr-queue bandwidth 4 3 2 1
wrr-queue cos-map 1 0 1 2 3
wrr-queue cos-map 2 4
wrr-queue cos-map 3 6 7
wrr-queue cos-map 4 5
int fa0/2
service-policy input icmp-cos
access-list 100 permit icmp any any
class-map icmp
match access-group 100
policy-map icmp-cos
class icmp
set cos 5
The 4th queue will be assigned 4/10 of the total bandwidth of the fa0/1
according to this configuration. "mls qos" in global configuration is a
must before any cos, dscp or ip precedence qos configuration go active.
If you want to go 1 step further, you can configure priority queue
(queue 4 is default priority queue) at int fa0/1 so all cos 5 packets
will be served before any other type of packets.
Please correct me if I get anything wrong =), I am still learning..
Cheers~
Jacky
On 9/15/05, chrlewis@cisco.com <chrlewis@cisco.com> wrote:
>
> Consider the following:
>
> Traffic classified in class cos gets a cos value of 5
>
> What does this mean?
> If the traffic coming in is not tagged with a .1q or ISL header what
> relevance does this have?
> The CoS value is actually determined by the internal DSCP value, so
> you need to determine how that internal DSCP is set.
>
> With wrr-queue cos-map 1 5 you are sending cos 5 (derived from
> internal
> DSCP) in to queue 1.
>
> With wrr-queue bandwidth you are giving 1/91 parts of the bandwidth
> with queue 1, is this what you want?
>
> As a further exercise, are you clear on how you would configure
> priority queueing for a different CoS on top of this?
>
> Good show commands to become familiar with are
>
> Show wrr-queue bandwidth
> Show wrr-queue cos-map
> And for extra credit know show mls qos map dscp-cos, this becomes
> useful when you have to configure the switch to set egress cos to a
> non-default value based off internal DSCP.
>
> Chris
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of Ahmed Ossama
> Sent: Thursday, September 15, 2005 5:31 AM
> To: ccielab@groupstudy.com
> Subject: CAT 3550 switch again
>
> Dear All,
>
> I am confused about some quality of service principles.
>
> 1st If I want to give ICMP traffic the higher priority ( for example),
> I have 3550 switch, the ingress port is fast 0/2 and the egress port
> fast 0/1.
>
> Shall I match the input packets with policy map then set the cos to 5
> then using wrr-queue bandwidth 1 30 30 30, wrr-queue cos-map 1 5
>
>
>
> Configuration will be as follow:
>
>
>
> interface FastEthernet0/1
>
> switchport access vlan 3
>
> switchport mode access
>
> no ip address
>
> wrr-queue bandwidth 1 30 30 30
>
> wrr-queue cos-map 1 5
>
> wrr-queue cos-map 2 1 2
>
> wrr-queue cos-map 3 0 3 4 6
>
> wrr-queue cos-map 4 7
>
> spanning-tree portfast
>
> !
>
>
>
> interface FastEthernet0/2
>
> switchport access vlan 3
>
> switchport mode access
>
> no ip address
>
> service-policy input cos
>
> end
>
> !
>
> Switch#sh policy-map cos
>
> Policy Map cos
>
> class cos
>
> set cos 5
>
>
>
>
>
> Or I must use a dscp -to-cos map and at the ingress set a dscp values
> as
> shown:
>
>
>
> interface FastEthernet0/2
>
> switchport access vlan 3
>
> switchport mode access
>
> no ip address
>
> service-policy input cos
>
> !
>
> Switch#show policy-map cos
>
> Policy Map cos
>
> class cos
>
> set ip dscp 5
>
> !
>
> mls qos map dscp-cos 45 to 5
>
>
>
> Or the two solutions are valid.
>
>
>
> Thanks ,
>
> ______________________________________________________________________
> _ Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> ______________________________________________________________________
> _ Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Oct 02 2005 - 14:40:15 GMT-3