Re: CAT 3550 switch again

From: Niche (jackyliu419@gmail.com)
Date: Fri Sep 16 2005 - 06:38:59 GMT-3


Hi,

I must say sorry cause I made some error in previous example and I have made
some modification,

from "wrr-queue bandwidth 4 3 2 1"
to "wrr-queue bandwidth 1 2 3 4"

There are 4 queues in wrr queueing, this command is to configure how much
bandwidth for each queue. The total bandwidth arragement will be the sum of
the numbers after the words "wrr-queue bandwidth".
1+2+3+4 = 10 (that means we have divided the total bandwidth (e.g. 100mb)
into 10 portions, eacf portion = 10mb). So according to our configuration,
queue 4 has 4/10 of the total bandwidth, that's 40mb

"wrr-queue cos-map 1 0 1 2 3"
"wrr-queue cos-map 2 4"
"wrr-queue cos-map 3 6 7"
"wrr-queue cos-map 4 5"

This is how we can assign each cos valued packet into appropiate wrr-queue,
according this configuration,
packet has been marked with cos value 0or1or2or3 will be assigned into
wrr-queue 1
packet has been marked with cos value 4 will be assigned into wrr-queue 2
packet has been marked with cos value 6or7 will be assigned into wrr-queue 3
packet has been marked with cos value 5 will be assigned into wrr-queue 4

"mls qos map cos-dscp"
This command actually is let us to configure a mapping according to the
incoming packet pre-defined cos value. cos --> dscp

e.g.
mls qos map cos-dscp 0 8 16 24 32 40 48 56

cos value = 0 will be map to dscp value 0
cos value = 1 will be map to dscp value 8
cos value = 2 will be map to dscp value 16
...
..
cos value = 7 will be map to dscp value 56

Cheers~
Jacky

On 9/16/05, Jens Petter Eikeland <jenseike@start.no> wrote:
>
> Hi ,
>
> I am not that familiar with how the wrr command works. I have tried to
> read
> the documentation, but did not understand it.
> Could you please describe what this command actually do for me..
>
> If you take your example under :
>
> wrr-queue bandwidth 4 3 2 1
> wrr-queue cos-map 1 0 1 2 3
> wrr-queue cos-map 2 4
> wrr-queue cos-map 3 6 7
> wrr-queue cos-map 4 5
>
> what do this actually do..
>
> I know also there are something similar called something like this :
>
> mls qos map cos-dscp
>
> can you please explain what this is to me?
>
> Jens Petter Eikeland
>
> -----Opprinnelig melding-----
> Fra: nobody@groupstudy.com [mailto:nobody@groupstudy.com] Pe vegne av
> Niche
> Sendt: 16. september 2005 09:01
> Til: ccielab@groupstudy.com
> Emne: Re: CAT 3550 switch again
>
> Hi,
>
> May be you can try this,
>
> Assume the incoming packet do not have any cos value pre-define,
>
> mls qos
>
> int fa0/1
> wrr-queue bandwidth 4 3 2 1
> wrr-queue cos-map 1 0 1 2 3
> wrr-queue cos-map 2 4
> wrr-queue cos-map 3 6 7
> wrr-queue cos-map 4 5
>
> int fa0/2
> service-policy input icmp-cos
>
> access-list 100 permit icmp any any
>
> class-map icmp
> match access-group 100
>
> policy-map icmp-cos
> class icmp
> set cos 5
>
> The 4th queue will be assigned 4/10 of the total bandwidth of the fa0/1
> according to this configuration. "mls qos" in global configuration is a
> must
> before any cos, dscp or ip precedence qos configuration go active.
>
> If you want to go 1 step further, you can configure priority queue (queue
> 4
> is default priority queue) at int fa0/1 so all cos 5 packets will be
> served
> before any other type of packets.
>
> Please correct me if I get anything wrong =), I am still learning..
>
> Cheers~
> Jacky
>
> On 9/15/05, chrlewis@cisco.com <chrlewis@cisco.com> wrote:
> >
> > Consider the following:
> >
> > Traffic classified in class cos gets a cos value of 5
> >
> > What does this mean?
> > If the traffic coming in is not tagged with a .1q or ISL header what
> > relevance does this have?
> > The CoS value is actually determined by the internal DSCP value, so you
> > need to determine how that internal DSCP is set.
> >
> > With wrr-queue cos-map 1 5 you are sending cos 5 (derived from internal
> > DSCP) in to queue 1.
> >
> > With wrr-queue bandwidth you are giving 1/91 parts of the bandwidth with
> > queue 1, is this what you want?
> >
> > As a further exercise, are you clear on how you would configure priority
> > queueing for a different CoS on top of this?
> >
> > Good show commands to become familiar with are
> >
> > Show wrr-queue bandwidth
> > Show wrr-queue cos-map
> > And for extra credit know show mls qos map dscp-cos, this becomes useful
> > when you have to configure the switch to set egress cos to a non-default
> > value based off internal DSCP.
> >
> > Chris
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Ahmed Ossama
> > Sent: Thursday, September 15, 2005 5:31 AM
> > To: ccielab@groupstudy.com
> > Subject: CAT 3550 switch again
> >
> > Dear All,
> >
> > I am confused about some quality of service principles.
> >
> > 1st If I want to give ICMP traffic the higher priority ( for example), I
> > have 3550 switch, the ingress port is fast 0/2 and the egress port fast
> > 0/1.
> >
> > Shall I match the input packets with policy map then set the cos to 5
> > then using wrr-queue bandwidth 1 30 30 30, wrr-queue cos-map 1 5
> >
> >
> >
> > Configuration will be as follow:
> >
> >
> >
> > interface FastEthernet0/1
> >
> > switchport access vlan 3
> >
> > switchport mode access
> >
> > no ip address
> >
> > wrr-queue bandwidth 1 30 30 30
> >
> > wrr-queue cos-map 1 5
> >
> > wrr-queue cos-map 2 1 2
> >
> > wrr-queue cos-map 3 0 3 4 6
> >
> > wrr-queue cos-map 4 7
> >
> > spanning-tree portfast
> >
> > !
> >
> >
> >
> > interface FastEthernet0/2
> >
> > switchport access vlan 3
> >
> > switchport mode access
> >
> > no ip address
> >
> > service-policy input cos
> >
> > end
> >
> > !
> >
> > Switch#sh policy-map cos
> >
> > Policy Map cos
> >
> > class cos
> >
> > set cos 5
> >
> >
> >
> >
> >
> > Or I must use a dscp -to-cos map and at the ingress set a dscp values as
> > shown:
> >
> >
> >
> > interface FastEthernet0/2
> >
> > switchport access vlan 3
> >
> > switchport mode access
> >
> > no ip address
> >
> > service-policy input cos
> >
> > !
> >
> > Switch#show policy-map cos
> >
> > Policy Map cos
> >
> > class cos
> >
> > set ip dscp 5
> >
> > !
> >
> > mls qos map dscp-cos 45 to 5
> >
> >
> >
> > Or the two solutions are valid.
> >
> >
> >
> > Thanks ,
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Oct 02 2005 - 14:40:15 GMT-3