From: Capt.Spock (capt.spock@gmail.com)
Date: Tue Aug 23 2005 - 20:24:03 GMT-3
Thanks chris! It was weird issue.
If I take out the below commands and put it again it worked. Does not
work again after a reboot.
bridge irb
Int bvi 1
ip address x.x.x.x
int eth0.1
bridge-group 1
int eth0.2
bridge-group 1
bridge 1 protocol ieee
bridge 1 route ip
Not sure if this is a bug so I am moving on once it works fine and not
bothering if it does not work again.
Thanks!
Spock
On 8/23/05, Chris Lewis (chrlewis) <chrlewis@cisco.com> wrote:
> Not sure I can debug your setup from here, but if the question is about
> getting eigrp adjacency to a BVI, it is possible.
>
> I have the following setup
>
> R5(E1/0)-------(E1/0)R1(E0/0)-------(E0/0)R6
>
> R1 is configured thus:
>
> interface Ethernet0/0
> no ip address
> bridge-group 1
> !
> interface Ethernet1/0
> no ip address
> bridge-group 1
> !
> interface BVI1
> ip address 136.1.136.1 255.255.255.0
> !
> router eigrp 100
> network 136.1.136.0 0.0.0.255
> no auto-summary
> !
> bridge 1 protocol ieee
> bridge 1 route ip
>
> R5 and R6 have their ethernet's in 136.1.136.0 subnet and have eigrp
> enabled on those interfaces.
>
> Neighbors are as follows:
>
> Router1#sho ip eigrp nei
> IP-EIGRP neighbors for process 100
> H Address Interface Hold Uptime SRTT RTO Q
> Seq
> (sec) (ms) Cnt
> Num
> 1 136.1.136.5 BV1 13 00:04:36 1 4500 0
> 3
> 0 136.1.136.6 BV1 11 00:18:57 92 552 0
> 2
>
> Router5(config-router)#do sho ip eigrp nei
> IP-EIGRP neighbors for process 100
> H Address Interface Hold Uptime SRTT RTO Q
> Seq
> (sec) (ms) Cnt
> Num
> 1 136.1.136.1 Et1/0 12 00:05:01 1 3000 0
> 3
> 0 136.1.136.6 Et1/0 12 00:05:02 391 2346 0
> 3
>
> Router6>sho ip eigrp nei
> IP-EIGRP neighbors for process 100
> H Address Interface Hold Uptime SRTT RTO Q
> Seq
> (sec) (ms) Cnt
> Num
> 1 136.1.136.5 Et0/0 10 00:05:30 1 3000 0
> 2
> 0 136.1.136.1 Et0/0 13 00:19:49 608 3648 0
> 2
>
> Your redistribution is probably not happening because the eigrp routes
> are not getting there. I'd try simplifying your config first, then doing
> a debug of ip eigrp and debug ip packet detail and look for retry
> exceeds and unroutables to see why packest are not exchanged to form
> neighbors.
>
> Chris
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Capt.Spock
> Sent: Tuesday, August 23, 2005 9:17 AM
> To: Group Study
> Subject: BVI and routing...
>
> Have a scenario where BVI is being used to connect to two EIGRP
> neighbors and not getting desired results.
>
> BB
> |
> E0.3
> R1-------E0.1(R6)E0.2------R3
> | |
> R2_________|
>
>
> BB, R6 are in RIP; R1,R2,R3,R6 are in EIGRP AS
> 100
>
> R6 has 3 subinterfaces for E0; E0.1 E0.2 E0.3. Created a BVI with
> E0.1 and E0.2.
>
> R6 cannot see R1 and R3 as EIGRP neighbors with BVI. R1 can ping BVI,
> and R3. vice-versa. Have redistributed RIP to EIGRP on R6. The
> Redistribution is not hapenning.
>
> R6#sh ip eigrp nei
> IP-EIGRP neighbors for process 100
>
> R1#sh ip eigrp nei
> IP-EIGRP neighbors for process 100
> H Address Interface Hold Uptime SRTT RTO Q
> Seq T
> (sec) (ms) Cnt
> Num
> 0 136.1.136.3 Et0/0 11 00:29:20 4 200 0
> 78
>
> R3#sh ip eigrp nei
> IP-EIGRP neighbors for process 100
> H Address Interface Hold Uptime SRTT RTO Q
> Seq T
> (sec) (ms) Cnt
> Num
> 1 136.1.136.1 Et0/1 13 00:29:44 1 200 0
> 32
> 0 136.1.23.2 Se0/0 13 00:48:49 2 200 0
> 32
>
> R6 Config.................................
>
> bridge irb
> interface Ethernet0
> no ip address
> no ip route-cache
> no ip mroute-cache
> media-type 10BaseT
> !
> interface Ethernet0.16
> encapsulation dot1Q 16
> no ip route-cache
> no ip mroute-cache
> bridge-group 1
> !
> interface Ethernet0.36
> encapsulation dot1Q 36
> no ip route-cache
> no ip mroute-cache
> bridge-group 1
> !
> interface Ethernet0.63
> encapsulation dot1Q 63
> ip address 204.12.1.6 255.255.255.0
> no ip route-cache
> no ip mroute-cache
>
> router eigrp 100
> redistribute rip metric 1500 10 255 1 100 network 136.1.136.6 0.0.0.0
> network 150.1.6.0 0.0.0.255 no auto-summary no eigrp
> log-neighbor-changes !
> router rip
> version 2
> redistribute eigrp 100 metric 2
> network 54.0.0.0
> network 204.12.1.0
> no auto-summary
>
> interface BVI1
> ip address 136.1.136.6 255.255.255.0
>
> bridge 1 protocol ieee
> bridge 1 route ip
>
> Any help is appreciated...
>
> Thanks!
> Spock
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:20 GMT-3