From: Chris Lewis \(chrlewis\) (chrlewis@cisco.com)
Date: Mon Aug 22 2005 - 19:36:13 GMT-3
Not sure what you have going on, but pputting a simplified version of
your config on a 12.3 router does not give the same results.
My config:
interface Loopback0
ip address 90.90.90.1 255.255.255.0
!
interface Loopback1
ip address 90.90.91.1 255.255.255.0
!
interface Loopback2
ip address 90.90.92.1 255.255.255.0
!
interface Loopback3
ip address 90.90.93.1 255.255.255.0
!
interface Loopback4
ip address 90.90.94.1 255.255.255.0
!
interface Loopback5
ip address 90.90.95.1 255.255.255.0
!
interface Loopback6
ip address 90.90.96.1 255.255.255.0
!
interface Loopback7
ip address 90.90.97.1 255.255.255.0
!
interface Loopback8
ip address 90.90.98.1 255.255.255.0
!
interface Loopback9
ip address 90.90.99.1 255.255.255.0
!
interface Loopback10
ip address 90.90.100.1 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.136.1 255.255.255.192
!
access-list 1 permit 90.90.96.0 0.0.3.255
!
route-map LOOP permit 10
match ip address 1
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute connected subnets route-map LOOP
network 172.16.136.1 0.0.0.0 area 0
Which gives the following results as expected.
Router1(config-router)#do sho ip ospf data
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link
count
2.2.2.2 2.2.2.2 236 0x80000001 0x009B75 1
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
90.90.96.0 2.2.2.2 235 0x80000001 0x00B4CE 0
90.90.97.0 2.2.2.2 235 0x80000001 0x00A9D8 0
90.90.98.0 2.2.2.2 235 0x80000001 0x009EE2 0
90.90.99.0 2.2.2.2 235 0x80000001 0x0093EC 0
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Schulz, Dave
Sent: Monday, August 22, 2005 1:38 PM
To: ccielab@groupstudy.com
Subject: OSPF Redistribution with route-map
Greetings, group -
I am trying to redistribute loopback interfaces (specific ones) with a
route-map, and having a strange occurrence.
Here is the configuration:
R3#sh run
!
interface Loopback0
ip address 90.90.90.1 255.255.255.0
!
interface Loopback1
ip address 90.90.91.1 255.255.255.0
!
interface Loopback2
ip address 90.90.92.1 255.255.255.0
!
interface Loopback3
ip address 90.90.93.1 255.255.255.0
!
interface Loopback4
ip address 90.90.94.1 255.255.255.0
!
interface Loopback5
ip address 90.90.95.1 255.255.255.0
!
interface Loopback6
ip address 90.90.96.1 255.255.255.0
!
interface Loopback7
ip address 90.90.97.1 255.255.255.0
!
interface Loopback8
ip address 90.90.98.1 255.255.255.0
!
interface Loopback9
ip address 90.90.99.1 255.255.255.0
!
interface Loopback10
ip address 90.90.100.1 255.255.255.0
!
interface Serial0
ip address 192.168.1.3 255.255.255.0
encapsulation frame-relay
ip ospf message-digest-key 1 md5 ipexpert ip ospf priority 0 no arp
frame-relay frame-relay map ip 192.168.1.2 302 broadcast frame-relay
map ip 192.168.1.4 302 broadcast no frame-relay inverse-arp
frame-relay lmi-type ansi !
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
no auto-cost
area 0 authentication message-digest
redistribute connected subnets route-map LOOP network 192.168.1.0
0.0.0.255 area 0 !
access-list 1 permit 90.90.96.0 0.0.3.255 log route-map LOOP permit 10
match ip address 1 set metric 10 !
Here is the sh ip ospf database:
R3# sh ip ospf data
OSPF Router with ID (2.2.2.2) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link
count
1.1.1.1 1.1.1.1 700 0x80000024 0xD3EF 1
2.2.2.2 2.2.2.2 167 0x80000002 0xDFFA 1
192.168.1.4 192.168.1.4 480 0x80000020 0x2DEF 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
192.168.1.2 1.1.1.1 55 0x80000020 0x30FB
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
90.90.96.0 2.2.2.2 18 0x80000001 0x503D 0
90.90.97.0 2.2.2.2 18 0x80000001 0x4547 0
90.90.98.0 2.2.2.2 18 0x80000001 0x3A51 0
90.90.99.0 2.2.2.2 18 0x80000001 0x2F5B 0
90.90.100.0 90.90.100.1 232 0x80000001 0xFF6D 0
R3#
Looks good, except for one item....the access list was intended to allow
only subnets 96 through 99 (which it does)....but I am also getting the
100 subnet!? I can't figure out why this is not being denied.
And....why is it showing up from the router-id 90.90.100.1, when I have
specifically set the router-id to 2.2.2.2. Very strange, eh?
Dave
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:19 GMT-3