From: Gustavo Novais (gustavo.novais@novabase.pt)
Date: Thu Aug 18 2005 - 23:05:54 GMT-3
Hello group!
Sorry to be resuming a not so old discussion, but I 've doing tests with
ip multicast helper -map, and I just can't see it working!
For what I can see on the remote router the broadcasts are received
untouched, and do not see any counts on the ACL specified on either of
multicast helper maps
I'm testing this through this set of commands on a 3550 that I have on
the sender network
3550------fa0/0-(R8)-Serial0/0------Serial0/0-(R7)-fa0/0
On 3550 I'm using rtr to generate udp broadcast packets with port 2000
rtr 1
type udpEcho dest-ipaddr 139.10.67.255 dest-port 2000 control disable
timeout 2000
frequency 3
rtr schedule 1 start-time now
Network of R7 Fa0/0 is 139.10.67.0
Network of 3550 and R8 is 139.10.89.0
For I could understand from the examples I saw the multicast helper
command goes to the routers INPUT interface (both). So I have:
UDP to port 2000 and group 224.78.78.78
on R8
!
ip multicast-routing
!
!
interface Loopback0
ip address 139.10.8.8 255.255.255.0
!
interface FastEthernet0/0
ip address 139.10.89.8 255.255.255.0
ip directed-broadcast
ip pim dense-mode
ip multicast helper-map broadcast 224.78.78.78 ACL-TRAFFIC
!
interface Serial0/0
mtu 1024
ip address 139.10.87.8 255.255.255.0
ip router isis
ip pim dense-mode
no ip mroute-cache
!
!
ip forward-protocol udp 2000
!
!
!
ip access-list extended ACL-TRAFFIC
permit udp any any eq 2000 log-input
deny udp any any
!
!
end
R8#
and on the receiver side:
R7
!
ip multicast-routing
!
!
interface FastEthernet0/0
ip address 139.10.67.7 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
mtu 1024
ip address 139.10.87.7 255.255.255.0
ip directed-broadcast
ip pim sparse-dense-mode
ip multicast helper-map 224.78.78.78 139.10.67.255 ACL-TRAFFIC
ip igmp join-group 224.78.78.78
clockrate 2000000
!
ip forward-protocol udp 2000
!
!
!
ip access-list extended ACL-TRAFFIC
permit udp any any eq 2000
deny udp any any
!
What I see on debug ip packet detail is
*Mar 3 00:38:20.418: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:20.418: IP: s=139.10.89.20 (Serial0/0), d=139.10.67.255
(FastEthernet0/0), len 44, rcvd 5
*Mar 3 00:38:20.418: UDP src=58051, dst=2000
*Mar 3 00:38:20.418: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:23.418: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:23.418: IP: s=139.10.89.20 (Serial0/0), d=139.10.67.255
(FastEthernet0/0), len 44, rcvd 5
*Mar 3 00:38:23.418: UDP src=51984, dst=2000
*Mar 3 00:38:23.418: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:26.415: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:26.419: IP: s=139.10.89.20 (Serial0/0), d=139.10.67.255
(FastEthernet0/0), len 44, rcvd 5
*Mar 3 00:38:26.419: UDP src=58157, dst=2000
*Mar 3 00:38:26.419: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:29.416: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via RIB
*Mar 3 00:38:29.416: IP: s=139.10.89.20 (Serial0/0), d=139.10.67.255
(FastEthernet0/0), len 44, rcvd 5
*Mar 3 00:38:29.420: UDP src=55618, dst=2000
*Mar 3 00:38:29.420: IP: tableid=0, s=139.10.89.20 (Serial0/0),
d=139.10.67.255 (FastEthernet0/0), routed via
As I said... no match on access-lists ACL-TRAFFIC
Am I doing anything wrong?
What should I see on this output?
Where should I see it working?
Any help is welcome
Thanks and sorry for picking up this matter again, but it is
"#%!"#%|"|!&"&!/ me!
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:19 GMT-3